Page MenuHome

Blender 3.3.0 alpha crashing at Ubuntu 20.04 LTS in VMWare
Closed, ArchivedPublic

Description

System Information
Operating system:
Graphics card:

Blender Version
Broken: 3.3.0 Alpha
Worked: 3.2.0

Short description of error
Blender 3.3.0 alpha shuts down at startup with a crash at Ubuntu 20.04 LTS in a vmware installation.

Blender 3.2.0 works fine at the same Ubuntu vm. And Blender 3.3.0 works fine at Ubuntu 22.04 LTS

Exact steps for others to reproduce the error

I have none. Sorry. I cannot send my VMWare installation. This would be 60 Gb :)

The issue is about this post at devtalk: https://devtalk.blender.org/t/blender-3-3-0-alpha-crashing-at-ubuntu-20-04-lts-in-vmware/24319

All i can provide is the crash log and the console output at start up to the crash.

crashlog.txt

backtrace
./blender(BLI_system_backtrace+0x20) [0xc378210]
./blender() [0x11dfc4a]
/lib/x86_64-linux-gnu/libc.so.6(+0x430c0) [0x7f6e4a42b0c0]
./blender(GPU_shader_get_builtin_block+0) [0xadaf740]
./blender() [0x19393fe]
./blender(DRW_shgroup_create+0x1d) [0x193b55d]
./blender(OVERLAY_background_cache_init+0xae) [0x19cba0e]
./blender() [0x1978f9d]
./blender() [0x1933b61]
./blender(DRW_draw_render_loop_ex+0x17f) [0x19364df]
./blender(view3d_main_region_draw+0x8f) [0x2523d1f]
./blender(ED_region_do_draw+0x841) [0x1c6c271]
./blender(wm_draw_update+0x7a3) [0x17a4553]
./blender(WM_main+0x30) [0x17a1280]
./blender(main+0x322) [0x10db512]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0x7f6e4a40c0b3]
./blender() [0x11dc52c]

Python backtrace

Console output:

./blender
Warning: Could not find a matching GPU name. Things may not behave as expected.
Detected OpenGL configuration:
Vendor: VMware, Inc.
Renderer: SVGA3D; build: RELEASE;  LLVM;
ERROR (gpu.shader): overlay_background VertShader: 
      | 
   17 | #define depthCubeArray samplerCubeArray
      | 
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | 
   15 | #define depth2DMSArray sampler2DMSArray
      | 
      | Error: initializer of type int cannot be assigned to variable of type uint
      | 
   14 | #define depth2DMS sampler2DMS
      | 
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | 
   15 | #define depth2DMSArray sampler2DMSArray
      | 
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | 
   17 | #define depthCubeArray samplerCubeArray
      | 
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint

ERROR (gpu.shader): overlay_background FragShader: 
      | 
   17 | #define depthCubeArray samplerCubeArray
      | 
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | 
   15 | #define depth2DMSArray sampler2DMSArray
      | 
      | Error: initializer of type int cannot be assigned to variable of type uint
      | 
   14 | #define depth2DMS sampler2DMS
      | 
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | 
   15 | #define depth2DMSArray sampler2DMSArray
      | 
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | 
   17 | #define depthCubeArray samplerCubeArray
      | 
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint
      | Error: initializer of type int cannot be assigned to variable of type uint

Writing: /tmp/blender.crash.txt
Speicherzugriffsfehler (Speicherabzug geschrieben)
x@ubuntu:~/Blender/blender-3.3.0-alpha+master.b46825545325-linux.x86_64-release$

Event Timeline

I cannot reproduce any issues in my Ubuntu 20.04 VM with the current master and I have not experienced any crashes in the past weeks either. I've tested this with developer builds and the buildbot build blender-3.3.0-alpha+master.08a39d32a988-linux.x86_64-release.

Many thanks for checking. I had meanwhile also updated the mesa drivers. But no luck. Seems that it is simply time to let go and move on with the next higher Ubuntu version.

Robert Guetzkow (rjg) closed this task as Archived.May 11 2022, 9:29 AM

I will close the ticket then, because officially this setup is not supported and it appears to be an issue with the software rendering.

Thanks for investigating anyways :)