Page MenuHome
Feed Advanced Search

Today

Jeroen Bakker (jbakker) added a comment to T93601: Eevee AOV passes have inacurate colour.

I have been looking into this issue today. It seems like an error that only happens when using render layers. I haven't been able to pinpoint the root cause, but doesn't seems to be the aa sampling.

Mon, Jan 17, 8:59 AM · BF Blender (3.1), EEVEE & Viewport
Pratik Borhade (PratikPB2123) changed the status of T94936: Subdivision: GPU option without Use Limit Surface collapses geometry from Needs Triage to Confirmed.
Mon, Jan 17, 8:28 AM · EEVEE & Viewport, BF Blender

Yesterday

Jesse Yurkovich (deadpin) added a comment to T94881: Subdivision: GPU Subdivision shows corrupt geometry on high polycount objects.

I also cannot reproduce when using a 1070 nVidia card. However, a very old AMD FirePro W2100 shows what's been demonstrated here so perhaps is related to AMD (or at least the older ones).

Sun, Jan 16, 10:53 PM · EEVEE & Viewport, BF Blender
Igor Melo (igoracmelo) added a comment to T94209: Viewport artifacts, slowdown, and crashing on Arch Linux w/ Intel graphics after driver update.

I'm having a very similar issue with Manjaro and mesa 21.
Including these huge artifacts when splitting the 3d view.

Sun, Jan 16, 6:00 PM · EEVEE & Viewport, BF Blender
Kévin Dietrich (kevindietrich) changed the status of T94952: When GPU subdivision is enabled, normal maps don't render correctly in Eevee from Needs Triage to Confirmed.
Sun, Jan 16, 3:15 PM · Modeling, EEVEE & Viewport, BF Blender
slowburn (slowburn) added projects to T94952: When GPU subdivision is enabled, normal maps don't render correctly in Eevee: EEVEE & Viewport, Modeling.
Sun, Jan 16, 2:14 PM · Modeling, EEVEE & Viewport, BF Blender
Garek (Garek) added a comment to T92890: The display will be damaged when the node editor in Fullscreen Area mode (ctrl alt spacebar).

Doesn't happen in 2.92 though.

Sun, Jan 16, 10:24 AM · BF Blender, EEVEE & Viewport
Garek (Garek) merged T94949: Error in UI nodes when switching on fullscreen area into T92890: The display will be damaged when the node editor in Fullscreen Area mode (ctrl alt spacebar).
Sun, Jan 16, 10:03 AM · BF Blender, EEVEE & Viewport
Kévin Dietrich (kevindietrich) closed T94865: Crash when switching to texture paint workspace on models with a subdivision modifier as Resolved by committing rBbc66cd986874: Fix T94865: GPU subdiv crash switching to texpaint area.
Sun, Jan 16, 8:43 AM · Sculpt, Paint & Texture, Modeling, EEVEE & Viewport, BF Blender
Garek (Garek) merged T94939: Crash upon showing rig in 3D-viewport into T94726: Segfault with GPU subdivision on a custom bone shape.
Sun, Jan 16, 7:25 AM · EEVEE & Viewport, Modeling, BF Blender
Jesse Yurkovich (deadpin) changed the status of T94921: Subdivision: GPU option does not take into account Auto smooth angle from Needs Triage to Confirmed.
Sun, Jan 16, 7:05 AM · EEVEE & Viewport, BF Blender

Sat, Jan 15

Pratik Borhade (PratikPB2123) renamed T93014: Blender crash on combining textures (intel) from Blender Crash to Blender crash on combining textures (intel).
Sat, Jan 15, 7:37 PM · EEVEE & Viewport, BF Blender
Pratik Borhade (PratikPB2123) changed the status of T93014: Blender crash on combining textures (intel) from Needs Triage to Confirmed.

Thanks @Jake (Welp) . Will confirm for now.

Sat, Jan 15, 7:34 PM · EEVEE & Viewport, BF Blender
Garek (Garek) added a project to T94936: Subdivision: GPU option without Use Limit Surface collapses geometry: EEVEE & Viewport.
Sat, Jan 15, 6:47 PM · EEVEE & Viewport, BF Blender
Garek (Garek) added a comment to T94881: Subdivision: GPU Subdivision shows corrupt geometry on high polycount objects.

Also another note: it's possible issue shown only with loose geometry such as Suzanne (but not always), deleting eyes for her didn't trigger issue. All other cases without loose geometry that I tested but later deleted (don't want to upload 200+ mb file) maybe just T94936.

Sat, Jan 15, 6:46 PM · EEVEE & Viewport, BF Blender
Garek (Garek) updated the task description for T94881: Subdivision: GPU Subdivision shows corrupt geometry on high polycount objects.
Sat, Jan 15, 6:43 PM · EEVEE & Viewport, BF Blender
Garek (Garek) added a comment to T94881: Subdivision: GPU Subdivision shows corrupt geometry on high polycount objects.

I experimented with Advanced options of modifier later at the time and was convinced it's same bug but apparently unchecking Use Limit Surface is separate bug that triggers on geometry even with low polycount. I mistaken them since this bug sometimes collapses geometry too. I filed a separate bugreport T94936.
To note: with this bug when geometry disappears viewport doesn't lag as if there is no geometry at all (it takes me dozens of seconds to add modifier).

Sat, Jan 15, 6:32 PM · EEVEE & Viewport, BF Blender
Richard (Meniac404) added a comment to T93680: Blender 3.0 is crashing when creating hair particle system (Windows, Intel).

try to download the daily builds

Sat, Jan 15, 7:12 AM · EEVEE & Viewport, BF Blender
Kévin Dietrich (kevindietrich) closed T94918: Subdivision: EEVEE/Workbench with GPU option uses viewport level instead of render as Resolved by committing rB9664cc91f338: Fix T94918: GPU subdivision uses viewport levels for final render.
Sat, Jan 15, 1:37 AM · EEVEE & Viewport, BF Blender

Fri, Jan 14

Jeroen Bakker (jbakker) closed T89553: GPU: Push Constants, a subtask of T89525: Migrate OpenGL Shaders to Vulkan., as Archived.
Fri, Jan 14, 10:41 PM · EEVEE & Viewport, BF Blender
Jeroen Bakker (jbakker) closed T89553: GPU: Push Constants as Archived.

Replaced by GPUShaderCreateInfo

Fri, Jan 14, 10:41 PM · EEVEE & Viewport, BF Blender
Jeroen Bakker (jbakker) abandoned D11843: Fix T89684: GPU builtin uniforms refactor..

Replaced by GPUShaderCreateInfo

Fri, Jan 14, 10:40 PM · EEVEE & Viewport
Jeroen Bakker (jbakker) closed T89684: GPU: Builtin Uniforms Refactor, a subtask of T89525: Migrate OpenGL Shaders to Vulkan., as Archived.
Fri, Jan 14, 10:39 PM · EEVEE & Viewport, BF Blender
Jeroen Bakker (jbakker) closed T89684: GPU: Builtin Uniforms Refactor as Archived.

Replaced by GPUShaderCreateInfo

Fri, Jan 14, 10:39 PM · EEVEE & Viewport, BF Blender
Jeroen Bakker (jbakker) abandoned D11758: GPU: Push Constants..

GPUShaderCreateInfo uses a different approach better matching how we want to support other backends

Fri, Jan 14, 10:38 PM · EEVEE & Viewport
Jesse Yurkovich (deadpin) updated subscribers of T94918: Subdivision: EEVEE/Workbench with GPU option uses viewport level instead of render.

CC @Kévin Dietrich (kevindietrich) - This one is somewhat different than the Cycles behavior, maybe an easier fix here.

Fri, Jan 14, 8:54 PM · EEVEE & Viewport, BF Blender
Garek (Garek) added a project to T94921: Subdivision: GPU option does not take into account Auto smooth angle: EEVEE & Viewport.
Fri, Jan 14, 8:54 PM · EEVEE & Viewport, BF Blender
Jesse Yurkovich (deadpin) changed the status of T94919: Subdivision: different shading with GPU option enabled from Needs Triage to Confirmed.

This may just be due to how Blender calculates the normals vs. OpenSubDiv. Confirming for now at default priority.

Fri, Jan 14, 8:46 PM · EEVEE & Viewport, BF Blender
Jesse Yurkovich (deadpin) changed the status of T94918: Subdivision: EEVEE/Workbench with GPU option uses viewport level instead of render from Needs Triage to Confirmed.
Fri, Jan 14, 8:45 PM · EEVEE & Viewport, BF Blender
Garek (Garek) added a project to T94919: Subdivision: different shading with GPU option enabled: EEVEE & Viewport.
Fri, Jan 14, 8:39 PM · EEVEE & Viewport, BF Blender
Garek (Garek) added a project to T94918: Subdivision: EEVEE/Workbench with GPU option uses viewport level instead of render: EEVEE & Viewport.
Fri, Jan 14, 8:23 PM · EEVEE & Viewport, BF Blender
Bilal (Kooale325) added a comment to T93680: Blender 3.0 is crashing when creating hair particle system (Windows, Intel).

@Jake (Welp) submitted the fix (D13806) so I think we can confirm this report.

Also, problem is more related to EEVEE & Viewport module and not #platform:_windows so replacing the tag

Fri, Jan 14, 2:47 PM · EEVEE & Viewport, BF Blender
Kévin Dietrich (kevindietrich) changed the status of T94881: Subdivision: GPU Subdivision shows corrupt geometry on high polycount objects from Needs Triage to Needs Information from Developers.

I cannot reproduce (using an NVidia card). @Jeroen Bakker (jbakker) can you try to reproduce this on an AMD card, please?

Fri, Jan 14, 12:14 PM · EEVEE & Viewport, BF Blender
Philipp Oeser (lichtwerk) updated the task description for T94886: Custom bone shape disappears if going to editmode on the custom shape object.
Fri, Jan 14, 9:54 AM · EEVEE & Viewport, Animation & Rigging, BF Blender
Philipp Oeser (lichtwerk) renamed T94886: Custom bone shape disappears if going to editmode on the custom shape object from Custom bone object to Custom bone shape disappears if going to editmode on the custom shape object.
Fri, Jan 14, 9:51 AM · EEVEE & Viewport, Animation & Rigging, BF Blender
Philipp Oeser (lichtwerk) triaged T94886: Custom bone shape disappears if going to editmode on the custom shape object as High priority.

Caused by rB594656e7a39d: Fix T93525: Crash with curve/text armature bone gizmo

Fri, Jan 14, 9:50 AM · EEVEE & Viewport, Animation & Rigging, BF Blender
Philipp Oeser (lichtwerk) triaged T94726: Segfault with GPU subdivision on a custom bone shape as High priority.

It wasnt really clear if T94871 was a duplicate (I think it is), but will set this to High prio as well...

Fri, Jan 14, 9:48 AM · EEVEE & Viewport, Modeling, BF Blender

Thu, Jan 13

Nathan Vegdahl (cessen) added a comment to T94001: Custom OCIO "Displays" don't work..

No, the OCIO we ship is 2.0.0, there have been no updates to it in recent weeks/months.

Thu, Jan 13, 8:57 PM · EEVEE & Viewport, BF Blender
Nathan Vegdahl (cessen) reopened T94001: Custom OCIO "Displays" don't work. as "Needs Information from Developers".
Thu, Jan 13, 8:55 PM · EEVEE & Viewport, BF Blender
Ray molenkamp (LazyDodo) added a comment to T94001: Custom OCIO "Displays" don't work..

@Jeroen Bakker (jbakker) Yes, I can build locally.

On my local build, everything seems to work correctly both with and without your patch. It's possible that OCIO was already upgraded in the Blender repo (in the OCIO github issue I linked above, it looks like they already had a fix upstream...?).

Thu, Jan 13, 8:47 PM · EEVEE & Viewport, BF Blender
Nathan Vegdahl (cessen) closed T94001: Custom OCIO "Displays" don't work. as Resolved.
Thu, Jan 13, 8:36 PM · EEVEE & Viewport, BF Blender
Nathan Vegdahl (cessen) added a comment to T94001: Custom OCIO "Displays" don't work..

Yes, it appear to already be fixed in (at least) the most recent 3.1 alpha builder.blender.org builds. So I think we can close this as fixed.

Thu, Jan 13, 8:35 PM · EEVEE & Viewport, BF Blender
Nathan Vegdahl (cessen) added a comment to T94001: Custom OCIO "Displays" don't work..

@Jeroen Bakker (jbakker) Yes, I can build locally.

Thu, Jan 13, 8:18 PM · EEVEE & Viewport, BF Blender
Garek (Garek) added a comment to T94871: Crash on production file due to OpenSubdiv OpenGL backend.

Can confirm at least T94726 is at work as cleaning up lib/char/sprite/sprite.blend to a single bone still makes it crash when that bone is with custom shape.
030_0020_A.lighting.blend was not showing issues when unlinking to a set of objects without bones as far as I tested.

Thu, Jan 13, 6:45 PM · BF Blender (3.1), EEVEE & Viewport, Render & Cycles
Diogo Valadares Reis dos Santos (DiogoX2) updated the task description for T93440: Viewport performance drops drastically after switching from atributte visualization to solid view.
Thu, Jan 13, 5:42 PM · EEVEE & Viewport, BF Blender
Garek (Garek) renamed T94881: Subdivision: GPU Subdivision shows corrupt geometry on high polycount objects from Subdivision: to Subdivision: GPU Subdivision shows corrupt geometry on high polycount objects.
Thu, Jan 13, 3:10 PM · EEVEE & Viewport, BF Blender
Garek (Garek) added a project to T94881: Subdivision: GPU Subdivision shows corrupt geometry on high polycount objects: EEVEE & Viewport.

Will not confirm myself on the off chance it's some driver/GPU issue or something.

Thu, Jan 13, 3:08 PM · EEVEE & Viewport, BF Blender
Kévin Dietrich (kevindietrich) added a comment to T94871: Crash on production file due to OpenSubdiv OpenGL backend.

Note, the bug can be triggered by loading lib/char/sprite/sprite.blend, which is a much simpler file. I think the issue is the same as T94726: Segfault with GPU subdivision on a custom bone shape, although it crashes in two different places.

Thu, Jan 13, 12:12 PM · BF Blender (3.1), EEVEE & Viewport, Render & Cycles
Dalai Felinto (dfelinto) updated the task description for T94871: Crash on production file due to OpenSubdiv OpenGL backend.
Thu, Jan 13, 11:19 AM · BF Blender (3.1), EEVEE & Viewport, Render & Cycles
Dalai Felinto (dfelinto) assigned T94871: Crash on production file due to OpenSubdiv OpenGL backend to Kévin Dietrich (kevindietrich).
Thu, Jan 13, 11:18 AM · BF Blender (3.1), EEVEE & Viewport, Render & Cycles
Dalai Felinto (dfelinto) changed the status of T94871: Crash on production file due to OpenSubdiv OpenGL backend from Needs Triage to Confirmed.

Kevin confirmed the issue in his computer as well, so a bug it is :)

Thu, Jan 13, 11:18 AM · BF Blender (3.1), EEVEE & Viewport, Render & Cycles
Dalai Felinto (dfelinto) updated the task description for T94871: Crash on production file due to OpenSubdiv OpenGL backend.
Thu, Jan 13, 11:13 AM · BF Blender (3.1), EEVEE & Viewport, Render & Cycles
Dalai Felinto (dfelinto) added projects to T94871: Crash on production file due to OpenSubdiv OpenGL backend: Render & Cycles, EEVEE & Viewport.

Adding all the reviewers of the original patch here to help shed some light into it, and hopefully finding another computer that runs into this as well (leaving it as unconfirmed until we can break in another system).

Thu, Jan 13, 11:12 AM · BF Blender (3.1), EEVEE & Viewport, Render & Cycles
Philipp Oeser (lichtwerk) updated subscribers of T94865: Crash when switching to texture paint workspace on models with a subdivision modifier.

@Kévin Dietrich (kevindietrich) ; mind checking?

Thu, Jan 13, 9:39 AM · Sculpt, Paint & Texture, Modeling, EEVEE & Viewport, BF Blender
Philipp Oeser (lichtwerk) renamed T94865: Crash when switching to texture paint workspace on models with a subdivision modifier from Crash when switching to texture paint mode on certain models to Crash when switching to texture paint workspace on models with a subdivision modifier.
Thu, Jan 13, 9:38 AM · Sculpt, Paint & Texture, Modeling, EEVEE & Viewport, BF Blender
Philipp Oeser (lichtwerk) changed the status of T94865: Crash when switching to texture paint workspace on models with a subdivision modifier from Needs Triage to Confirmed.

Can confirm, works without the subdiv modifier.

Thu, Jan 13, 9:30 AM · Sculpt, Paint & Texture, Modeling, EEVEE & Viewport, BF Blender
Eugene (imgood) added a comment to T92586: Flickering UI on MacBook M1 or external monitor MBP 13 M1.

Same for me. Blender 3.0, Apple M1 Pro

Thu, Jan 13, 7:17 AM · Platform: macOS, EEVEE & Viewport, BF Blender

Wed, Jan 12

Jacob Merrill (blueprintrandom) added a comment to T93220: EEVEE rewrite.

What will the openGL version required to use eevee rewrite?

Wed, Jan 12, 7:41 PM · EEVEE & Viewport
Jeroen Bakker (jbakker) added a project to T93601: Eevee AOV passes have inacurate colour: BF Blender (3.1).
Wed, Jan 12, 6:34 PM · BF Blender (3.1), EEVEE & Viewport
Jeroen Bakker (jbakker) triaged T93601: Eevee AOV passes have inacurate colour as High priority.
Wed, Jan 12, 6:34 PM · BF Blender (3.1), EEVEE & Viewport
Diogo Valadares Reis dos Santos (DiogoX2) renamed T93440: Viewport performance drops drastically after switching from atributte visualization to solid view from Viewport performance drops drastically after switching from eevee to solid view to Viewport performance drops drastically after switching from atributte visualization to solid view.
Wed, Jan 12, 5:21 PM · EEVEE & Viewport, BF Blender
Diogo Valadares Reis dos Santos (DiogoX2) added a comment to T93440: Viewport performance drops drastically after switching from atributte visualization to solid view.

It seems like it doesn't even need to be in eevee for the performance to be affected. If you switch to vertex visualization in the regular solid view and then switch back, it also reduces the performance.

Wed, Jan 12, 5:10 PM · EEVEE & Viewport, BF Blender
Diogo Valadares Reis dos Santos (DiogoX2) added a comment to T93440: Viewport performance drops drastically after switching from atributte visualization to solid view.

Just noticed today that this glitch also occurs when using the Experimental Sculpt Vertex Colors, since its stored in attributes. If stored to reguler vertex colors, it does not affect performance.

Wed, Jan 12, 4:55 PM · EEVEE & Viewport, BF Blender
Adam Janz (Copperplate) added a comment to T77090: Generative modifiers (solidify, mirror) draw face normals from original face (wrong direction).

@Philipp Oeser (lichtwerk) Thanks Philipp! Glad the devs are aware of this issue. I admit it's quite confusing to see inverted normals when modelling with the mirror modifier. A temporary workaround is to either turn off the "Cage" display on the modifier or enable "Face Orientation" in the Viewport Overlays so one can tell what normals are truly flipped.

Wed, Jan 12, 4:27 PM · EEVEE & Viewport, User Interface, Modeling
Philipp Oeser (lichtwerk) reopened T77090: Generative modifiers (solidify, mirror) draw face normals from original face (wrong direction) as "Needs Information from Developers".
Wed, Jan 12, 3:15 PM · EEVEE & Viewport, User Interface, Modeling
Philipp Oeser (lichtwerk) merged T94826: Face Normals display as NOT mirrored when Mirror Modifier is used into T77090: Generative modifiers (solidify, mirror) draw face normals from original face (wrong direction).
Wed, Jan 12, 3:14 PM · EEVEE & Viewport, User Interface, Modeling
Philipp Oeser (lichtwerk) merged task T94826: Face Normals display as NOT mirrored when Mirror Modifier is used into T77090: Generative modifiers (solidify, mirror) draw face normals from original face (wrong direction).
Wed, Jan 12, 3:14 PM · EEVEE & Viewport, BF Blender
Philipp Oeser (lichtwerk) added a comment to T94826: Face Normals display as NOT mirrored when Mirror Modifier is used.

Just noticed this has been reported before (and unfortunately closed as a design choice), see T77090: Generative modifiers (solidify, mirror) draw face normals from original face (wrong direction)

Wed, Jan 12, 3:14 PM · EEVEE & Viewport, BF Blender
Philipp Oeser (lichtwerk) added a comment to T77090: Generative modifiers (solidify, mirror) draw face normals from original face (wrong direction).

Cant we be more distinct and only do this if we know they will be drawn in the same place?

Wed, Jan 12, 3:12 PM · EEVEE & Viewport, User Interface, Modeling
Philipp Oeser (lichtwerk) renamed T77090: Generative modifiers (solidify, mirror) draw face normals from original face (wrong direction) from Different face normals behaviour with solidify modifier to Generative modifiers (solidify, mirror) draw face normals from original face (wrong direction).
Wed, Jan 12, 3:11 PM · EEVEE & Viewport, User Interface, Modeling
Philipp Oeser (lichtwerk) added a comment to T77090: Generative modifiers (solidify, mirror) draw face normals from original face (wrong direction).

Just noting that this also breaks the mirror modifier as noted in T94826: Face Normals display as NOT mirrored when Mirror Modifier is used

Wed, Jan 12, 3:06 PM · EEVEE & Viewport, User Interface, Modeling
Philipp Oeser (lichtwerk) changed the status of T94826: Face Normals display as NOT mirrored when Mirror Modifier is used from Needs Triage to Confirmed.

Can confirm, will check

Wed, Jan 12, 2:19 PM · EEVEE & Viewport, BF Blender
Clément Foucault (fclem) closed D13805: DRW: Add DRW_gpu_wrapper.hh.
Wed, Jan 12, 1:05 PM · EEVEE & Viewport
Pavel Duong (vignette) added a comment to T84655: Holdout doesn't work with Mix Shader correctly in Eevee.

I have found out there is a workaround to this problem using the following node-group:

Wed, Jan 12, 12:48 PM · EEVEE & Viewport, BF Blender
Pratik Borhade (PratikPB2123) changed the status of T93680: Blender 3.0 is crashing when creating hair particle system (Windows, Intel) from Needs Triage to Confirmed.

@Jake (Welp) submitted the fix (D13806) so I think we can confirm this report.

Wed, Jan 12, 12:30 PM · EEVEE & Viewport, BF Blender
Jeroen Bakker (jbakker) accepted D13805: DRW: Add DRW_gpu_wrapper.hh.

Seems fine. Would suggest to move it eventually to gpu module as well. Perhaps inside a different namespace (blender::gpu::wrappers).

Wed, Jan 12, 11:18 AM · EEVEE & Viewport
Pratik Borhade (PratikPB2123) merged T94843: Weird flickering/disappearance of viewport gizmos when I orbit or pan with the middle mouse button. into T94209: Viewport artifacts, slowdown, and crashing on Arch Linux w/ Intel graphics after driver update.
Wed, Jan 12, 10:10 AM · EEVEE & Viewport, BF Blender
Pratik Borhade (PratikPB2123) added a comment to T94843: Weird flickering/disappearance of viewport gizmos when I orbit or pan with the middle mouse button..

Hi, Thanks for the report. That's probably the same issue: T94209: Viewport artifacts, slowdown, and crashing on Arch Linux w/ Intel graphics after driver update
Try to downgrade mesa driver, that may resolve your issue for now.
Closing this ticket since we already have one. Thanks for the report :)

Wed, Jan 12, 10:09 AM · BF Blender, Platform: Linux
Pratik Borhade (PratikPB2123) changed the status of T94824: Annotations is rendering in off Overlays from Needs Triage to Confirmed.
Wed, Jan 12, 10:02 AM · EEVEE & Viewport, BF Blender
Johann Miegel (opalkanok) updated the task description for T94843: Weird flickering/disappearance of viewport gizmos when I orbit or pan with the middle mouse button..
Wed, Jan 12, 9:09 AM · BF Blender, Platform: Linux
Gilberto Rodrigues (gilberto_rodrigues) added a comment to T94806: Wireframe opacity doesn't work if object is "in front" and viewport shading is set to material preview or rendered..

@Carlos (Mujsoye) I think you are right

Wed, Jan 12, 4:23 AM · EEVEE & Viewport, BF Blender
Carlos (Mujsoye) added a comment to T94806: Wireframe opacity doesn't work if object is "in front" and viewport shading is set to material preview or rendered..

Hi.
Maybe I'm wrong but I think what you see is not the wireframe but the texture space box, it has the exact cube size .

Wed, Jan 12, 3:10 AM · EEVEE & Viewport, BF Blender
Vyacheslav (hitrpr) added a comment to T94671: Performance regression with subdivision modifier and enabled scene statistics.

tested. Thanks, all is fine now.

Wed, Jan 12, 12:43 AM · Modeling, EEVEE & Viewport, BF Blender

Tue, Jan 11

David Kozma (kynu) added a comment to T93573: Regression: Selection outline of curves in edit mode.

Hi Hans, I posted the bug originally.
I'm surprised these are related but no, you definitely shouldn't show outlines of any selected instances (in edit mode) either.
So if it's possible please solve this bug with turning those OFF.

Tue, Jan 11, 11:45 PM · Geometry Nodes, EEVEE & Viewport, Modeling, BF Blender
Clément Foucault (fclem) updated the summary of D13805: DRW: Add DRW_gpu_wrapper.hh.
Tue, Jan 11, 11:36 PM · EEVEE & Viewport
Clément Foucault (fclem) updated the summary of D13805: DRW: Add DRW_gpu_wrapper.hh.
Tue, Jan 11, 11:36 PM · EEVEE & Viewport
Clément Foucault (fclem) requested review of D13805: DRW: Add DRW_gpu_wrapper.hh.
Tue, Jan 11, 11:34 PM · EEVEE & Viewport
Hans Goudey (HooglyBoogly) added a comment to T93573: Regression: Selection outline of curves in edit mode.

This is because the evaluated mesh from a curve object is handled as an instance internally, and instance outlines don't turn off when in edit mode. So I see two options:

  1. Turn off instance outlines when in edit mode.
  2. Handle the instances that come from other geometry component types (points from mesh objects, meshes from curve objects, etc.) differently, only disable the edit mode outlines for them.
Tue, Jan 11, 8:29 PM · Geometry Nodes, EEVEE & Viewport, Modeling, BF Blender
Hans Goudey (HooglyBoogly) added a comment to T93756: Hiding all points of a spline in curve edit mode does not hide splines.

I'm not sure if this is possible to fix without larger changes currently. The evaluated curve has no idea about which control points were hidden in the original curve. There also isn't any "original index" tracking to support some kind of lookup heuristic to figure out what to hide. There is also ongoing discussion about switching to a totally separate curve data structure (T94193), so I'm not sure it's worth the time to rethink the design for this case.

Tue, Jan 11, 8:23 PM · Geometry Nodes, Modeling, EEVEE & Viewport, BF Blender
Pratik Borhade (PratikPB2123) changed the status of T94802: Xray doesn't work in wireframe shading for objects set to display as wire. from Needs Triage to Confirmed.
Tue, Jan 11, 7:07 PM · EEVEE & Viewport, BF Blender
Pratik Borhade (PratikPB2123) changed the status of T94806: Wireframe opacity doesn't work if object is "in front" and viewport shading is set to material preview or rendered. from Needs Triage to Confirmed.
Tue, Jan 11, 4:24 PM · EEVEE & Viewport, BF Blender
Jeroen Bakker (jbakker) updated the summary of D13801: T94001: Potential fix when using a OCIO 1d lut..
Tue, Jan 11, 3:52 PM · EEVEE & Viewport
Jeroen Bakker (jbakker) updated the summary of D13801: T94001: Potential fix when using a OCIO 1d lut..
Tue, Jan 11, 3:49 PM · EEVEE & Viewport
Jeroen Bakker (jbakker) updated the summary of D13801: T94001: Potential fix when using a OCIO 1d lut..
Tue, Jan 11, 3:47 PM · EEVEE & Viewport
Jeroen Bakker (jbakker) updated the summary of D13801: T94001: Potential fix when using a OCIO 1d lut..
Tue, Jan 11, 3:44 PM · EEVEE & Viewport
Jeroen Bakker (jbakker) added a comment to T94001: Custom OCIO "Displays" don't work..

@Nathan Vegdahl (cessen) hi! are you able to build blender for yourself?

Tue, Jan 11, 3:43 PM · EEVEE & Viewport, BF Blender
Jeroen Bakker (jbakker) added a revision to T94001: Custom OCIO "Displays" don't work.: D13801: T94001: Potential fix when using a OCIO 1d lut..
Tue, Jan 11, 3:43 PM · EEVEE & Viewport, BF Blender
Philipp Oeser (lichtwerk) closed T94233: Object Info - Random - Color Ramp [Random color not generated] [linux+intel+mesa] as Archived.

Note that this GPU isn't supported. Please see https://www.blender.org/download/requirements/ for minimum hardware requirements.
As we are planning to bump OpenGL 3.3 -> 4.3 for eevee2 I wouldn't spend time on this issue.

Tue, Jan 11, 2:59 PM · Platform: Linux, EEVEE & Viewport, BF Blender
Jeroen Bakker (jbakker) added a comment to T94233: Object Info - Random - Color Ramp [Random color not generated] [linux+intel+mesa].

Note that this GPU isn't supported. Please see https://www.blender.org/download/requirements/ for minimum hardware requirements.
As we are planning to bump OpenGL 3.3 -> 4.3 for eevee2 I wouldn't spend time on this issue.

Tue, Jan 11, 2:55 PM · Platform: Linux, EEVEE & Viewport, BF Blender
Germano Cavalcante (mano-wii) closed T94728: Auto Depth problem with Cliping Region as Resolved by committing rB6774cae3f25b: Fix T94728: Auto Depth problem with Cliping Region.
Tue, Jan 11, 2:40 PM · EEVEE & Viewport, BF Blender