Page MenuHome

Stephen Hamacek (hammers)
User

Projects

User does not belong to any projects.

User Details

User Since
Mar 3 2013, 9:04 AM (388 w, 4 d)

Recent Activity

Jun 14 2020

Stephen Hamacek (hammers) added a comment to T76023: Sidebar changes.

Would it be reasonably straightforward to just make the tabs MMB scrollable for now? All the workspace, properties tabs etc. have this behaviour when their panels are too small, why not these tabs? It would be a big improvement while we look for the longer term solution.

Jun 14 2020, 4:32 PM · Restricted Project, User Interface, BF Blender

Jun 8 2020

Stephen Hamacek (hammers) added a comment to T73686: Motion Paths not working with BlenRig armatures.

Thanks for all the action, sorry I missed the updates.. didn't realise it got reopened!

Jun 8 2020, 9:59 AM · Animation & Rigging, BF Blender

May 14 2020

Stephen Hamacek (hammers) added a comment to T53662: Usability issues with old group operators.

Ok thanks, looking forward to their thoughts on this.

May 14 2020, 9:05 AM · User Interface, Data, Assets & I/O, BF Blender
Stephen Hamacek (hammers) added a comment to T53662: Usability issues with old group operators.

Should I create a new report for rigid bodies operations creating Collections that aren't linked to the scene?

May 14 2020, 8:09 AM · User Interface, Data, Assets & I/O, BF Blender

May 13 2020

Stephen Hamacek (hammers) added a comment to T53662: Usability issues with old group operators.

As I Just mentioned in my merged report immediately above T76705, this seems to cause issues for rigid body workflow. The auto created 'Groups' which are effectively collections (RigidBodyWorld and RigidBodyConstraints) don't make it to the current scene by default, and I've ended up with all sorts of weirdness as a result. To me it seems that the groups should just be new collections within the current scene.

May 13 2020, 9:28 AM · User Interface, Data, Assets & I/O, BF Blender
Stephen Hamacek (hammers) created T76705: Ctrl-G creates Collection, but not linked to scene. Includes auto created rigid body collections and added through + in object prop. panel.
May 13 2020, 1:54 AM · BF Blender

Mar 12 2020

Stephen Hamacek (hammers) added a comment to rB5e30bd43f873: Fluid: Optimization for fluid domain obstacle boundary handling.

I'm just curious whether this might be applicable to smoke as well. I have an unusual case where I'm cutting shapes through smoke and getting stair stepping at the collider boundaries I think (related to the voxel size I guess). Would love it if there were a way to smooth this.

Mar 12 2020, 11:58 AM

Mar 7 2020

Stephen Hamacek (hammers) added a comment to T74494: Eevee Viewport and Render Blowouts/Glitches in Bloom pass.

I wasn't really sure what to do, when the problem relates mostly to animation rendering results. For me first frame (101) usually renders fine, then second and (sometimes) subsequent frames break. For me The problem exists after 2 frames, So rendering just f101 and f102, is all that's needed for me. But I understand it's hard if it can't be reproduced, especially an intermittent issue.

Mar 7 2020, 3:51 AM · BF Blender

Mar 6 2020

Stephen Hamacek (hammers) created T74494: Eevee Viewport and Render Blowouts/Glitches in Bloom pass.
Mar 6 2020, 2:24 PM · BF Blender

Feb 22 2020

Stephen Hamacek (hammers) added a comment to T74062: Mantaflow Gas domain: 'use adaptive time steps' doesn't seem to adapt..

Glad to see this, explains why I haven't had any luck with that feature yet.

Feb 22 2020, 4:09 AM · Nodes & Physics, BF Blender

Feb 9 2020

Stephen Hamacek (hammers) created T73686: Motion Paths not working with BlenRig armatures.
Feb 9 2020, 3:30 AM · Animation & Rigging, BF Blender

Feb 1 2020

Stephen Hamacek (hammers) added a comment to T71935: Blender does not remember windows size and position.

Ive hit a situation where the save image browser defaults to the size of the rendered image render window being saved, but this is really inconvenient in the case of portrait aspect renders. Each time I need to stretch the file browser or close settings etc. to read the filenames. Perhaps that's not the best choice for sizing the browser.

Feb 1 2020, 4:47 AM · BF Blender

Dec 31 2019

Stephen Hamacek (hammers) added a comment to T69985: Area Light Soft Shadows displayed in viewport but Viewport render image/animation shows hard shadow with eevee.

Yep me too. This is causing me a big problem at render time. 20-40s multilayer renders in command line, 2 or 3 seconds viewport, but shadows not rendering nicely from there, despite displaying perfectly fine in the viewport. Help!

Dec 31 2019, 9:56 AM · EEVEE & Viewport, BF Blender

Dec 10 2019

Stephen Hamacek (hammers) added a comment to T68801: Extruding a single vertex won't extrude it.

Well I've just had this issue, and discovered the work around via this too. I guess it could be a bug for the addon, as it is very counterintuitive to think that a single vert has entered face-select mode automatically, when really mostly you would create a vert with the intention of extruding it.

Dec 10 2019, 6:03 AM · Add-ons (Community)

Nov 1 2019

Stephen Hamacek (hammers) added a comment to T71147: 2.81 & 2.82 Eevee stops rendering in Rendered and Look Dev modes in viewports (macOS).

I've had this issue and similar drawing issues for a while too

Nov 1 2019, 1:10 AM · EEVEE & Viewport, Platform: macOS, BF Blender

Oct 8 2019

Stephen Hamacek (hammers) added a comment to T70598: Unable to select mesh objects in viewport, and edit mode not displaying overlays.

It's still happening, intermittent, but still there. Quite a few issues happening quite randomly, objects disappearing, not selectable or not editable. I'll try to fit more testing in soon.

Oct 8 2019, 2:29 PM · EEVEE & Viewport, Platform: macOS, BF Blender
Stephen Hamacek (hammers) added a comment to T70598: Unable to select mesh objects in viewport, and edit mode not displaying overlays.

Just tested in the new daily build, and it looks like it's ok now. Will update here later if the problem resurfaces. Thanks!

Oct 8 2019, 2:13 AM · EEVEE & Viewport, Platform: macOS, BF Blender
Stephen Hamacek (hammers) added a comment to T70598: Unable to select mesh objects in viewport, and edit mode not displaying overlays.

I just tried with a new file, just deleting the cube and adding a Suzanne, and had similar behaviour after deselecting, selecting and entering edit mode. Object selection seems to work but only selecting right next to the origin, not on the object itself, which isn't the case in 2.80. And edit mode behaviour--lack of any geometry overlay is the same. So, no metaballs needed ;)

Oct 8 2019, 1:53 AM · EEVEE & Viewport, Platform: macOS, BF Blender

Oct 7 2019

Stephen Hamacek (hammers) added a comment to T65302: Blender 2.8 - EDIT Mode - Crashing after selecting one of multiple materials.
Oct 7 2019, 9:13 AM · BF Blender
Stephen Hamacek (hammers) created T70598: Unable to select mesh objects in viewport, and edit mode not displaying overlays.
Oct 7 2019, 4:48 AM · EEVEE & Viewport, Platform: macOS, BF Blender

Aug 12 2019

Stephen Hamacek (hammers) added a comment to T61432: Sampling Subframes not working 2.8.

Glad to find this report, Having this issue on Mac OS 2.80, and also keen for a fix. Keep up the fine work!

Aug 12 2019, 4:11 AM · BF Blender

Apr 9 2019

Stephen Hamacek (hammers) added a comment to T58187: object visibility controlled by driver bug.

Nice Idea Sidney. And in case it hasn't occurred to anyone, I've resorted to adding a mask modifier to relevant objects and keyframing/driving that, in the meantime.

Apr 9 2019, 4:31 AM · BF Blender

Mar 13 2019

Stephen Hamacek (hammers) added a comment to T56635: Driver/Keyframes on object visibility do not update viewport.

Likewise just tried object visibility keyframing in latest build as of today (Mac) and still no option to keyframe or add drivers to object viewport visibility (eye icon in outliner). This is quite a crucial feature for me to start migrating my main project to 2.80

Mar 13 2019, 6:34 AM · Dependency Graph, BF Blender, Animation & Rigging

Feb 11 2019

Stephen Hamacek (hammers) created T61410: Driver-controlled renderability unpredictable, and no drivers avail. on viewport visibility.
Feb 11 2019, 12:24 PM · BF Blender

Sep 28 2018

Stephen Hamacek (hammers) added a comment to T37796: Undo after leaving sculpt mode through object mode menu blender loses sculpted mesh.

Whoah! I just had this issue under 2.79 Mac and with Multires sculpt. Sculpted obj 1, Sculpted obj2, edit object 3, make mistake, hit undo, Object one sculpt lost completely.

Sep 28 2018, 5:17 AM · BF Blender

Sep 10 2018

Stephen Hamacek (hammers) added a comment to T48892: Rigify Update and Fixes.

Just a small bugfix needed for the bird rigify. There is a double deformation problem in the foot after generating—looks like the DEF-toe.R and .L are set to deform and this causes the visible problem with the middle toe. Unchecking this fixes the problem, but I don't think this bone is even needed, since the toe controller already moves the regular toe def bones.

Sep 10 2018, 1:02 PM · Add-ons (Community)

Aug 1 2018

Stephen Hamacek (hammers) added a comment to T53461: NDOF Device configuration.

I think that's probably right Campbell. I normally access the config within Blender via the L button on the 3dconnexion, for a quick access menu. Not sure if this relates, but within Orbit mode, inverting the Z axis doesn't work.

Aug 1 2018, 5:46 AM · BF Blender
Stephen Hamacek (hammers) added a comment to T51893: Environment Textures do not Properly Light the Scene in Blender 2.8 EEVEE.
Aug 1 2018, 2:22 AM · BF Blender: 2.8

Jun 29 2018

Stephen Hamacek (hammers) added a comment to T42981: The "Fill Deformed" option in a curve's Object Data is inert....

I agree this option would make sense for 3d curves. For example I am using a curve as a spring, and as the curve is stretched so too is the radius of the spring curve along its length. Ideally of course the curve should get deformed, then the geometry around it is filled without the additional bevel stretching.

Jun 29 2018, 4:12 AM · BF Blender

Jun 26 2018

Stephen Hamacek (hammers) added a comment to T55555: Crash as soon as press material button in properties panel.

Thanks, mac build fixed for me too.

Jun 26 2018, 2:58 AM · Platform: Windows, Platform: macOS, BF Blender: 2.8

Oct 24 2017

Stephen Hamacek (hammers) added a comment to T52886: UI Text messed up on 2nd display/video card Mac.

Thanks @Arto Kitula (akitula). Just tried your build and sadly the glitch remains.

Oct 24 2017, 8:28 AM · Platform: macOS, BF Blender

Oct 23 2017

Stephen Hamacek (hammers) added a comment to T52886: UI Text messed up on 2nd display/video card Mac.

I just tried this build from builder.blender.org. Not sure if this is the one I need to try: blender-2.79.0-git20171022.57a0cb797d6-x86_64

Oct 23 2017, 3:22 AM · Platform: macOS, BF Blender

Oct 15 2017

Stephen Hamacek (hammers) added a comment to T51736: Drawing issues when running in multiple windows.

I'm out of my depth, but I thought this might relate to this bug I reported T52886

Oct 15 2017, 6:04 AM · BF Blender: 2.8

Sep 26 2017

Stephen Hamacek (hammers) added a comment to T52886: UI Text messed up on 2nd display/video card Mac.

In the past I had a GTX660 pc card (unflashed) alongside the Radeon original mac card. Now running a (non official) mac flashed Titan with Radeon card.

Sep 26 2017, 2:31 AM · Platform: macOS, BF Blender

Sep 24 2017

Stephen Hamacek (hammers) created T52886: UI Text messed up on 2nd display/video card Mac.
Sep 24 2017, 2:46 PM · Platform: macOS, BF Blender

Oct 16 2016

Stephen Hamacek (hammers) added a comment to T49453: CUDA not working on OSX 10.11.6.

Thanks for letting us know. Sorry I didn't find the duplicate report. Look forward to the fix when you can.

Oct 16 2016, 9:54 AM · Platform: macOS, BF Blender

Oct 15 2016

Stephen Hamacek (hammers) created T49726: No CUDA available 2.78 Mac 10.9.5.
Oct 15 2016, 5:17 PM · BF Blender

May 17 2015

Stephen Hamacek (hammers) added a comment to T43042: "UV Local View" option useless in Cycles .

I just struggled with a UV issue I think because of this, so I think this is an issue even for Cycles users.

May 17 2015, 6:56 AM · Cycles, BF Blender

Mar 13 2015

Stephen Hamacek (hammers) added a comment to T34109: Copy, Paste, Duplicate Render Layers.

Thanks again Bartek. This has been so useful. At the moment (with 2.73a) I'm not able to paste layers between files. Is that something to do with recent changes?

Mar 13 2015, 2:55 AM · Add-ons (Community)

Jan 3 2015

Stephen Hamacek (hammers) added a comment to T43088: Remesh and Motion blur incompatibility.

Sorry about the .blend, I wasn't trying to include images, but I guess I failed at making the linked character rig local...

Jan 3 2015, 6:48 AM · BF Blender

Jan 1 2015

Stephen Hamacek (hammers) created T43088: Remesh and Motion blur incompatibility.
Jan 1 2015, 3:50 AM · BF Blender

Oct 21 2014

Stephen Hamacek (hammers) added a comment to T42312: Crashes on saving .exr files with cycles GPU rendering..

I did some more testing on 2.72a:

Oct 21 2014, 4:51 PM · BF Blender: Unconfirmed, Platform: macOS

Oct 20 2014

Stephen Hamacek (hammers) created T42312: Crashes on saving .exr files with cycles GPU rendering..
Oct 20 2014, 3:43 PM · BF Blender: Unconfirmed, Platform: macOS
Stephen Hamacek (hammers) added a comment to T42182: Adjusting Cloth cache frame range can crash Blender.

OK will try to package something up to post. Cheers.

Oct 20 2014, 1:39 PM · BF Blender: Unconfirmed, BF Blender

Oct 11 2014

Stephen Hamacek (hammers) created T42182: Adjusting Cloth cache frame range can crash Blender.
Oct 11 2014, 10:36 AM · BF Blender: Unconfirmed, BF Blender

Oct 6 2014

Stephen Hamacek (hammers) added a comment to T36382: Simulation cache can not be saved for linked objects.

Just a followup to confirm your experience @Adam Priest (pre).

Oct 6 2014, 5:56 PM · Modifiers, BF Blender

Sep 2 2014

Stephen Hamacek (hammers) added a comment to T36382: Simulation cache can not be saved for linked objects.

@Adam Priest (pre) thanks for posting, Glad there is a workaround—been trying to figure this out too.

Sep 2 2014, 9:24 AM · Modifiers, BF Blender

Mar 29 2014

Stephen Hamacek (hammers) added a comment to T39497: Save as/Save copy loses textures from linked assets.

Ah sorry, I just realised I hadn't reloaded the 'Save copy'. That looks like it works as expected. *embarrassed*

Mar 29 2014, 3:17 AM · BF Blender
Stephen Hamacek (hammers) raised the priority of T39497: Save as/Save copy loses textures from linked assets from to 90.
Mar 29 2014, 3:12 AM · BF Blender

Mar 20 2014

Stephen Hamacek (hammers) added a comment to T38897: Problems moving animation channels up and down in dope sheet/action editor.

Just tried with 2.7 official and all works perfectly so far. Thanks for implementing this great enhancement!

Mar 20 2014, 9:22 AM · BF Blender

Mar 18 2014

Stephen Hamacek (hammers) added a comment to T38897: Problems moving animation channels up and down in dope sheet/action editor.

Strange indeed. I definitely can't move channels except top/bottom in that build (not just in this blend). RC1 OK. I guess I'll wait and try another build soon...

Mar 18 2014, 2:27 PM · BF Blender
Stephen Hamacek (hammers) attached 0 file(s) of 1: F81666: ChannelMoveTest.blend.zip

Here's a blend with one of the rigs I'm using atm. Haven't tried rc2 yet, but def. seems to not work in 2aff243

Mar 18 2014, 3:34 AM · BF Blender

Mar 16 2014

Stephen Hamacek (hammers) added a comment to T38897: Problems moving animation channels up and down in dope sheet/action editor.

@Bastien Montagne (mont29) I've just tried the latest build 2aff243 to check this out, but now the channels won't move up/down at all, only move to top or bottom (shift-pageup/pagedown).

Mar 16 2014, 8:50 AM · BF Blender

Mar 1 2014

Stephen Hamacek (hammers) added a comment to T38897: Problems moving animation channels up and down in dope sheet/action editor.

I've figured out what's going on here I think. As I only had about half the bones visible at the time, the up/down seems to be taking into account the non-displayed bones in the list too, So sometimes the channels are 'invisibly' moving up and down among channels I can't see.

Mar 1 2014, 2:21 AM · BF Blender
Stephen Hamacek (hammers) raised the priority of T38897: Problems moving animation channels up and down in dope sheet/action editor from to 90.
Mar 1 2014, 2:08 AM · BF Blender

Feb 21 2014

Stephen Hamacek (hammers) added a comment to T38737: Box select channels in dope sheet doesn't select corresponding bones in rig..

Thanks so much aligorith!

Feb 21 2014, 1:31 PM · BF Blender
Stephen Hamacek (hammers) raised the priority of T38737: Box select channels in dope sheet doesn't select corresponding bones in rig. from to 90.
Feb 21 2014, 7:05 AM · BF Blender

Feb 20 2014

Stephen Hamacek (hammers) added a comment to T38580: 3D Mouse Pro and Blender on a 5.1 Mac Pro Tower do not play well.

And another slightly vague observation. Spacenavigator on Mac 10.8.5 and recent build, I've had the following experience:

Feb 20 2014, 12:39 AM · BF Blender

Feb 16 2014

Stephen Hamacek (hammers) added a comment to T38580: 3D Mouse Pro and Blender on a 5.1 Mac Pro Tower do not play well.

@Campbell Barton (campbellbarton), thanks for checking into this and looking forward to some of your proposals on the wiki! NDOF for colour picking sounds cool. And +1 from me for pan without shift key, as this is the intended use of the device imo (i.e. one-handed).

Feb 16 2014, 1:51 AM · BF Blender

Feb 14 2014

Stephen Hamacek (hammers) added a comment to T38580: 3D Mouse Pro and Blender on a 5.1 Mac Pro Tower do not play well.

I've put my settings up in a post on BA:
http://blenderartists.org/forum/showthread.php?327268-3D-mouse-settings&p=2578299&posted=1#post2578299

Feb 14 2014, 8:00 AM · BF Blender

Feb 12 2014

Stephen Hamacek (hammers) added a comment to T38580: 3D Mouse Pro and Blender on a 5.1 Mac Pro Tower do not play well.

I'm trying a spacenavigator at the moment too, on Mac 10.7.5. Have only had limited success after much experimentation. At the moment I have 3 of the available 6 axes working properly.

Feb 12 2014, 5:17 AM · BF Blender

Jan 13 2014

Stephen Hamacek (hammers) added a comment to T35290: Freestyle ignores layer mask in render layers.

Would be great if there were an elegant solution to this. Becomes even more difficult with partly occluded objects. I'm trying to hack together compositing solutions with multiple layers, But it's a hacky and imprecise way to go. Good luck!

Jan 13 2014, 2:38 AM · Rendering, BF Blender

Jan 10 2014

Stephen Hamacek (hammers) added a comment to T34109: Copy, Paste, Duplicate Render Layers.

Just discovered this add-on which would have saved me hours of work, but having errors like kopias above in 2.69.

Jan 10 2014, 7:45 AM · Add-ons (Community)

Jan 7 2014

Stephen Hamacek (hammers) added a comment to T37974: Running 2 Instances with the Same Filename corrupts the Temp EXR image file.

So is this an issue for background command-line rendering too?

Jan 7 2014, 4:01 PM · BF Blender, Rendering

Jan 6 2014

Stephen Hamacek (hammers) added a comment to T38086: File output node only renders one frame in simple conversion setup.

Issue still present in hash b0ab91c

Jan 6 2014, 5:40 AM · Compositing, BF Blender
Stephen Hamacek (hammers) added a comment to T38086: File output node only renders one frame in simple conversion setup.

I'm downloading yesterday's later build to try, in case this is fixed by https://developer.blender.org/T38074

Jan 6 2014, 4:27 AM · Compositing, BF Blender
Stephen Hamacek (hammers) raised the priority of T38086: File output node only renders one frame in simple conversion setup from to 90.
Jan 6 2014, 4:12 AM · Compositing, BF Blender

Dec 22 2013

Stephen Hamacek (hammers) added a comment to T37906: Adding force field settings to boids gives hard crash.

Thanks so much sergey!

Dec 22 2013, 4:23 AM · BF Blender

Dec 21 2013

Stephen Hamacek (hammers) raised the priority of T37906: Adding force field settings to boids gives hard crash from to 90.
Dec 21 2013, 6:23 AM · BF Blender

Dec 17 2013

Stephen Hamacek (hammers) added a comment to T36594: Alpha channel of TGA, DDS, JPEG200, IRIS is not interpreted correctly.

Not sure if this is related, but I was trying to use alpha channel from Video file (ProRes 4444) in compositor, but alpha seemed to not be interpreted at all. Let me know if you would like some sample frames and/or .blend.

Dec 17 2013, 8:43 AM · Images & Movies, BF Blender

Dec 13 2013

Stephen Hamacek (hammers) added a comment to T37797: Command line rendering wrong on first rendered frame.

You're a legend - all good now! Only thing better than having bugs fixed just after you report them: having them fixed just before ;)

Dec 13 2013, 2:16 AM · BF Blender
Stephen Hamacek (hammers) added a comment to T37797: Command line rendering wrong on first rendered frame.

Thanks Brecht, sorry I missed that update! Testing now.

Dec 13 2013, 1:50 AM · BF Blender
Stephen Hamacek (hammers) raised the priority of T37797: Command line rendering wrong on first rendered frame from to 90.
Dec 13 2013, 1:35 AM · BF Blender

Nov 25 2013

Stephen Hamacek (hammers) added a comment to T37612: UV warp modifier bone fields break when bone name changed..

Well that was quick. Thanks!

Nov 25 2013, 6:27 AM · BF Blender
Stephen Hamacek (hammers) raised the priority of T37612: UV warp modifier bone fields break when bone name changed. from to 90.
Nov 25 2013, 5:53 AM · BF Blender