Page MenuHome

Chuck Ocheret (smart61)
User

Projects

User does not belong to any projects.

User Details

User Since
Feb 9 2017, 6:04 PM (135 w, 5 d)

Recent Activity

Sun, Sep 8

Chuck Ocheret (smart61) added a comment to T66231: Performance degradation of Principled Shader in Eevee when metallic is turned off.

It is still a problem for me on 2.81.

Sun, Sep 8, 5:38 PM · Platform: macOS, BF Blender

Sat, Sep 7

Chuck Ocheret (smart61) added a comment to T69543: Sculpt mode new Stroke Spacing distance set to Scene causes immediate exit or crash.

This is still crashing/exiting for me on the latest build done on my Mac as well as with the current daily build from blender.org (version: 2.81 (sub 8), branch: master, commit date: 2019-09-07 16:22, hash: rBabeab4fcad66)

Sat, Sep 7, 11:15 PM · BF Blender

Thu, Sep 5

Chuck Ocheret (smart61) added a comment to T69543: Sculpt mode new Stroke Spacing distance set to Scene causes immediate exit or crash.

I'm using a local build. It looks like I'm building from a later commit than you are testing against (11:47 vs 10:52). ¯\_(ツ)_/¯

Thu, Sep 5, 6:07 PM · BF Blender
Chuck Ocheret (smart61) created T69543: Sculpt mode new Stroke Spacing distance set to Scene causes immediate exit or crash.
Thu, Sep 5, 4:00 PM · BF Blender

Jul 3 2019

Chuck Ocheret (smart61) added a comment to T66231: Performance degradation of Principled Shader in Eevee when metallic is turned off.

Some more info. After a reboot, I don't feel the sluggishness very much at all. However, after loading the scene multiple times (e.g. revert) it gets more and more sluggish with metallic set to 0. Even if I restart blender, it continues to become increasingly sluggish over time. Therefore, I am suspecting that somehow MacOS is experiencing some sort of resource leak related to the GPU. Rebooting appears to be the only things I can find (so far) that gets me back to good performance. I can now get this performance issue with a simple cube with the default shader (Principled BSDF) such that metallic 1 gives great performance and 0 gives horrible performance. Very weird. I'll try the suggestion with resetting to factory settings later today. I have been messing with BoolTool, HardOps, and BoxCutter. Never experienced this before.

Jul 3 2019, 4:15 PM · Platform: macOS, BF Blender

Jul 2 2019

Chuck Ocheret (smart61) added a comment to T66231: Performance degradation of Principled Shader in Eevee when metallic is turned off.

I do not see this problem on my Windows machine. Of course, my Windows box has got dual GTX 1080Ti's. I still experience it on my MacBook Pro, which is where this was first reported. I rebuilt Blender today and the problem persists. It may be something specific to this scene since I have not noticed this before. The Knobs object is a duplicate of a cutter object I used with the BoolTools plug-in. I made the knobs visible again (and turned back on various Cycles options that BoolTool disables). But maybe BoolTools sets some other option that makes the Knobs object weird.

Jul 2 2019, 8:17 PM · Platform: macOS, BF Blender

Jun 29 2019

Chuck Ocheret (smart61) added a comment to T66232: Object that renders in Eevee disappears in Cycles.

Ah. good catch everyone. The Knobs were a duplicate of a cutter that was used with the BoolTool plug-in. I hadn't realized that the plug-in had also changed those settings. Thx.

Jun 29 2019, 3:24 PM · BF Blender
Chuck Ocheret (smart61) created T66232: Object that renders in Eevee disappears in Cycles.
Jun 29 2019, 12:45 AM · BF Blender
Chuck Ocheret (smart61) created T66231: Performance degradation of Principled Shader in Eevee when metallic is turned off.
Jun 29 2019, 12:41 AM · Platform: macOS, BF Blender

Apr 9 2019

Chuck Ocheret (smart61) created T63423: Multiple Principled Volume shader failures w/ Eevee.
Apr 9 2019, 4:21 PM · BF Blender

Apr 1 2019

Chuck Ocheret (smart61) added a comment to T63195: Sculpt Mode UI appears to have lost the ability to lock Radius and Strength.

Thanks for pointing that out. I just looked and added my own objection to the changes. As of now, Sculpt Mode is completely unusable for me since. I have to do my Sculpting in 2.79 or Zbrush for the time being. Sigh.

Apr 1 2019, 9:02 PM · BF Blender
Chuck Ocheret (smart61) added a comment to D4529: Brush Tool Properties re-org.

I don't see where the equivalent to the lock icon for the Radius is in the options panel. This lock was essential to those of us who used DynTopo in Constant Detail (I live there) so that zooming in on the mesh "locks" your brush to the zoomed geometry (i.e. you don't have to counter-resize your brush to compensate for zooming). I see a Radius Unit property now in the Options panel. But that appears to affect much more when I switch it to View. It does seem to tie the brush size to the zoom, but it completely messes with the DynTopo resolution settings (at least in constant detail). And in fact, I simply can't get sculpting to work as expected at all. This is basically unusable now. I do agree that we need a better interface than the lock symbol or at least we need a good tooltip to describe what it does. I don't even mind it being in the options panel since I always leave it on. But it doesn't do what it used to do. Falling back to Z-brush until this is fixed.

Apr 1 2019, 8:56 PM
Chuck Ocheret (smart61) added a comment to T63191: Grease Pencil Strokes visible behind solid objects.

I just tried it with completely opaque strokes drawn with strength set to 1.0 and no pressure sensitivity. This is just to ensure that there is absolutely no transparency involved. If you look from the front (Numpad 1) you can see the that it looks like the far strokes are subtracting from the near strokes. When you look from the back (Ctrl-Numpad 1) it all looks ok.

Apr 1 2019, 8:44 PM · BF Blender
Chuck Ocheret (smart61) added a comment to T63191: Grease Pencil Strokes visible behind solid objects.

I've tried both 3D location (my current setting) as well as 2D layers with much the same effect. Even in the example you posted above, you can see the rear strokes through the sphere, but only where there are strokes in front of the sphere. The effect when animating is that the strokes in front serve as a transparency map for the sphere. Except all you can see through the sphere are the strokes from the same GP object behind it.

Apr 1 2019, 8:27 PM · BF Blender
Chuck Ocheret (smart61) created T63195: Sculpt Mode UI appears to have lost the ability to lock Radius and Strength.
Apr 1 2019, 8:21 PM · BF Blender
Chuck Ocheret (smart61) created T63191: Grease Pencil Strokes visible behind solid objects.
Apr 1 2019, 7:23 PM · BF Blender

Mar 29 2019

Chuck Ocheret (smart61) created T63102: Blender 2.8 manual references 2.79 API docs.
Mar 29 2019, 5:31 PM · Documentation

Mar 27 2019

Chuck Ocheret (smart61) added a comment to T63017: While in X-ray display, selection made via lasso select does not display properly.

It does seem depth buffer related in some cases. Another symptom I just found. In the same .blend file I sent, try the following:

Mar 27 2019, 7:38 PM · BF Blender
Chuck Ocheret (smart61) added a comment to T63017: While in X-ray display, selection made via lasso select does not display properly.

This problem also occurs in edge select mode or face select mode. So in step 5 above, it is not essential to be in vertex select mode.

Mar 27 2019, 4:57 PM · BF Blender
Chuck Ocheret (smart61) created T63017: While in X-ray display, selection made via lasso select does not display properly.
Mar 27 2019, 4:29 PM · BF Blender

Feb 27 2019

Chuck Ocheret (smart61) added a comment to T62023: Navigating in edit mode crashes instantly.

After trying many things, including resetting to factory settings, reinstalling the cloud plug-in, I can occasionally get past this point. But edit mode always eventually crashes in the same spot.

Feb 27 2019, 10:58 PM · BF Blender
Chuck Ocheret (smart61) updated the task description for T62023: Navigating in edit mode crashes instantly.
Feb 27 2019, 10:32 PM · BF Blender
Chuck Ocheret (smart61) created T62023: Navigating in edit mode crashes instantly.
Feb 27 2019, 10:31 PM · BF Blender

Jan 28 2019

Chuck Ocheret (smart61) added a comment to T57069: macOS screen scaling wrong on startup.

I built locally and it works brilliantly now. Thanks! The native pixel stuff on MacOS is quirky. Ironic that I just found a workaround 3 days ago.

Jan 28 2019, 9:13 PM · Platform: macOS, BF Blender

Jan 26 2019

Chuck Ocheret (smart61) added a comment to T60884: Alt-C shortcut for "Convert To..." is not present but it is documented.
Jan 26 2019, 11:32 PM · BF Blender
Chuck Ocheret (smart61) created T60884: Alt-C shortcut for "Convert To..." is not present but it is documented.
Jan 26 2019, 1:24 AM · BF Blender

Jan 25 2019

Chuck Ocheret (smart61) added a comment to T57069: macOS screen scaling wrong on startup.

Still a problem. But I have a workaround for my particular system at the moment.

Jan 25 2019, 6:15 PM · Platform: macOS, BF Blender
Chuck Ocheret (smart61) added a comment to T60163: Multires modifier not always updating external data files when .blend is saved causing changes to be lost.

Seems to work fine now. Thanks! Awesome work.

Jan 25 2019, 5:26 PM · BF Blender

Jan 7 2019

Chuck Ocheret (smart61) added a comment to T60124: Multires modifier not reading data from external files.

Yes. Good point. Anyway, I'm grateful for the quick fix here. And hope we can get the newly encountered problems sorted too. This is especially painful for me since the 2.79 branch does not work at all on my MacBook Pro anymore at this point, which means I can only run 2.79 on WIndows, which I don't have on a laptop.

Jan 7 2019, 4:49 PM · BF Blender

Jan 6 2019

Chuck Ocheret (smart61) added a comment to T60124: Multires modifier not reading data from external files.

Not sure if I should put this here. But I created a new bug report https://developer.blender.org/T60163 because even though the issue here was fixed quickly (thanks!) and closed, it introduced new problems. So this mechanism is still not very usable.

Jan 6 2019, 8:43 AM · BF Blender

Jan 4 2019

Chuck Ocheret (smart61) created T60163: Multires modifier not always updating external data files when .blend is saved causing changes to be lost.
Jan 4 2019, 5:58 PM · BF Blender

Jan 3 2019

Chuck Ocheret (smart61) added a comment to T60124: Multires modifier not reading data from external files.

Minor point... This came up as a result of SculptJanuary. Tons of people are trying out Blender 2.8 for this and a bunch of people have responded that they've experienced this bug. I published a tip last year about using external multires data so that we can keep all of the files on GitHub. If you pack all the data internally, then .blend files generally grow too large for vanilla GitHub. But with external multires you get a bunch of files that don't go beyond their file limits. So we're going back to 2.79 for detail sculpt passes/baking until this is fixed.

Jan 3 2019, 6:46 PM · BF Blender
Chuck Ocheret (smart61) added a comment to T60124: Multires modifier not reading data from external files.

I am adding a sample .blend and the associated .btx file. From debugging it looks like the .btx file is referenced with a relative path so just putting them in the same directory and opening the .blend should demonstrate the problem. Remember, saving the .blend file might overwrite the .btx file. So copy Cube.btx to Cube.btx.sav or something so you can keep trying as you debug.

Jan 3 2019, 6:37 PM · BF Blender
Chuck Ocheret (smart61) created T60124: Multires modifier not reading data from external files.
Jan 3 2019, 5:41 PM · BF Blender

Dec 25 2018

Chuck Ocheret (smart61) created T59831: Inconsistent behavior in box select.
Dec 25 2018, 1:44 AM · User Interface, BF Blender

Dec 21 2018

Chuck Ocheret (smart61) added a comment to T57069: macOS screen scaling wrong on startup.

Same thing has been happening for me on Mojave for ages. Still happening with the daily build and my local build for 2.79. Does not happen for 2.8. I have the most recent 2018 MacBook Pro running Mojave. It happens whether or not I'm just using the laptop screen or if I hook up an external thunderbolt display with or without screen mirroring. If there is any more info I can provide I am happy to help by debugging in Xcode on my system live or whatever. Just tell me what you need. It basically forces me to run Blender 2.79 on my Windows system, which makes me sad.

Dec 21 2018, 9:47 PM · Platform: macOS, BF Blender

Oct 5 2018

Chuck Ocheret (smart61) created T57075: Can't build blender on MacOS Mojave.
Oct 5 2018, 7:51 PM · BF Blender: 2.8

Sep 12 2018

Chuck Ocheret (smart61) added a comment to T56783: Blender Cloud not accessible via daily build.

Same errors when I build Blender locally on my Mac.

Sep 12 2018, 5:04 PM · Infrastructure: Blender Cloud, Add-ons
Chuck Ocheret (smart61) added a comment to T56783: Blender Cloud not accessible via daily build.

Also get this when attempting to use Shift-Ctrl-Alt-A to load an image from the Blender Cloud. No error visible in the console.

Sep 12 2018, 5:03 PM · Infrastructure: Blender Cloud, Add-ons
Chuck Ocheret (smart61) added a comment to T56783: Blender Cloud not accessible via daily build.

Also get this when attempting to use Shift-Ctrl-Alt-A to load an image from the Blender Cloud. No error visible in the console.

Sep 12 2018, 4:56 PM · Infrastructure: Blender Cloud, Add-ons
Chuck Ocheret (smart61) added a comment to T56783: Blender Cloud not accessible via daily build.

Better image showing valid login with Blender ID authentication plugin...

Sep 12 2018, 4:35 PM · Infrastructure: Blender Cloud, Add-ons
Chuck Ocheret (smart61) created T56783: Blender Cloud not accessible via daily build.
Sep 12 2018, 4:31 PM · Infrastructure: Blender Cloud, Add-ons

Sep 11 2018

Chuck Ocheret (smart61) added a comment to T56275: Blender ID Authentication fails due to lack of SSL module.

Quick update... Interestingly the brew openssl appears to break a a number of things in MacOS so I had to back it out. In other words it isn't the best workaround for the problem. I just downloaded the daily build. I can't tell if this problem is still there because now the 'requests' module is missing from Python. This has been a problem in the past (I reported it for a production release a long time ago) but I haven't seen it in a while.

Sep 11 2018, 4:52 PM · Add-ons

Aug 31 2018

Chuck Ocheret (smart61) added a comment to T56275: Blender ID Authentication fails due to lack of SSL module.

Thanks! That email revealed a workaround for the problem. After installing the brew openssl with

Aug 31 2018, 3:10 PM · Add-ons

Aug 30 2018

Chuck Ocheret (smart61) added a comment to T56275: Blender ID Authentication fails due to lack of SSL module.

Is there anyway to get someone to address this? This problem with the Mac daily build has persisted for a while (I only reported it after it remained broken for a few weeks). I have built Blender on my Mac at home and it exhibits the same problem. Not having SSL working means no access to Blender Cloud from the daily build and breaks things like the SketchFab uploader, several cloud rendering frameworks, etc... Is it more than a build config issue?

Aug 30 2018, 7:42 PM · Add-ons

Aug 18 2018

Chuck Ocheret (smart61) added a comment to T56275: Blender ID Authentication fails due to lack of SSL module.

I noticed that this may be related to another tracked issue - https://developer.blender.org/T54506 (Not sure if there's a better way to refer to it). Glad it isn't an explicit security issue despite the erroneous logged-in status. It is quite a painful problem for me at the moment because I have 3 classes w/ 90 students trying to wrap up Summer work and use the new Principled Hair BSDF and we depend on SSL for a number of plug-ins including our render farm setup.

Aug 18 2018, 10:20 PM · Add-ons

Aug 16 2018

Chuck Ocheret (smart61) added a comment to T56275: Blender ID Authentication fails due to lack of SSL module.

@Sybren A. Stüvel (sybren) Sorry about change the priority. Given that there might be a security issue (as described above on Aug 14) I felt it should be escalated. The problem persists today with the latest Mac build at builder.blender.org - https://builder.blender.org/download//blender-2.79-eebc292b424-OSX-10.9-x86_64.zip. I recall that this problem has recurred multiple times in the past with various Python modules not being available, including the SSL module.

Aug 16 2018, 3:50 PM · Add-ons
Chuck Ocheret (smart61) reopened T51309: Blender Cloud addon fails to authenticate via HTTPS as "Open".

Same problem now with current Mac daily build found on builder.blender.org at https://builder.blender.org/download//blender-2.79-eebc292b424-OSX-10.9-x86_64.zip.

Aug 16 2018, 3:44 PM · Add-ons

Aug 15 2018

Chuck Ocheret (smart61) raised the priority of T56275: Blender ID Authentication fails due to lack of SSL module from Normal to Confirmed, High.

This is still a problem in today's build and it exhibits the same security issue I reported yesterday. Please check today's Mac build at https://builder.blender.org/download//blender-2.79-a9700e7ad27-OSX-10.9-x86_64.zip.

Aug 15 2018, 3:40 PM · Add-ons

Aug 13 2018

Chuck Ocheret (smart61) added a comment to T56275: Blender ID Authentication fails due to lack of SSL module.

I downloaded the 2.79 build just now https://builder.blender.org/download//blender-2.79-c19ddcc975f-OSX-10.9-x86_64.zip, which appears to be the Aug 10 build. I had slightly different symptoms today, which make me a little more nervous.

Aug 13 2018, 6:36 PM · Add-ons

Aug 9 2018

Chuck Ocheret (smart61) added a comment to T56275: Blender ID Authentication fails due to lack of SSL module.

I got the lates Mac version from https://builder.blender.org/download dated Aug 8, 2018. The link in this page has changed to Aug 9 by now.

Aug 9 2018, 1:38 PM · Add-ons

Aug 8 2018

Chuck Ocheret (smart61) created T56275: Blender ID Authentication fails due to lack of SSL module.
Aug 8 2018, 4:24 PM · Add-ons

Feb 28 2017

Chuck Ocheret (smart61) created T50821: 2.78c is missing the Python requests package which breaks many things.
Feb 28 2017, 5:21 PM · BF Blender
Chuck Ocheret (smart61) added a comment to T50820: Blender Cloud Add-on installation not working on 2.78c (also very confusing).

A little more detail. It looks like 2.78c does not include the Python requests package.

Feb 28 2017, 5:09 PM · Add-ons
Chuck Ocheret (smart61) created T50820: Blender Cloud Add-on installation not working on 2.78c (also very confusing).
Feb 28 2017, 4:53 PM · Add-ons