Page MenuHome

AudioProject
ActivePublic

Members

  • This project does not have any members.

Details

Description

Sound import, export, editing and playback through the Audaspace library.

Module Owner: @Joerg Mueller (nexyon)

Recent Activity

Mon, Sep 16

Richard Antalik (ISS) added a comment to T69684: Sound Strip Audio "Pan" defaults are misleading .

I mean this could be enum for placement and pan field of -1 to 1 range.

Mon, Sep 16, 12:34 PM · Audio, Video Sequencer, BF Blender
Richard Antalik (ISS) added a comment to T68729: sound strip from wav-file changes length when frame rate changes.

Is this report really for version v2.76b?
That version is almost 4years old. We are not able to make fix for such old release. Please consider upgrading.

Mon, Sep 16, 4:49 AM · Audio, Video Sequencer, BF Blender
Mikeycal Meyers (mikeycal) added a comment to T69684: Sound Strip Audio "Pan" defaults are misleading .

I wonder if it would be possible to show which speaker the pan is directed towards, by putting a Letter, representing the speaker, next to the number?

Mon, Sep 16, 2:17 AM · Audio, Video Sequencer, BF Blender
Richard Antalik (ISS) added a revision to T69684: Sound Strip Audio "Pan" defaults are misleading : D5806: Fix T69684: Sound Strip "Pan" function is misleading.
Mon, Sep 16, 2:06 AM · Audio, Video Sequencer, BF Blender
Richard Antalik (ISS) added a comment to T69684: Sound Strip Audio "Pan" defaults are misleading .

I would say, that this panning range seems a bit hacky, but it is also described in manual:
https://docs.blender.org/manual/en/latest/video_editing/sequencer/properties/strip.html#sound

Mon, Sep 16, 1:25 AM · Audio, Video Sequencer, BF Blender

Sat, Sep 14

Christopher_Anderssarian added a comment to T69684: Sound Strip Audio "Pan" defaults are misleading .

Yet the default settings allow you to set it out of range -2 and 2. If it is set out of range, it won't pan at all.

Sat, Sep 14, 7:42 PM · Audio, Video Sequencer, BF Blender

Wed, Sep 11

Philipp Oeser (lichtwerk) added a comment to T69558: crash in BKE_scene_update_sound for a soundstrip without linked sound.

In tomorrows build (with the fix above), having the soundstip in there should also not crash anymore...

Wed, Sep 11, 8:53 PM · Audio, Video Sequencer, BF Blender
Jack Schaberg (JaySchay) added a comment to T69558: crash in BKE_scene_update_sound for a soundstrip without linked sound.

Hi. Yes, deleting the audio track takes care of the crash issue on 2.81 alpha. Thank you.

Wed, Sep 11, 8:05 PM · Audio, Video Sequencer, BF Blender
Philipp Oeser (lichtwerk) closed T69558: crash in BKE_scene_update_sound for a soundstrip without linked sound as Resolved by committing rB30aa67d5d57b: Fix T69558: crash in BKE_scene_update_sound for a soundstrip without linked….
Wed, Sep 11, 5:49 PM · Audio, Video Sequencer, BF Blender
Philipp Oeser (lichtwerk) added a revision to T69558: crash in BKE_scene_update_sound for a soundstrip without linked sound: D5764: Fix T69558: crash in BKE_scene_update_sound for a soundstrip without linked sound.
Wed, Sep 11, 5:38 PM · Audio, Video Sequencer, BF Blender
Philipp Oeser (lichtwerk) added projects to T69558: crash in BKE_scene_update_sound for a soundstrip without linked sound: Video Sequencer, Audio.
Wed, Sep 11, 5:32 PM · Audio, Video Sequencer, BF Blender

Tue, Sep 10

Philipp Oeser (lichtwerk) added projects to T69684: Sound Strip Audio "Pan" defaults are misleading : Video Sequencer, Audio.
Tue, Sep 10, 2:44 PM · Audio, Video Sequencer, BF Blender
Philipp Oeser (lichtwerk) added projects to T69682: "Render Audio..." does not always render keyframe transitions that have been placed in Volume, Pitch or Pan. : Video Sequencer, Audio.
Tue, Sep 10, 2:40 PM · Audio, Video Sequencer, BF Blender

Tue, Sep 3

Philipp Oeser (lichtwerk) triaged T66786: Audio SDL: Video editor Sound muted without muting it as Waiting for Developer to Reproduce priority.
Tue, Sep 3, 2:22 PM · Audio, BF Blender
Philipp Oeser (lichtwerk) renamed T66786: Audio SDL: Video editor Sound muted without muting it from Video editor Sound muted without muting it to Audio SDL: Video editor Sound muted without muting it.
Tue, Sep 3, 2:21 PM · Audio, BF Blender
Philipp Oeser (lichtwerk) added a project to T66786: Audio SDL: Video editor Sound muted without muting it: Audio.
Tue, Sep 3, 2:21 PM · Audio, BF Blender

Sun, Sep 1

Abid Maqbool (cto.abid) added a comment to T69355: Closing window stops video playback but not audio.

Exact Steps:

  • Open provided file
  • Window -> New Window
  • Play Animation (spacebar)
  • Close Window

Audio is still still playing until end

Sun, Sep 1, 1:12 PM · User Interface, BF Blender

Sat, Aug 31

Christopher_Anderssarian created T69355: Closing window stops video playback but not audio.
Sat, Aug 31, 2:01 PM · User Interface, BF Blender

Wed, Aug 28

Richard Antalik (ISS) added projects to T68946: VSE - Bad interpolation in exported audio: Audio, Dependency Graph.

I have a strong feeling, that this, T68945: VSE - Improper audio on frame 1 when exporting to lossy-compressed audio and T69167: VSE - "Render Audio" exports only one audio strip in some cases are caused by the same issue, or at least an issue in depsgraph.

Wed, Aug 28, 4:28 PM · Dependency Graph, Audio, Video Sequencer, BF Blender
Richard Antalik (ISS) added a project to T69167: VSE - "Render Audio" exports only one audio strip in some cases: Audio.

Possibly Depsgraph issue.

Wed, Aug 28, 4:21 PM · Audio, Video Sequencer, BF Blender
Richard Antalik (ISS) added a project to T68945: VSE - Improper audio on frame 1 when exporting to lossy-compressed audio: Audio.

I do experience similar issues during preview, but not in rendered files, at least not "audibly"
This is quite contrary, to what's reported.

Wed, Aug 28, 4:17 PM · Audio, Video Sequencer, BF Blender

Aug 19 2019

Philipp Oeser (lichtwerk) added projects to T68729: sound strip from wav-file changes length when frame rate changes: Video Sequencer, Audio.
Aug 19 2019, 9:35 AM · Audio, Video Sequencer, BF Blender

May 21 2019

Bastien Montagne (mont29) closed T60715: Heap-use-after-free error on exit of debug build (in Audaspace area) as Archived.

Archiving, cannot reproduce that anymore with current own builds… Probably a mysterious glitch in libs/compiler/linker magic.

May 21 2019, 10:01 AM · Audio, BF Blender

May 10 2019

Joerg Mueller (nexyon) closed T64376: Module 'aud' has no attribute 'device' as Invalid.

Blender 2.8 uses the latest version of audaspace where the aud API has changed considerably, please refer to the audaspace bindings API documentation.

May 10 2019, 9:34 AM · Audio, BF Blender

May 9 2019

cuong (vuiquahuhu) updated the task description for T64376: Module 'aud' has no attribute 'device'.
May 9 2019, 8:06 PM · Audio, BF Blender
Brecht Van Lommel (brecht) assigned T64376: Module 'aud' has no attribute 'device' to Joerg Mueller (nexyon).
May 9 2019, 7:54 PM · Audio, BF Blender
cuong (vuiquahuhu) added projects to T64376: Module 'aud' has no attribute 'device': Audio, BF Blender: 2.8.
May 9 2019, 12:17 PM · Audio, BF Blender

Feb 23 2019

Joerg Mueller (nexyon) removed a project from T58153: Preview mono audio not the same as render: Video Sequencer.
Feb 23 2019, 12:21 AM · BF Blender, Audio

Feb 20 2019

Richard Antalik (ISS) added a comment to T54969: VSE crashes or hangs unpredictably 4-6 frames into certain second sound strips during rendering..

On windows you can just download and run Blender, no need to install.
Not sure about other platforms.

Feb 20 2019, 11:57 AM · Audio, Video Sequencer, BF Blender
Richard Antalik (ISS) added a comment to T58153: Preview mono audio not the same as render.

Right now I am focusing on bugs.
If there is VSE bug not tagged, I guess other devs will relay this to me If I don't catch it.

Feb 20 2019, 11:54 AM · BF Blender, Audio
Ojvind Bernander (bernander) added a comment to T54969: VSE crashes or hangs unpredictably 4-6 frames into certain second sound strips during rendering..

Okay, maybe the bug has been fixed as a side effect of something else then?
I will test on 2.80 as soon as it's officially released. I hesitate to remove my current installation in case something breaks, and I'll need to deal with reinstalling an old version...

Feb 20 2019, 10:56 AM · Audio, Video Sequencer, BF Blender
Christopher_Anderssarian added a comment to T58153: Preview mono audio not the same as render.

Yes, this is still an issue. It's a minor inconvenience for me, but others may find it a blocker in their work flow.

Feb 20 2019, 10:21 AM · BF Blender, Audio
Richard Antalik (ISS) added a comment to T58153: Preview mono audio not the same as render.

Is this still an issue?
If yes, Should I keep VSE tag?
I am trying to cleanup workboard a bit..

Feb 20 2019, 2:01 AM · BF Blender, Audio

Feb 19 2019

Richard Antalik (ISS) closed T54969: VSE crashes or hangs unpredictably 4-6 frames into certain second sound strips during rendering. as Archived.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.

Feb 19 2019, 1:02 AM · Audio, Video Sequencer, BF Blender

Feb 12 2019

Joerg Mueller (nexyon) closed T48505: VSE audio pitch changes the speed of the audio as Invalid.

@Hossein Shah (hk1ll3r), you're right the strip length stays the same, but that doesn't mean that the speed doesn't change. If you have a strip of full length (not cut on any side) and you change the pitch to 2, you'll end up with double pitch and double speed, but the strip will stay the same length, meaning that it's silent in the second half. We intentionally don't change the strip length when the pitch is changed, since this can cause many problems, especially when you animate the pitch. I hope this clarifies the issue. If not, please ask further questions on devtalk.blender.org as @Sergey Sharybin (sergey) suggested.

Feb 12 2019, 10:29 AM · Video Sequencer, Audio, BF Blender
Sergey Sharybin (sergey) added a comment to T48505: VSE audio pitch changes the speed of the audio.

@Hossein Shah (hk1ll3r), instead of re-opening old reports, make a new one. With all the information requested there.
Please note that this is not really a place for discussion, but for a bug tracking, where artists report reproducible bugs and developers fix them. For discussions there are other channels like devtalk.blender.org, or blender artists.

Feb 12 2019, 10:01 AM · Video Sequencer, Audio, BF Blender
Hossein Shah (hk1ll3r) reopened T48505: VSE audio pitch changes the speed of the audio as "Open".

I'm new to blender, not sure if this is the right place but here I try...

Feb 12 2019, 4:38 AM · Video Sequencer, Audio, BF Blender

Feb 6 2019

Richard Antalik (ISS) added a comment to T54969: VSE crashes or hangs unpredictably 4-6 frames into certain second sound strips during rendering..

Only now I realized, that this is 2.79 bug report
Can not reproduce this in 2.79 f4dc9f9d68b or in 2.8

Feb 6 2019, 4:19 PM · Audio, Video Sequencer, BF Blender

Feb 5 2019

Bastien Montagne (mont29) updated subscribers of T60715: Heap-use-after-free error on exit of debug build (in Audaspace area).

Unfortunately gcc9 is not actually installable in debian testing currently (there are some unstable packages, but broken).

Feb 5 2019, 4:34 PM · Audio, BF Blender

Feb 4 2019

Ojvind Bernander (bernander) added a comment to T54969: VSE crashes or hangs unpredictably 4-6 frames into certain second sound strips during rendering..

See attached screenshot for the codec settings.

Feb 4 2019, 6:04 PM · Audio, Video Sequencer, BF Blender
Sebastian Parborg (zeddb) triaged T54969: VSE crashes or hangs unpredictably 4-6 frames into certain second sound strips during rendering. as Needs Information from User priority.
Feb 4 2019, 5:41 PM · Audio, Video Sequencer, BF Blender

Feb 1 2019

Richard Antalik (ISS) added a comment to T61043: Blender crashes on VSE zoom / scroll timeline sometimes.

The bug was introduced in rBdbe23c545649, so it only exists in 2.8, not 2.7. And yes @Richard Antalik (ISS) I can confirm that, but it has nothing to do with this bug.

Feb 1 2019, 4:14 PM · Audio, Video Sequencer, BF Blender
Joerg Mueller (nexyon) claimed T61043: Blender crashes on VSE zoom / scroll timeline sometimes.

The bug was introduced in rBdbe23c545649, so it only exists in 2.8, not 2.7. And yes @Richard Antalik (ISS) I can confirm that, but it has nothing to do with this bug.

Feb 1 2019, 4:00 PM · Audio, Video Sequencer, BF Blender
Joerg Mueller (nexyon) closed T61043: Blender crashes on VSE zoom / scroll timeline sometimes as Resolved by committing rBd9d72cc9cba5: Fix T61043: Blender crashes on VSE zoom / scroll timeline sometimes.
Feb 1 2019, 3:59 PM · Audio, Video Sequencer, BF Blender

Jan 31 2019

Richard Antalik (ISS) raised the priority of T61043: Blender crashes on VSE zoom / scroll timeline sometimes from Needs Information from User to Confirmed, High.

@Joerg Mueller (nexyon), not sure if you are involved in audio codec stuff, can you confirm my claim: "especially mp3 can report longer length of data stream then actual length." This is just a general observation from number of mp3 files, that behave this way.

Jan 31 2019, 11:58 PM · Audio, Video Sequencer, BF Blender

Jan 22 2019

Joerg Mueller (nexyon) added a comment to T60715: Heap-use-after-free error on exit of debug build (in Audaspace area).

Just tried with setting it in C/CXX FLAGS but same result as with WITH_COMPILER_ASAN. Please let me know what you get with gcc9. If you still have it there, I fear you'll have to help me debugging this. ;)

Jan 22 2019, 10:21 PM · Audio, BF Blender
Bastien Montagne (mont29) added a comment to T60715: Heap-use-after-free error on exit of debug build (in Audaspace area).

Hrrrmmm… Well, I do not use WITH_COMPILER_ASAN either, it does not work very well for me… So I rather just edit the CMAKE_C/CXX_FLAGS_DEBUG flags in cmake, and add -fsanitize=address to both.

Jan 22 2019, 12:17 PM · Audio, BF Blender

Jan 21 2019

Joerg Mueller (nexyon) added a comment to T60715: Heap-use-after-free error on exit of debug build (in Audaspace area).

I tried reproducing - I enabled WITH_COMPILER_ASAN (and disabled cycles and libmv in order to get it compile on my machine) but I only get memory leaks when I run blender then, not the error you reported. Do you have any hints on how to reproduce it?

Jan 21 2019, 10:49 PM · Audio, BF Blender
Bastien Montagne (mont29) assigned T60715: Heap-use-after-free error on exit of debug build (in Audaspace area) to Joerg Mueller (nexyon).

@Joerg Mueller (nexyon) Assigning to you for now, guess you'll be more familiar than me with c++/templates/std weirdness. ;)

Jan 21 2019, 6:43 PM · Audio, BF Blender
Bastien Montagne (mont29) created T60715: Heap-use-after-free error on exit of debug build (in Audaspace area).
Jan 21 2019, 6:42 PM · Audio, BF Blender