Page MenuHome

A few naming changes
ClosedPublic

Authored by William Reynish (billreynish) on Mar 1 2019, 9:45 PM.

Details

Summary

In accordance with T56648, here is a patch with some naming changes:

  • Render Border -> Render Region

Since you aren't rendering the border, but the region - same reason we changed Border Select to Box Select

  • Instancing 'Scale' -> 'Scale to Face Sizes'

'Scale' is just too ambiguous here.

  • Instancing 'Rotation' -> 'Align to Vertex Normals'

'Rotation' is just too ambiguous here.

This patch only makes changes to the UI level. Python API and anything underlying is left unchanged here.

Diff Detail

Repository
rB Blender

Event Timeline

William Reynish (billreynish) updated this revision to Diff 13957.

'Scale to Face Sizes' instead of 'Scale Instances to Face Sizes'

These seem to improve clarity substancially.

Slightly off topic: Any reason why group instancing ability has been removed from mesh (or any non empty) object types?

Those were quite useful to create "snapping cages" for alignment purposes, custom display objects or "personalized bounding bexes" since instance geometry can't be snapped to.

Brecht Van Lommel (brecht) requested changes to this revision.Mar 4 2019, 12:59 PM

Could also rename Verts to Vertices.

release/scripts/startup/bl_ui/properties_object.py
302

Would not use plural here and leave out vertex: Align To Normal.

321

Would not use plural here, seems inconsistent with other UI names: Scale to Face Size.

340

Maybe can just be Factor.

release/scripts/startup/bl_ui/space_view3d.py
797

VIEW3D_OT_clip_border also needs updated name and description.

source/blender/editors/space_image/image_ops.c
3768

Also need to update descriptions.

This revision now requires changes to proceed.Mar 4 2019, 12:59 PM

@Brecht Van Lommel (brecht): Sure, I’m fine with your suggested edits. Will update.

Overall we aren’t really consistent in Blender for when we use plural and singular. We often use plurals for tools also, such as ‘Extrude along Normals’, especially when it is important that it is extruding along each individual normal.

I thought the same with these examples - it is aligning to each individual vertex normal, so I used the plural. To me it seems slightly clearer to use ‘Align to Normals’ rather than ‘Align to Normal’, which implies that it will only use one normal.

But again we aren’t really perticularly consistent throughout the UI with this. We probably should define somemore consistent rules for it.

William Reynish (billreynish) marked 5 inline comments as done.Mar 6 2019, 1:46 PM
This revision is now accepted and ready to land.Mar 6 2019, 1:53 PM
This revision was automatically updated to reflect the committed changes.