Page MenuHome

blender -P not fully implemented, or buggy & context.render() needs window
Closed, ArchivedPublic

Description

Group: current SVN version
Resolution: Fixed
Category: Python

The -P flag does not really work very well.
I'm not entirely sure what it was designed to
do, but as implemented it seems to merely
act as an alternative to an 'On Load'
script link. Using the -P flag brings up
the user interface which seems to defeat the
purpose of being a 'batch mode' thing.
I can use the -b flag to explicitely
run in batch mode, which is kind of
a pain because then I also have to
specify a blend file. Still, with -b, I run
into trouble when I run context.render() ,
for example, because the scene render module
seems to depend on a render window being open.
context.render() also seems to be of limited use
for this purpose, since while it does render
an image, it doesn't save it. It might be
good to have an optional argument to this
function to save the render to a file, as
specified by the other attribures of the render
scene context. The workaround for this is to use
the context.renderAnim() function, which always
saves a file, and use this to render a one frame
animation (this still suffers from the weakness
of needing a render window though). Grep-ing
for G.background might yeild some clues as
to how to better implement a batch mode
processor, since this is the flag that the
-b mode uses to suppress rendering to a
render window.

Thank you for taking the time to read this,
Chris

Details

Type
Bug

Event Timeline

This task was automatically closed as archived as part of migration, because the project or tracker this task belonged to is no longer active.