Page MenuHome

still Micro Lags in BGE Animations
Closed, ResolvedPublic

Description

Category: Animation

I noticed that some Month ago. I've changed my Hardware and System in the meantime, but it still happens. (2.49b/2.5)

before: XP32; GForce
now: Win7 64; Radeon 4850

What happens:
In all kind of animations in Blender GE, are some strange micro lags. I hope i explain it right. Shown best with linear animations. Please have a look at the file.

All Cubes have a different Way to move. Such micro delays have effect to all cubes.
EXE-Tests in XP32 does have the same Results. (Don't run in Win7 64, so i can't test.)

Maybe You can find something out.
Thank You.

Details

Type
Bug

Event Timeline

I think I can see the problem you're talking about. Every once in a while there is a slight stutter. If I turn off the "Use Frame Rate" and just let vsync cap things, things seem to run smoothly. I get the feeling a frame is getting skipped or something so for just a fraction of a second, the fps changes.

Aaron Carlisle (Blendify) lowered the priority of this task from Normal to Needs Information from User.

Please make sure this still relevant with blender 2.75 test build and please give a .blend that we can use to test this

Yes, it still happens. In Viewport and Standalone Player.

Build 148ed4e

Win7 64, Radeon 6950

Aaron Carlisle (Blendify) raised the priority of this task from Needs Information from User to Normal.Jun 8 2015, 10:32 PM

i can't reproduce the bug. @Doc Holiday (doc_holiday) can you re test a blender version with commit d979ac4cc9967c5dce27461926396abe5de54b3d ?

Aaron Carlisle (Blendify) lowered the priority of this task from Normal to Needs Information from User.Jul 28 2015, 2:43 PM
Aaron Carlisle (Blendify) closed this task as Resolved.Aug 4 2015, 5:08 PM
Aaron Carlisle (Blendify) claimed this task.

Time to close. seams to be resolved by d979ac4cc9967c5dce27461926396abe5de54b3d