Page MenuHome

Horizontal button window (Properties) layout wrong for wide areas
Closed, InvalidPublic

Description

A Properties view (former button window) set in Horizontal mode miscalculates its size when the buttons in it do not fill it up horizontally.

Steps to reproduce:
1. Start Blender.
2. Change bottom view to Properties.
3. Select a narrow (few panels) mode, such as Objects Constraints.
4. Pan the view a bit with middle mouse button. Fiddling with its size also works.
At this point, the scrollbar appears, yet horizontal panning does not work, and the contents of the panel are rendered too large to be usable (and often outside the view).
Several other methods are possible to trigger the behaviour, such as just pointing at the buttons, and switching the normal Properties view to horizontal mode.
Of note is that I found the bug when loading older Blender files, where the buttonwindow was normally horizontal at the bottom.

Possibly related is that a too small vertically view can't be panned vertically, bug #22657, and bug #20048 which sounds like the same thing. #21026 issue 4 is also the same issue, but the other three seem not to be.
Apologies if this clutters up the issue tracker further.

system-info.txt from Blender 2.49 since 2.53 beta didn't have that menu choice. The version shown on the splash screen is 2.53.0 and "r"; I downloaded the binary from the website today (blender-2.53-beta-linux-glibc27-i686).

Event Timeline

Hello,
I also played around with the horizontal buttons, and I was easily able to reproduce the problem.

When trying to move the view (it does not matter how), the zoom is changed to maximum and the view switches between big and normal.

When I change it to another view, the old size is back.

Another problem that should be fixed is that you cannot scroll down if a panel is higher than the view.

I'm using Linux with yesterdays SVN

Michael

Bug #23308 possibly same error.

In all cases it seems the "smart" packing and scaling of the boxes gets confused when given a horizontal packing job to do.

Perhaps a subtle way of getting us all to use vertical alignment :-)

This is an item for our todo list. I added a link to this report for clarity and tracking purposes: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/UserInterface#Buttons.2FMenus

Thanks for taking the time to report.

Nathan Letwory (jesterking) changed the task status from Unknown Status to Invalid.Sep 12 2010, 11:48 PM

Closed duplicate https://projects.blender.org/tracker/index.php?func=detail&aid=22799&group_id=9&atid=498

Closing duplicate report:
http://projects.blender.org/tracker/index.php?func=detail&aid=24785&group_id=9&atid=498