Page MenuHome

Scrubbing Timeline in VSE with Jack Audio doesn't scrub just plays the audio track
Closed, ResolvedPublic

Description

Using Jack audio, an mp3 and scrubbing enabled doesn't scrub, it just continues the playing of the audio track. Dragging the play head back and forth repeatedly plays the track from where it's at, it doesn't even relate to the point on the time line of the audio.

Build Revision: 32105M from svn.

64bit Linux Maverick Merekat
FFMPEG from svn

USB Creative Audigy soundcard. 42msec latency.

Details

Type
Bug

Event Timeline

Scrubs much better cached :-)

Assigning to our sound man.

I bet it's the mp3 file! ffmpeg has problems with specific mp3 files with problematic headers so that it's unable to seek within the file. Could you please attach the problematic mp3 file, so that I can check?

hi

Link to file Windcatcher.mp3 download.

http://www.jamendo.com/en/album/49758

OpenAL scrubs the mp3 fine, but Jack can't.

Hmm, I'm sorry, looks like I didn't read the description precisely enough.

For me the file works perfectly.

Could you please try SDL as audio backend, SDL and Jack use the same software mixing code while OpenAL has its own, maybe that helps isolating the problem.

Hi

No apologies necessary for misreading, really appreciate your work on blender sound system. :-)

SDL scrubs fine too.

I'm using jackdmp 1.9.6 on a dual Xeon processors workstation.

I get a couple of errors when starting jackd.

Cannot create thread 1 Operation not permitted
Cannot create thread 1 Operation not permitted

Have no idea if that relates to problem. Although Jack seems to work fine for Ardour etc.

Thanks

I think I could reproduce the problem! Do you have AV-sync on? With it I seem to have the same problem, will look into it.

Fixed in revision 32256, thanks for reporting.

Joerg Mueller (nexyon) closed this task as Resolved.Oct 2 2010, 5:29 PM