Image editor paint icon missing until enter weight paint
Closed, ResolvedPublic


I am using Ubuntu 10.10 64b r34328.

The problem is that the preview icon for the image editor for the paint brush, are missing. At least until I caused the 3D display to enter a paint mode (weight paint in this case), which displays the icons. The result is that the icons start showing up in the image editor (see attached images).



Nicholas, do you have time to investigate this? You worked on better display for icons before...

hmm, seems like its still broken in latest SVN. I attached a blend showing the problem now.

Basically, if you add a texture, the thumbnail for the default clouds preview thumbnail is generated. The problem is that if you change the texture type to magic, lets say, the brush preview doesn't update (although it seems the brush itself in sculpt uses the right brush). Also, if you create the texture from the texture panel instead of via the tool shelf, the preview thumbnail doesn't get generated at all, and stays empty.

Thanks, reopened. Thought you meant an entirely different problem, but this is indeed still a bug :)

OK, brush texture should get regenerated now. Marking fixed again.

Not to be a pest or anything (hehe), but now I noticed that my tiny preview icons of the current texture, in the texture panel, are missing again (they only started working for me a few days ago). Im guessing this is a bug again?

I also attached a screenshot "Missing icons 3.png" to this report. Lemmie know if you need anything else.

Okay, it seems that this bug is back again, possibly since #25720 fixed the broken mini thumbnails that I reported above.

I mentioned the problem to Ton on irc, so I think he is at least looking into the problem.

In the meantime, I will also attach a screenshot to confirm, to this post. I will also reply back here if the matter is resolved (assuming Ton doesn't comment here first, of course).

I reopen this report, I suggest Nicholas should consult me first before working more here :)

Sergey - my original fix for this bug was completely wrong, but I haven't looked into it since then.

ubuntu 11.04 64bits rev43524

I can't reproduce initial bug about brushes preview icons in UV editor.

About little preview icons in texture panel, I noticed that texture panel have no list template for brushes.
Tiny texture icons seem to be created for these lists.

Unassigning self, following UI code makes my head hurt too much :)

Looking into this issue.

Ok, issue is caused by starting Icon Preview render job from two places: from texture buttons for small icon preview and from properties panel in image editor for large icon of texture. This preview job is starting in suspended mode and if new instance of the same job is starting, suspended job will be totally stopped. This is normally for cases when you're changing different settings -- in this case you'd wouldn't want re-render be triggered on every slide change. But what we've have with brush preview is that two instances of this job were creating for large and small icon separately, but because of described policy only one icon was rendered. Can see several ways to resolve the issue:
- Make job's owner icon rect instead of ID. But it'll lead to extra renderers created, so don't like this.
- Render all icon sizes if one of icons was changed. It'll require minimal changes but will introduce slowdown in cases if large texture icon isn't needed (i.e. texture isn't used by any brushes). So also don't like this approach.
- If suspended job is getting to be stopped, check if it was started for the same icon resolution and if not, that resolution will be also rendered in new job. So it'll be still minimal re-rendering happens, but in cases when job was started from two places for different icon sizes it'll work just fine.
There's patch in attachments where third approach was implemented.
Don't think i'll want such changes be commited so close to release..

From default blend:
* In Textures panel, select Brush textures
* Press New
* Select Material textures
* Click Browse button to show texture list

The small icon in the menu has not been updated. (Selecting the entry in the menu does then update the icon.)

Managed to reproduce and fix issue. In fact, it wasn't so nice idea of always using large icons for search menus in commit 28779. Now it should behave properly.

It was wrong patch attached. Attaching correct one.

Fixed update of brush texture in sculpt mode.

Patch looks ok to me, only suggestion from me is in interface_layout.c and interface_templates.c, it could use the ICON_SIZE_PREVIEW/ICON_SIZE_ICON constants there?

Fixed in svn rev44192. Thanks for the report, tests and review!

Sergey Sharybin (sergey) closed this task as Resolved.Feb 17 2012, 5:08 PM