Page MenuHome

Motion Trail: display and edit motion trails in the 3d-view
Closed, ArchivedPublic

Description

Project: Blender Extensions
Tracker: Py Scripts Contrib
Blender: 2.60
Author(s): Bart Crouch
Script name: Motion Trail
Homepage: http://sites.google.com/site/bartiuscrouch/scripts/motion_trail
Wiki page: http://wiki.blender.org/index.php/Extensions:2.5/Py/Scripts/Animation/Motion_Trail
Category: Animation
SVN Download: http://projects.blender.org/scm/viewvc.php/*checkout*/contrib/py/scripts/addons/animation_motion_trail.py?root=bf-extensions
Status: Open

The add-on uses right-mouse button to select and Q-key to move. Press Q-key again to confirm movement or Escape-key to cancel.
Note: you can't select a keyframe, handle or timebead when it is located on top of an object.

There are 3 modes in the add-on: Location, Speed and Timing.
* Location: select a keyframe or handle and move it to change the location data of the object's animation path.
* Speed: select and move a timebead to change the speed-in or speed-out of the associated keyframe.
* Timing: select and move a single keyframe to change the location of that keyframe on the timeline. Selecting and dragging a timebead moves all keyframes (except from the first and last one) on the timeline.

The Speed and Timing mode don't change the location of the object , only the speed. This holds true as long as the handles in the graph-editor don't overlap.

The motion trail can display different colours. Most interesting are the speed and acceleration gradients.
Speed: blue is slow, red is fast
Acceleration: green is positive, yellow is no acceleration, red is negative acceleration.
Note: the colours are relative. So each is speed gradient contains both 100% blue and 100% red.
Warning: At the start and end frames the gradients might be slightly off.

Event Timeline

I'm not certain about the proper procedures, but can I move this to contrib when I make it pep-8 compliant?

Hi! With the new wiki stuff going on i had no time to try this but judging from the vid, for me this could go even in trunk!

Alright, I'll move it to contrib when I'm done making it pep-8 compliant and after that other people can decide upon moving it to contrib.

Version 2.0.1
Small fix to have it work correctly for people using left-mouse button selection.

previous message should have been:
Alright, I'll move it to contrib when I'm done making it pep-8 compliant and after that other people can decide upon moving it to TRUNK.

Hi I'm using blender 2.57 trunk 36147 downloaded from blender.org .
When I try to install the script it says:

Traceback (most recent call last):
File "C:\PROGRA~1\BLENDE~1\Blender\2.57\scripts\startup\bl_ui\space_userpref.py", line 1075, in execute
pyfile = self.filepath
File "C:\PROGRA~1\BLENDE~1\Blender\2.57\scripts\modules\bpy_types.py", line 626, in __getattribute__
return getattr(properties, attr)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xe7 in position 60: invalid continuation byte

(made some modification you now command line does some breaks)

I went to User Preferences -> Install Addon
What should I do?

João Araújo, thanks for reporting.
I've taken a look at your problem and it seems this is an error caused by Blender, which is not specific to the MotionTrail add-on. The filepath contains a character that Blender can't read (is it a ç?).

Could you please test if you also get an error when installing any other add-on from the same filepath?
If you get an error with other add-ons as well (which is what I expect), I recommend you post this to the main bug tracker ( http://projects.blender.org/tracker/?atid=498&group_id=9 ).
If other add-ons at the same filepath install correctly, please post here again. It would also be convenient if you could post the filepath of where the add-on is located on your computer. Especially the 60th character is interesting as that is what Blender breaks on.

FOUND THE SOLUTION!

I went to the text editor, paste the script there, hit RUN SCRIPT and no errors were found.

My conclusion: This is a bug of the Preferences addons installer.

hey Bart, as said above feel free to move this in svn/contrib so that eventually it'll get more testers :)

Hi Luca, a new version is currently in development, addressing a lot of bugs.
I'll move this item to contrib simultaneously when releasing the new version.

hi, maybe we could get this immediatly moved?
thanks, bart, drop in to irc please asap.

hi, updates for matrix reversal rev 39800

Update for matrix reversal isn't fully functional, I'll check up on it soon.

Hi,
Just a Reminder for people to Join the Mail List.
If you have not already, please visit this page:
http://lists.blender.org/mailman/listinfo/bf-extensions-cvs
& join the list.

Hi,

It looks like the orientation ( matrix ) in the viewport still doesn't work in 2.6 RC1. Just to follow-up.

Just tested in OS X 64 Bit 2.60 rc1 and it works initially but the path seems to adjust incorrectly when you adjust the viewpoint, either by switching with the numeric keypad or by rotating / panning the view with the mouse. Subsequently, the axes that you haven't yet moved in seem to be exaggerated. Also made it crash by moving some motion trail created keyframes in dopesheet, then dis / re enabling the addon to try and update changes...

Moved from Py Scripts Upload to Py Scripts Contrib

Moved to contrib and fixed change in matrix multiplication order (blender 2.60).

r43210 win_x64

When clicking on handle in motion trail view I have a following error in console and addon stops working (sometimes blender crash, especially on quit):
----------------------------------------------------------------------------
Traceback (most recent call last):
File "C:\Program Files\Blender Foundation\Blender\2.61\scripts\addons_contrib\animation_motion_trail.py", line 1451, in modal
handle_type
TypeError: bpy_struct: item.attr = val: enum "AUTO_CLAMPED" not found in ('AUTO', 'VECTOR', 'ALIGNED', 'FREE')

location:<unknown location>:-1
----------------------------------------------------------------------------

Czarek Kopias,

just try a new build...this issue was fixed 2 hours ago..

Greetings

Hi,
Due to changes to the api including the merging of bmesh, several addons are outdated.
Please, if you are the author of an addon check your script with blender revision 44256 or newer.
That is builds made After blender 2.62 official release.
I would ask that updates be made to your addon before the Blender 2.63 release.
6-8 weeks away.
This allows time for the api to become more exposed & bmesh to stablize furthur.
If you need help, drop into irc freenode #blenderpython or #blendercoders & feel welcome to ask questions.
At the time of 2.63 release, scripts that are not repaired or in active developement will have their tracker page marked "Closed"
this will not affect your links to the tracker, similar to closing scripts in 2.49b, the page will be still availible & can be re-opened.

Thanks for your understanding & patience during these Exciting Times.
Brendon.

Trying to enable motion trail, I encountered the following error:

Traceback (most recent call last):
File "/Users/ … /Blender/2.62/scripts/addons/animation_motion_trail.py", line 1481, in invoke active.keymaps['Object mode']]
KeyError: 'bpy_prop_collection[key]: key "Object Mode" not found'

location:<unknown location>: -1

I thought that was odd... Any help out there?

@Brock Haffner: that's indeed weird. It might be because of a change in the Blender keymaps. I'll add it to my list, thanks for reporting.

I can confirm that the bug Brock Haffner reported still exists in 2.65 (64bit) r52859 (official release). I hope you can get this fixed, as motion trail is an incredibly helpful feature when animating. It's really the only thing I kept missing from Cinema4D.

Sorry for the DP, but I thought this might help:
Motion trail works in all blender-versions up to (and including) the RC 1 of blender 2.65 (r52667), but not in the release. I don't have any build in between r52667 and r52859 to test, but that at least narrows it down a bit.

The exact error I'm getting is this:

Traceback (most recent call last):
File "C:\Program Files (x86)\Blender Foundation\blender-2.65-release-windows64
\2.65\scripts\startup\bl_ui\properties_game.py", line 262, in poll
@classmethod
KeyboardInterrupt

location: <unknown location>:-1

location: <unknown location>:-1

Sorry again, wrong errormessage:

Traceback (most recent call last):
File "C:\Program Files (x86)\Blender Foundation\blender-2.65-release-windows64\2.65\scripts\addons\animation_motion_trail.py", line 1481, in invoke
active.keymaps['Object Mode']]
KeyError: 'bpy_prop_collection[key]: key "Object Mode" not found'

location: <unknown location>:-1

location: <unknown location>:-1

Third time pays for all.... I think I have found a temporary fix:

Line 1481 presently is
"active.keymaps['Object Mode']]"
If you change this to
"active.keymaps['3D View']]"
it will work. Notice that I've got no idea what this line does exactly (I guess it sets the keymap to objectmode, but have no clue why this is done). So I can't say if it leads to any problems anywhere else in the script. So far I have found the script working as it is supposed to after changing the line.

I think I found a bug: when input settings are changed to selecting with LMB (instead of RMB), the viewport trail works ok (selection, grabbing, scaling etc).

However, when I try to click on any option on the 3D View Toolbar [T key] (like changing the node handle type, for example), the trail selection (a node or a handle, in that case) becomes unselected.

Maybe because the script detects a Left-Click, then tries to select another thing?

This task was automatically closed as archived as part of migration, because it was determined to be no longer active.

The authoritative list of addons is on the wiki, we no longer have a report for each addon to track bugs and updates. Bugs can be reported individually and assigned to the addon developers. See the Add-ons project page for more information on the workflow.

Nobody (None) closed this task as Archived.Mar 5 2011, 7:50 PM