Home

Operator.draw(): UI doesn't redrawn
Closed, InvalidPublic

Description
Hey there!

Operator's popup is not redrawn when chaging some value.

Test script: http://www.pasteall.org/19842/python

Click bool prop - UI doesn't updated.

Thanks in advance!

Best regards,
Andrey
bdancer (Andrey Izrantsev) set Type to Bug.Via Old WorldMar 12 2011, 1:42 AM
assigning to myself, I looked into this before but will try find some solution.
lichtwerk (Philipp Oeser) added a comment.Via Old WorldApr 13 2012, 3:49 PM
I can confirm this. This also affects some of the addons that are shipped (e.g. "AddCurve:Sapling", "AddCurve:CurveaceousGalore", ...)
ton (Ton Roosendaal) added a comment.Via Old WorldOct 21 2012, 1:13 PM
Bump up to Campbell if this a current issue for him, a todo for later, or something for someone else tackle :)
ton (Ton Roosendaal) added a comment.Via Old WorldNov 2 2012, 1:01 PM
The redraws are all OK - but the issue is that our menu popups are only generated once, with a fixed region boundbox and static defined options.

What you want is a persistent panel with dynamic amounts of buttons and settings. For such cases popups shouldn't be used - and not will become available either.

I will put on my short term todo: general option for operator buttons to draw its properties as permanent set of options. That's what we intended with Blender design spec to make a non-modal parellel working UI :)
ton (Ton Roosendaal) closed this task as "Invalid".Via Old WorldNov 2 2012, 1:01 PM

Add Comment