Alt+N, Enter In Image View Does closes the dialog without executing.
Closed, ResolvedPublic

Description

Title says it all, easy to test.

Details

Type
Bug


confirmed on ubuntu 11.04 64 bits rev41945

Regarding to comments in ui_handle_menu_event() from interface_handlers.c this is intended behavior. Probably because of this code is shared with menus and popup-s.
Probably logic can be splited for menu and popups. Brecht, what do you think about this?

I'm not sure what you mean by splitting logic, how big a change that would be? A bugfix in revision 33696 changed this from OK to CANCEL. But I guess it should be OK for this case still, then popup_func can be used?

Fixed in svn rev42125. Thanks for the report and review. Closing report now.

Sergey Sharybin (sergey) closed this task as "Resolved".Nov 24 2011, 2:52 PM