Strange crash using translated Blender
Closed, ResolvedPublic

Description

Hi. I'm a translator for the spanish version. I'm working by running blender and checking the UI for terms and then translating them, but I've reached to a point when Blender crashes and I couldn't determine why. Follow this steps:

1) Change translation to spanish or whatever you want, so you can see the UI in a non-english language. (You can do the next steps in english and then change to another language, so you don't lose)
2) Create an Armature and Select it
3) Go to the Object Data panel and search for the iTaSC parameters section
4) Change Legacy to iTaSC
5) Now, (in a non-english language) try to leave the cursor over either the Animation or Simulation buttons to see the text that describes the button's functionality > Crash.

I've figured out that this bug is just related to other languages except the original in english. Couldn't determine why. I've seen the original text and english and translated it to it's equivalent in spanish (and replaced the .mo to see the changes), but this crash appears again if I do the step 5 over again. I'm using the last Blender update.

Blender r42566
LinuxMint 12
QuadCore 3.2Ghz
4 GB RAM
Nvidia GT 240 (290.10 driver)

Details

Type
Bug

Confirmed. Looks like simple NULL-pointer check is needed, but prefer to ensure how RNA descriptions were supposed to work with Campbell.
Assigning to self.

Fixed in svn rev42569. Thanks for the report, closing it now.

Sergey Sharybin (sergey) closed this task as "Resolved".Dec 11 2011, 4:50 PM