Page MenuHome

Proxies Not Visible in VSE Preview Window until Blender Reboot
Closed, ResolvedPublic

Description

I have a very large, HD video to edit in the VSE. So, I sought to learn the proxy system so that I could scrub through it and do the editing in a reasonable amount of time.

I followed the instructions a poster gave at this thread at BlenderForum: http://blenderartists.org/forum/showthread.php?245586-Proxies-in-the-VSE

However, I could not see the proxies in the VSE display even after generating them. Eventually, I saved it and walked away. When I returned and rebooted Blender, the proxy sequence was visible!

I tried this several times, and it was always the same: the proxy sequence doesn't appear in the VSE display window until Blender is rebooted.

(One related note, which is probably not a bug: I could not figure out how to make the Proxy sequence one type or another. Initially, it was an Image Sequence. Now, it's a .AVI. I don't believe that I changed any settings, and I couldn't alter it. This is probably an issue with the interface rather than any bug, though.)

Blender v. 2.61
OS: Windows XP
32 Bit

Attached is a .Blend with 30 seconds of the sort of footage I used.

Details

Type
Bug

Event Timeline

Perhaps it's just misunderstanding how proxies stuff works in blender.
You need to enable Proxy / Timecode checkbox in panel, then choose resolutions you want to build proxy for, then go to menu Strip -> Rebuild Proxy and Timecode indices. After this you can go to View Settings panel, and set Proxy Render Size to some value you want (and for which proxy was generated). This will switch sequencer to display proxied videos instead of original. This option belongs to Sequencer editor, so if you're using another editor for display (as it is in file you're using and how it's configured in Video Editing screen) you need to open N-panel of sequencer used for preview, scroll down to View Settings panel and set proxy render size there.
The only possible issue here is that if you've switched to proxy preview before proxy job finished, empty frames might be cached and then displayed in preview, but in another cases it's just works.
About proxy type.. I'm not sure why you need to control this. Current logic is the following: for video files .avi files are creating, for image sequences image sequence is created.

Sergey,

No, I'm doing everything properly. I understand everything you wrote, and that's what I've been doing. For me, on my program and my PC, when I try to get the Proxy to display in the VSE display, it just shows up as black. I have to save, close the program, then reload. And THEN the Proxy appears.

It's not a huge deal (although it was very frustrating before I figured out I could do this), but it's clearly a glitch or flaw of some sort.

I literally just did it again on a completely new file, and the exact same thing happened: when I tell the VSE display to show the Proxy, it turns black. The only way to get it to appear is to reboot the program (at least that's the only way I've been able to get it to appear.)

(Also, I now see why I was getting an Image Sequence for the Proxy early on, rather than a .AVI. I was creating a Proxy for a Meta Strip. If you do that, you'll see that it automatically creates a folder and an Image Sequence. No big deal.)

I can't see differences in how metastrips behaves. Proxy builder walks recursively into meta strips and builds proxies for movie/image sequence strips only. I've tried plenty of setups here and the only case when i do have black frame instead of proxy happens when i'm changing Proxy Render Size before proxy building finished. It's independent on if video strip is inside meta strip or not.
Can you provide detailed exact steps of what you're doing? It's either different things we're doing or something more crappy reason like things-dependent-on-particular-OS-setup. It might a screencast, too. But bug tracker allows to attach files which are less than 5Mb only, you might use ftp://download.blender.org/incoming for sharing.

Btw, Are you using official release and does it happen with all video files you've tried?

Sergey,

I attached a 1 MB .Blend to this originally, and I've been using an identical set-up for each subsequent attempt.

You noted that maybe this is an issue with the OS. That might well be the case: I know it happened to at least one of the problems that I reported as a Bug, and it was fixed in the SVN.

I can't do a screencast because my computer is too slow. But it's really not complicated at all: I'm doing everything that anybody else would do, but the Proxie simply doesn't display until I reboot. If you can't replicate it, then perhaps somebody with a similar OS has to try it.

Triend win7 32/64 bit and winXP 32bit. In my cases all worked fine.. Maybe somebody else from developers will be able to reproduce the issue.
Two thing:
- video in provided file is missed -- they aren't getting backed into .blend and need to be distributed separately.
- i've just commited some changed to proxies (svn rev44177). Can you test blender at least rev44177? It should be available at http://builder.blender.org/download/ relatively soon.

I tried to verify and test this behaviour. While I couldn't reproduce the case that the proxy doesn't show up at all, I did in fact discover that the current frame wasn't showing up if you switch to proxy display before the proxy indices have been calculated.

Steps to reproduce:
1. In Blender VSE add a movie strip starting at frame 1.
2. Switch on dual strip/preview view in the header
3. move the current frame to frame 100 or so (doesn't really matter, just make sure the frame isn't black)
3. hit N to show the properties of the strip.
4. Check proxy / timecode and leave the proxy resolution at 25
5. Go further down to the view setting panel and for proxy render size choose 25%
==> now the preview will be black since we haven't calculated the prosy indices yet
6. Select the strip and in the Strip Menu choose "Rebuild Proxy and Timecode Indices"
7. Wait until finished (watch the small progress bar in the header of the VSE)
==> the preview is still black
8. now go forward or backward a few frames and back
==> you will see that the previously current frame still is black.

Save the .blend file
Re-open the .blend file (don't need to restart blender)
==> Now the frame shows up fine.

Issue Andrea described was fixed in svn rev44358. Pretty much sure there should be no blender restart needed after rebuilding proxies needed now.
If the issue will still occur for you, please check if "Refresh Sequencer" button helps you and also provide step-by-step instructions how to run into your issue.

Sergey Sharybin (sergey) closed this task as Resolved.Feb 23 2012, 9:43 AM