Page MenuHome

Left/Right vertex weights flipped
Closed, ResolvedPublic

Description

Open the attached .blend file in a pre-bmesh version of Blender (2.62 official should be fine) to see the expected behavior by rotating one of the arm bones. Open the same .blend file a version of Blender after the bmesh merge and you should notice that the influences are flipped. The right arm bone deforms the left arm on the mesh and vice versa. My suspicion is that this stems from the fact that the armature is deforming a mesh with a mirror modifier on it. However, it works properly in Blender prior to bmesh, so the expected behavior is that this will continue to work properly.

This can be resolved in the .blend file with a simple python script that switches the names of all of the .R and .L vertex groups... however I'd rather not have to run that script on every .blend file where I encounter this problem.

Details

Type
Bug

Event Timeline

I encountered the similar problem but in my case the vertices data become utterly broken. (I don't know if this is exactly the same or not.)

Please load the following file (This is the famous "Hatsune Miku" model in Japan):

http://kiomodel.sakura.ne.jp/modeldata/KioMiku_blender_20091010.zip

The right/left vertices of the hair and the skirt should be flipped.

Fixed in svn44299.

Was indeed Mirror modifier flipping vgroups on original vertices instead of mirrored one… And poor Miku gets back her hair and skirt too, so it was indeed the same problem!

Closing, thanks for reporting. :)

Bastien Montagne (mont29) closed this task as Resolved.Feb 21 2012, 3:47 PM

Thanks, Bastien.

BTW, typing Alt+A in the Miku's blend file starts the animation, but the collision doesn't work at all. Probably this is the same as [#30268] because Miku's hair and skirt use the cloth collision.