Page MenuHome

Fluid-Sytem does not work! (R-2.62)
Closed, ResolvedPublic

Description

The Fluid-System does not work!. In both (32 and 64 Bit)-Systems. Checked on different Windows-7 Systems. The Fluid-System is Static and the Cancel-Button (Cross) does not work! The only thing to interrupt the Fluid-Baken ist to terminate the Programm with Taskmanager.

Details

Type
Bug

Event Timeline

It works fine here on windows 7 64/32 bits.
Does it happen with all scenes or just with a particular setup? Anyway, having sample .blend file will help making sure we're using exactly the same configurations.

O.K. I have Upload my Scene-File as Attachment and you can Test it. The Sphere as Flow-Objekt (InFlow) works perfect in V-2.61 but in V-2.62 there is a static Flow (All the same like Frame-1- and no "Flow"...) and the Cancel-Button does not work!. On two different Windows-7-Versions tested and on every System V-2.61 works but V-2.62 does not work! (Sorry for my bad English!)

Regression was caused by commit 43593 where speed control was added. In your case Speed is set to zero (maybe versioning patch issue or it was set to zero accidentally). If you set it to 1 behavior will be exactly the same as in 2.61 release.
I'm not sure if it's issue from blender side or elbeem (who doesn't break simulation for totally still setup).
Daniel, you seems the only developer who is active enough and familiar with elbeem code, can you please check this report? Thanks!

The code in the version patch in that commit is wrong:
FluidsimSettings *fss = (FluidsimSettings *)md;

Fix in svn, thanks for the report.

Brecht, that versioning thing is indeed very bad, but it just solves one particular side of the issue -- old file now behaves in the same way as in previous release. But it does not resolve issue with cancelling bake when Speed is set to zero. Either we need to disallow setting speed to zero or we need this to be fixed from elbeem side.

I would fix this from elbeem side.
Would be cool to have effects like having a camera flying around a time-stopped splash and then time goes on as normal.
Will (hopefully) fix this before next blender release.

Canceling the sim with speed = 0 should work again in svn.

Thank you for reporting.

Daniel Genrich (genscher) closed this task as Resolved.Apr 22 2012, 7:32 PM