Page MenuHome

Can only alt+scroll image buffer slot once
Closed, ResolvedPublic

Description

This is a minor issue but it still bugs me. In the UV/Image Editor, I want to cycle through the image buffers with alt+scroll on the slot list on the header. Problem is this only works once, since the next scroll will change the frame by 1. I have to move the mouse slightly on the slot list every time I want to alt+scroll to the next buffer. This is only on the header. Doing it in the properties (N-key) I can scroll through the whole list without moving the mouse. Unfortunately there's also a minor issue here in the properties. Since an empty buffer doesn't have a Curves panel, the whole interface jumps up and the slot list is no longer under the mouse. It is much preferable doing this on the header anyway.

OS: Linux
Tested on revision 44546 - 44608

Details

Type
Bug

Event Timeline

Developer's note:
Issue is caused by mapping old buttons to new buttons. Render slot button in header holds RenerResult for particular slot, but in N-panel it hols RenderResult from RenderEngine. So what's happening is: switching render slot to empty slot makes slot button in header contain NULL as button function's argument, but old button holds RenderResult for rendereed image, so this two buttons aren't equal and so button isn't getting activated and no scrolling happens.
Making slot button hold RenderResult directly from RenderEngine (as it's happening with buttons in N-panel) makes old->new buttons mapping work correct and it's possible to alt-scroll smoothly. Looks quite safe change, but maybe Brecht can verify this (patch is in attachments)?

Patch looks ok to me, please commit :)

Commited to svn rev45168.
Thanks for both of report and review.Closing now.

Sergey Sharybin (sergey) closed this task as Resolved.Mar 26 2012, 1:45 PM