Page MenuHome

Particle simulation, rekey crashes blender
Closed, ResolvedPublic

Description

While creating screenshots for the wiki/manual I also tried testing the information on the page.

I've run into a reoccurring crash where trying to rekey a selected particle path in particle mode "W menu > Rekey" causes blender to crash.


Blender 2.62
Win7 64bit
Plenty of ram and CPU

Details

Type
Bug

Event Timeline

I've got a crash here when i'm trying to enter particle edit mode for circle. Probably it's somehow related issues?
Clearing baked cache seems to help here (i can enter particle edit mode and run rekey normally). Maybe crash is caused by missed cache file? Anyway don't think it's nice experience to crash here.
Janne, can you please check this?

The crash when entering particle mode is now fixed in r45026, but unfortunately the rekey operator was only intended to work with hair, so only possible fix currently was to disable this for non-hair editing. I also disabled a couple of other "only hair" operators such as subdivide and remove doubles if the editable thing is not hair.

Janne Karhu (jhk) closed this task as Resolved.Mar 20 2012, 2:02 PM