When "append", actions with users get lost after re-opening the blend
Closed, ResolvedPublic


After making an "append" on an armature, I have to chek the "F" box (Save this data block even if it has no users) on every actions to avoid losing them when re-opening the blend.
This happens although those actions are used in constraints/Actions.
This happens (at least) on 2.62 and 2.63

Screen : http://i43.servimg.com/u/f43/11/23/98/17/action10.jpg

Thank you :)

Emmanuel Méritte (bubble) set Type to Bug.Via Old WorldMay 6 2012, 3:43 PM
Joshua Leung (aligorith) added a comment.Via Old WorldMay 7 2012, 1:59 AM

Could you please try again in the latest svn to see if some of these problems are at least partially resolved first?

Emmanuel Méritte (bubble) added a comment.Via Old WorldMay 8 2012, 2:38 AM

Well, as I had other bugs with 2.62 (crashes, error messages) I had to go back to 2.61 that looks more stable to me.
And my old XP machine can't afford being spammed with several installations and tests. (Really :( It doesn't even have a working sound card any more... )

but I can say that this "F users Actions loss issue" i've reported here was already present in the 2.61 version. So it's not a new issue.
I used to work with 2.49. I never had that problem, as I can remember.

Sergey Sharybin (sergey) added a comment.Via Old WorldMay 8 2012, 10:56 AM

Joshua meant there were some fixes after 2.63 release which might resolve your issues. If you want them to be resolved, you'll need to upgrade to newer blender version, right? ;)

Sergey Sharybin (sergey) added a comment.Via Old WorldMay 22 2012, 12:47 PM

Emmanuel, we really need to know if it's still issue with the very recent version f blender. Also sample minimal .blend files would help a log.
Bug tracker is like a collaboration tool between artists and developers -- there're lots of artists and only few developers, and having more effort from artists helps really a lot.
It was no activity here for couple of weeks, so will close for now. Will re-open when more info would be provided.

Emmanuel Méritte (bubble) added a comment.Via Old WorldMay 23 2012, 12:46 AM

I've just tested with 2.63a on an another computer (windows XP).
The issue still remains.

Sergey Sharybin (sergey) added a comment.Via Old WorldMay 23 2012, 12:18 PM

Reopening and assigning to Joshua.

Emannuel, still having sample file might help here :)

Emmanuel Méritte (bubble) added a comment.Via Old WorldMay 23 2012, 6:10 PM

You can find a blend here :

Explanations :
- Armature layer 1 : use those bones by scaling them
to move finger bones.

- Armature Layer 2 : finger bones with bone Action Constraints assigned to.

- Other layers : all other bones using
no actions.

What happens ?
1- Append the armature in a new blend
2- In the Action Editor : the "F" before the action names
has disappeared
3- After saving the new blend and re-opening, a zero appears
before the action names.
Actions get lost at next re-opening.

Joshua Leung (aligorith) added a comment.Via Old WorldJun 11 2012, 6:49 AM

Can't reproduce any action loss here, and things seem to work fine after several save/reload cycles (r.47720).

I did notice that upon appending the fake users are indeed removed. However, this is not important as action constraints now give the referenced constraints users. So perhaps in 2.63a only some of the commits I made to fix related issues here were actually merged.

I'll mark this as resolved in the meantime. But, please do check whether the problem is solved for you in the latest test builds.


Joshua Leung (aligorith) closed this task as "Resolved".Via Old WorldJun 11 2012, 6:49 AM

Add Comment