Dual quaternion skinning behaves strangely with scaling
Closed, InvalidPublic


When a mesh has an armature modifier on it, and the bones of the modifier are both rotated and scaled, strange deformations occur that are not expected.

See in the attached blend file. When you play back the animation, the bones first rotate to bend the mesh, and then they uniformally scale to a smaller size. One would expect the mesh to also uniformally scale to a smaller size, but instead the mesh expands (relative to the size of the bones) in a strange way. Similarly--though more subtly--when the bones are scaled non-uniformally, one would expect the mesh to also scale in the same way as the bones, but similar strange deformations occur as in the uniform case.

This is very problematic for rigs that need to allow the scaling of bones (e.g. for flexy rigs, squash-and-stretch, etc.)

I'm not sure if this is an inherent limitation of dual quaternion skinning. If it is, then oh well. But if it is not, then it needs to be fixed.

Ton Roosendaal (ton) added a comment.Via Old WorldOct 20 2012, 1:15 PM

Bump up to brecht to check on this :)

  1. This is an old report an unlikely to be tackled anytime soon
  2. I read a bit about dual quaternion skinning and if I understand correctly this is a known limitation of the original algorithm. It was improved in the meanwhile, but that would be a feature request, not a bug

So I think after 2 years it's time to close this \o/

Julian Eisel (Severin) closed this task as "Invalid".Via WebDec 23 2014, 4:50 AM

Add Comment