Blender crashes badly on startup (OSX PPC 10.5.8)
Closed, InvalidPublic

Description

Specs: PowerMac G5 dual 2.0GHz, OSX 10.5.8, 4GB RAM, ATI X800 XT (256MB)
Blender versions: 2.62, 2.63, 2.63a

Every Blender version since 2.61 crashes badly on startup. A blank window opens, the pointer becomes a "spinning beachball" and the OS locks up, ignoring all keyboard input and mouse clicks. Because the OS locks up, there is no way to "Force Quit" Blender and no crash log is generated. The only way to continue is to hold the power button to shut off the computer.

I suspect that a change was made in version 2.62 which causes problems with the ATI X800 XT card. (a farily uncommon card)

mevans (M Evans) set Type to Bug.Via Old WorldJul 7 2012, 4:49 PM
sergey (Sergey Sharybin) added a comment.Via Old WorldJul 12 2012, 12:31 PM

Jens, AFAIR we had quite the same issues? And AFAIR there used to be a way to run blender in software gl mode on OSX to check whether this is indeed driver/opengl related issue?

jensverwiebe (jens verwiebe) added a comment.Via Old WorldJul 12 2012, 2:26 PM

Hmm, reporting this sooooo late is bad, due we would have to bisect lot of revisions.
I just can say that all is fine on PPC G4 with ATI Radeon and also under Rosetta where i test
after compiling for general buildquality.

I propose some openGL specialist should look over the code as we also have a small glitch
with some gdx under OSX 10.7 it seems ( # 31165 ).

Personally i cannot reproduce any problem atm..

Jens

mevans (M Evans) added a comment.Via Old WorldJul 12 2012, 2:52 PM

I'd like to be able to give more information to help solve this. Is there a debug version I can run that will save (or show) detailed information? Or is there a debug software I can use to get more information? (remembering that the OS completely locks up and the computer must be shut off - possibly corrupting open files)

dingto (Thomas Dinges) added a comment.Via Old WorldSep 24 2012, 7:34 PM

Closing this report, we are in the process of dropping support for PPC due to issues and it becomes more problematic to support PPC with new libs etc.

dingto (Thomas Dinges) closed this task as "Invalid".Via Old WorldSep 24 2012, 7:34 PM
mevans (M Evans) added a comment.Via Old WorldSep 27 2012, 12:13 AM

OK. I'll just have to be content with 2.61. Thanks.

Add Comment