Home

Changing layer broken for objects shared by multiple scenes
Closed, ResolvedPublic

Description
Hi,

I have an object that is shared by multiple scenes. If I change the layer
of the object in one scene, often the object will jump back to the old
layer due to the instance of the object in the other scene.

Probably changing the layer on any given scene should update
the layer of the other instances of the object in other scenes
too. Either that, or the layer of the object should be moved
from the Object data structure to whatever data structure is
used to link objects to scenes.

Chris
hos (Chris Want) set Type to Bug.Via Old WorldJul 27 2012, 12:51 AM
This isnt a bug, layers are a scene property - not owned by the object.
hos (Chris Want) added a comment.Via Old WorldJul 27 2012, 2:00 AM
HI Campbell,

It is a bug -- if you change the layer of an object in a scene,
and later while you're working, the layer jumps back to the
old layer in that scene, then that is a bug. No user would
possibly want or expect that behavior. If layers are a scene
property, then this should not happen, so somewhere in
the system the layer of an object in one scene is getting
updated with the layer of the object in another scene.
Smells like a bug to me.

Chris
Ah, if they jump between layers from within the same scene this is indeed bad (should only be when switching scenes).

This threw me
"""Probably changing the layer on any given scene should update
the layer of the other instances of the object in other scenes
too."""

Not sure what you mean here, the Base->lay (objects instance in a scene), can be different in each scene by design.


Can you give steps to redo bad jumping between layer behavior?
hos (Chris Want) added a comment.Via Old WorldJul 30 2012, 4:46 PM
Thanks Campbell, this behaviour has happened a few times, but I'm finding it hard to replicate the steps to reproduce it. When I do, I'll upload a blend.

Chris
Hi Campbell,

I think I've created a blend (layer_bug.blend, attached to this follow up) and a recipe for reproducing this bug:

0) Load layer_bug.blend
1) Change scene to "Scene" and observe that all objects are on layer 1.
2) Change scene to "SceneLinkedCopy" and observe that all objects are on layer 2.
3) Change scene back to "Composite" and hit F12 to render -- you'll see a cube.
4) Next change the *screen* from "Default" to "Compositing" and press F12 to render -- you'll see no cube
5) Now change the *screen* back to "Default" and the scene to "Scene" -- huh? All of the objects have jumped from layer 1 to layer 2.

I hope these instructions are understandable, and that you are able to reproduce the behaviour that I get here!

Cheers,
Chris
ton (Ton Roosendaal) added a comment.Via Old WorldNov 4 2012, 3:36 PM
Putting on my list
ton (Ton Roosendaal) added a comment.Via Old WorldNov 4 2012, 7:46 PM
Confirmed - fishy stuff here. Will dig into tomorrow.
ton (Ton Roosendaal) added a comment.Via Old WorldNov 6 2012, 7:07 PM
And the fix goes to svn. Error of 2.5 years old, in beginning of 2.5 period.
ton (Ton Roosendaal) closed this task as "Resolved".Via Old WorldNov 6 2012, 7:07 PM
hos (Chris Want) added a comment.Via Old WorldNov 6 2012, 7:11 PM
Thank you Ton!

Chris

Add Comment