Home

new objects and Units scale
Closed, ResolvedPublic

Description
build r49249
os: win7 64bit

when changing the Units "Scale" then not all objects that are created are affected by that unit.

reproduce scenario:
1. set the units scale to 1.0
2. create a cube and a camera
3. now change the units scale to 0.01
4. create a new cube and a camera again.
5. now the created cube gets huge while the camera is still the same size.

not sure whats going oin here but either the cube is way to big and should not have a edge length of 2m anymore but 20mm or the camera that gets created should be way bigger and all the clippings aadjusted acordingly. but i would guess the cube gets the wrong initial size.
kromar (dan grauer) set Type to Bug.Via Old WorldJul 30 2012, 9:47 AM
sergey (Sergey Sharybin) added a comment.Via Old WorldJul 30 2012, 9:49 PM
This isn't a bug. When you scale units newly added meshes are creating in a way to match this units. It's mesh itself which is being scaled, it's not object scale is being applied. Camera always has got the same size wich could be affected by object's scale, which is in your case is always (1.0, 1.0, 1.0)

It could be confusing in some cases, but wouldn't conside it a bug. Thanks for the report, but closing it now.
kromar (dan grauer) added a comment.Via Old WorldAug 28 2012, 2:36 PM
well, it seems that only the default cube is affected by the unit scale, all other default meshes remain the same size on creation:D
kromar (dan grauer) added a comment.Via Old WorldSep 27 2012, 3:28 PM
why exactly was this report closed?
the bug is still there!

create a cube with different unit scale (1 / 0.1) and then create any other object with different unit scale (1 / 0.1) and see the difference.
the cube that was created with 0.1 scale is 10 times bigger than all the other objects you just created.
why would only the cube follow that logic and none of the other objects? makes no sense at all...
sergey (Sergey Sharybin) added a comment.Via Old WorldSep 27 2012, 3:52 PM
Well, looks like misunderstand initial issue. As i understand now some primitives are affected by unit scale and some not. This is indeed strange.
sergey (Sergey Sharybin) added a comment.Via Old WorldSep 28 2012, 2:16 PM
Actually will look into making things unified here.
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 19 2012, 2:58 PM
Fixed in svn rev51423.

Some notes from commit log:

- Lattice is not scaled to grid cell size yet, it uses slightly different add
function which makes scaling a bit tricky and hacky. Would prefer to do a
bit bigger refactor here, so it's a TODO for now.

- Cameras, speakers and other helpers are not scaling. They don't have data
on which scale could be applied and perhaps it should be some kind of draw
scale. Also would consider it's a TODO for now.

Updated TODO list there http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Editors#3D_View

Thanks for the report, would mark as fixed it now. All the rest stuff is for larger redesign of add system.
sergey (Sergey Sharybin) closed this task as "Resolved".Via Old WorldOct 19 2012, 2:58 PM

Add Comment