Memory leak when rendering
Closed, ResolvedPublic


Sys: Ubuntu 12.04 - 64bit graphic card Nvidia GTX 460
Blender builds: multiple
When rendering, total memory on the header just keeps climbing until the sys is locked down. I've tried cycles, and internal; easiest is straight composite through the node editor with a movie clip input. Tried multiple builds from graphicall to buildbot and trunk all have the same problem. Windows builds work fine.

Rian Tut (einstein) set Type to Bug.Via Old WorldSep 2 2012, 6:33 AM
Rian Tut (einstein) added a comment.Via Old WorldSep 2 2012, 9:17 PM

Ok, Today I tried to render the same file i was testing with linux on windows and had the same problem. File is a node editor composite with a large 400 mb AVCHD H.264 clip as the input.
Created a new file with the same general layout and same input file-- rendered fine and total mem didn't go above 230mb's.
However, after saving the file and closing blender --- restarted blender and rendered without changing anything mem went out of control.
Tried a third new file to confirm; allways worked until saving and quitting blender , saving file and reloading without quitting blender doesn't cause a problem either and just a note: changing the compute device or enabling OpenCL in the Node editor didn't seem to change anything.

Brecht Van Lommel (brecht) added a comment.Via Old WorldSep 3 2012, 11:55 AM

Please provide a simple .blend file that we can use to redo the problem.

Sergey Sharybin (sergey) added a comment.Via Old WorldSep 3 2012, 4:29 PM

Fixed issue with movie clip being cached when rendering animation, which wasn't intended.
Please try using blender svn rev50355 (or newer) and see if your issue is resolved (builds would be available at

If the issue would still exist for you, please provide all files needed to reproduce the issue and give exact steps of reproducing the issue.

Attached the file and the video clip. Created the file and tested on windows 7 64bit although linux is same.
1 open file 2 select the attached clip in node input hit render animation and observe the total mem on the header 3 save file and quit blender; reopen and observe the mem.
4 create new file and observe mem repeat step 3.

Rian Tut (einstein) added a comment.Via Old WorldSep 6 2012, 12:43 AM

Nice! problem gone.

Sergey Sharybin (sergey) added a comment.Via Old WorldSep 6 2012, 10:24 AM

Cool to hear this!
Thanks for the report, closing it now.

Sergey Sharybin (sergey) closed this task as "Resolved".Via Old WorldSep 6 2012, 10:24 AM

Add Comment