No pressure sensitivity with Wacom Intuos 5
Closed, ResolvedPublic

Description

Hi

I just bought an Intuos 5 recently and it seems to me that Blender is not able to access the stylus pressure, resulting in lack of pressure levels in sculpting, drawing etc in Blender. I can see that this can be hard to debug since not many devs have access to latest Wacom tablets.

I am using the Wacom driver from August 2012, under Windows 7 64 bit.

Blender and Mypaint (under windows) are the only tools that seems to suffer from this issue which might suggest something to do with cross platform tablet libraries

thanks

k

kursadk (kursad k) set Type to Bug.Via Old WorldOct 5 2012, 4:05 AM
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 18 2012, 1:16 PM

I do have access to this tablet now, however pressure works nicely here on windows 7 64bit. I'm using pro633-4_int.exe driver from official site and using blender 2.64. Will check if removing all wacom drivers (i've got drivers for bamboo and graphire installed since times i've been looking into other bugs) and installing drivers from scratch will make pressure unworkable.

sergey (Sergey Sharybin) added a comment.Via Old WorldOct 18 2012, 1:33 PM

Removed all the drivers and installed pro633-4_int.exe from scratch and blender still operates with pressure nice here. Is it the same driver you're using? And are there some other applications launched the same time you're using blender (there could be some conflict between them) ?

kursadk (kursad k) added a comment.Via Old WorldOct 18 2012, 7:59 PM

Sergey thanks then follow up.

It is interesting to hear that you were able to make wacom5 driver work for Blender.. The driver works just fine here with any other app(Zbrush, Photoshop, Modo etc) regardless of how many other wacom apps are open. The only apps that do not seem to respect the wacom5 drivers are Gimp, Blender and Paint Sai.

I am going to totally uninstall and reinstall the driver to see if it works.

cheers

ton (Ton Roosendaal) added a comment.Via Old WorldOct 19 2012, 7:20 PM

To me this seems to be a system/install/driver issue...

plasmasolutions (Thomas Beck) added a comment.Via Old WorldOct 20 2012, 1:43 PM

Unfortunately, it doesn't work for me too... Ton, didn't you get some intuos 5 sent by wacom last time? So Sergey could eventually test it with one of these?!
I'm under Ubuntu 12.10, linux-wacom drivers supplied with ubuntu. Everywehere else my tablet is working really fine. Tried it with texture paint mode.

sergey (Sergey Sharybin) added a comment.Via Old WorldOct 20 2012, 1:48 PM

Thomas, yes i do have access to intuos 5 now. It worked perfectly for me on Debian Testing and Windows 7. Would download Ubuntu 12.10 and check if it works there.

sergey (Sergey Sharybin) added a comment.Via Old WorldOct 22 2012, 2:22 PM

@Thomas, i've run Ubuntu 12.10 live cd, installed libsdl1.2debian and builds from blender.org recognized the tabled "out of box" -- pressure works perfectly here. Also tried to compile blender myself (recent trunk) after installing some developer pakages. Own build also worked fine here -- pressure was working in both texture paint and sculpting. Had cycles disabled tho, but it shouldn't be an issue i guess.

@kursad, any luck with pressure after re-installing the driver?

kursadk (kursad k) added a comment.Via Old WorldOct 22 2012, 7:52 PM

Sergey Sharybin

Thanks for the efforts. I am at the end of a project deliver, being very busy I was not able to try it. I also did not want to mess with my driver while I am urging to finish my project. However I am going to try the wacom driver issues in couple days. In that regard if you can hold off for couple days about this bug, that would be great.

thanks

kursadk (kursad k) added a comment.Via Old WorldNov 2 2012, 9:41 PM

Hi Sergey

I finally had time to mess around with this. I got to make it work by deleting all my wacom configs and installing the latest nov 2012 driver from Wacom.

Please close this bug, as it seems like there was a fluke somewhere.


thanks

sergey (Sergey Sharybin) added a comment.Via Old WorldNov 5 2012, 1:35 PM

Pardon for delay -- had a week off. Nice to hear the issue is solved for you!

sergey (Sergey Sharybin) closed this task as "Resolved".Via Old WorldNov 5 2012, 1:35 PM
morgothbauglyr (Tobias Reich) added a comment.Via Old WorldDec 7 2012, 4:14 PM

i'm having similar issues with sculpting (intuos 3). when pressure sensitivity is on, the radius becomes maybe 1% of the sert radius at max pressure. low pressure causes crashes. ill try reinstalling the drivers

Add Comment