Home

Selection bug in viewports
Closed, InvalidPublic

Description
I'm having problems with selecting objects (by single RMB click) whenever viewport is displayed in any mode other than "wireframe". The selected object is always the one behind the object I'm actually trying to select, what means, that if there's no other object "in the background" the selection gets done correctly. Selection works fine for region, circle and lasso selection modes.

System and specs:
Windows 7 Home Premium x64
MSI GT-740 notebook, GeForce GTS-250M
Blender 2.64a
lucas (Łukasz Paraszka) set Type to Bug.Via Old WorldOct 5 2012, 6:52 PM
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 5 2012, 7:49 PM
This could be caused by FSAA enabled in video driver settings. Please make sure you're not overwritting FSAA settings for blender and try selection again.

Also, does it happen if you reset to factory settings, duplicate cube several times and try to select some cubes?
Selection works ok when I reset to factory settings. I tried to compare my settings but couldn't find any differences causing this problem. However, I forgot to point, that my startup.blend file was taken from 2.63 version, so maybe that's the case (added an attachment).
What's funny - I did a small test:
1) started Blender, opened any of my files (created in 2.63 or earlier) ->selection doesn't work
2) started Blender, reset to factory settings, opened any of my files (loading UI as well) ->selection works
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 5 2012, 8:33 PM
This is interesting. Quite late here, will check the file tomorrow.
brecht (Brecht Van Lommel) added a comment.Via Old WorldOct 8 2012, 2:46 PM
It's due to the key configuration, if you restore it, it will work again. At the very end of the 3d view global keymap, there's a number of mouse selection entries that are duplicates of the ones higher up, if you remove those it will work again. These were causing the select operator to run twice.

Not sure how this happened, probably an issue with keymap syncing, these operators were changed in 2.64.
sergey (Sergey Sharybin) added a comment.Via Old WorldOct 19 2012, 2:37 PM
Brecht, not sure when exactly keymap matching happens -- seems somehow depends on subverison or so. You're more familiar with this stuff, could you please look into this stuff?

Also actually not sure what would be correct behavior here -- if properties are changing you still could run into conflicts/wrong keymaps pretty easy.
ton (Ton Roosendaal) added a comment.Via Old WorldOct 24 2012, 12:24 PM
Custom keymap syncing with new keymap defaults might be the culprit yes.

We would need your help to present a case for it how to redo such errors. I will have it on my attention list as well, for when people change defaults - that things get tested well. If you can find a case for us to fix, just post it here and we work on it.
ton (Ton Roosendaal) closed this task as "Invalid".Via Old WorldOct 24 2012, 12:24 PM

Add Comment