Switching language does nothing
Closed, ResolvedPublic

Description

Hi,
Switching language (international fonts) in user preferences does nothing.



Regards,

Platform:
================================
Windows 7 x32


OpenGL:
================================
- Renderer: ATI Radeon HD 4770
- Vendor: ATI Technologies Inc.
- Version: 3.3.11653 Compatibility Profile Context


Blender:
================================
Version: 2.64 (sub 6)
Revision: 51698

Mikhail Rachinskiy (alm) set Type to Bug.Via Old WorldOct 28 2012, 2:19 AM
Bastien Montagne (mont29) added a comment.Via Old WorldOct 28 2012, 8:58 AM

Could you please start blender from the command line, with the --debug-all option, try to switch language, and attach here the prints in the console ? Thanks !

Sergey Sharybin (sergey) added a comment.Via Old WorldOct 28 2012, 9:16 AM

@Bastien,
Russian localization works fine here. However, tried Traditional Chinese and it didn't work "Could not change locale to zh_TW". This works in 2.64a. Afraid it's caused by that long/short locale used on windows..

Mikhail Rachinskiy (alm) added a comment.Via Old WorldOct 28 2012, 12:06 PM

Version 264 sub 5 svn r0

ordered
OBCube
wm_subwindow_open: swin 1 added
wm_subwindow_open: swin 2 added
wm_subwindow_open: swin 3 added
wm_subwindow_open: swin 4 added
wm_subwindow_open: swin 5 added
wm_subwindow_open: swin 6 added
wm_subwindow_open: swin 7 added
ED_screen_refresh: set screen
found bundled python: c:\Downloads\26\2.64\python
SRNA Subclassed: 'Context'
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'Menu'
time bl_operators 0.0200
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Bone'
SRNA Subclassed: 'EditBone'
SRNA Subclassed: 'PoseBone'
SRNA Subclassed: 'Mesh'
SRNA Subclassed: 'Object'
SRNA Subclassed: 'Texture'
SRNA Subclassed: 'Header'
time bl_ui 0.0540
SRNA Subclassed: 'KeyingSetInfo'
time keyingsets_builtins 0.0020
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'PropertyGroup'
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'RenderEngine'
addon_utils.enable cycles
SRNA Subclassed: 'Operator'
addon_utils.enable io_curve_svg
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'PropertyGroup'
addon_utils.enable io_mesh_stl
SRNA Subclassed: 'Operator'
addon_utils.enable io_scene_obj
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Operator'
addon_utils.enable mesh_bsurfaces
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
addon_utils.enable mesh_looptools
SRNA Subclassed: 'Operator'
addon_utils.enable mesh_relax
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'Menu'
addon_utils.enable space_view3d_copy_attributes
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Operator'
addon_utils.enable info_creator
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Menu'
addon_utils.enable sculpt_ui
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Operator'
addon_utils.enable some_change
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Operator'
addon_utils.enable volume
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Panel'
addon_utils.enable mesh_extra_tools
SRNA Subclassed: 'Operator'
addon_utils.enable mesh_insert_edge_ring
SRNA Subclassed: 'Operator'
addon_utils.enable object_drop_to_ground
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'PropertyGroup'
addon_utils.enable render_to_print
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Operator'
addon_utils.enable space_view3d_simple_align
Python Script Load Time 0.1850
SRNA Subclassed: 'PropertyGroup'
SRNA Subclassed: 'Library'
SRNA Subclassed: 'KeyingSetInfo'
SRNA Subclassed: 'Group'
SRNA Subclassed: 'MeshEdge'
SRNA Subclassed: 'MeshTessFace'
SRNA Subclassed: 'MeshPolygon'
SRNA Subclassed: 'RenderEngine'
SRNA Subclassed: 'Text'
SRNA Subclassed: 'Sound'
SRNA Subclassed: 'Panel'
SRNA Subclassed: 'Header'
SRNA Subclassed: 'Menu'
SRNA Subclassed: 'Operator'
SRNA Subclassed: 'Macro'
read file
Version 262 sub 3 svn r0
wm_window_make_drawable: set drawable 1
ghost_event_proc: ghost redraw 1
ghost_event_proc: ghost redraw 1
recalcob Cube
recalcdata Cube
ED_screen_refresh: set screen
ghost_event_proc: ghost redraw 1
ghost_event_proc: ghost redraw 1
ui_item_menutype_func: opening menu "INFO_MT_file"
wm_subwindow_open: swin 8 added
wm_subwindow_open: swin 1 added
wm_subwindow_open: swin 2 added
bpy.ops.screen.userpref_show()
WM_operator_last_properties_store: storing properties for 'SCREEN_OT_userpref_sh
ow'
wm_window_make_drawable: set drawable 2
wm_subwindow_open: swin 3 added
ED_screen_refresh: set screen
ghost_event_proc: ghost redraw 2
ghost_event_proc: ghost redraw 2
wm_window_make_drawable: set drawable 1
wm_window_make_drawable: set drawable 2
wm_window_make_drawable: set drawable 1
wm_window_make_drawable: set drawable 2
wm_window_make_drawable: set drawable 1
wm_window_make_drawable: set drawable 2
wm_subwindow_open: swin 4 added
bpy.ops.view2d.scroll_down(deltax=0, deltay=-40, page=False)
WM_operator_last_properties_store: storing properties for 'VIEW2D_OT_scroll_down
'
WM_operator_last_properties_init: loading previous properties for 'VIEW2D_OT_scr
oll_down'
bpy.ops.view2d.scroll_down(deltax=0, deltay=-40, page=False)
WM_operator_last_properties_store: storing properties for 'VIEW2D_OT_scroll_down
'
wm_window_make_drawable: set drawable 1
wm_window_make_drawable: set drawable 2
wm_subwindow_open: swin 4 added
Could not change locale to ru_RU
wm_window_make_drawable: set drawable 1
wm_window_make_drawable: set drawable 2
wm_window_make_drawable: set drawable 1
wm_window_make_drawable: set drawable 2
wm_window_make_drawable: set drawable 1
wm_window_make_drawable: set drawable 2
wm_subwindow_open: swin 4 added
wm_window_make_drawable: set drawable 1

Blender quit

Sergey Sharybin (sergey) added a comment.Via Old WorldOct 28 2012, 1:42 PM

Next time please attach logs as files, not as text in the comment.

Bastien Montagne (mont29) added a comment.Via Old WorldOct 30 2012, 11:45 PM

Here is a short update… I spent (or rather, spoiled) hours on Windoze trying to fix this, and here is the current situation, I think :
* The current gettext runtime in windows lib dir is a rather old version, it has the gettext_putenv helper, but not the setlocale overwrite;
* I tried with a latest binary (1.18.1), from the gnome ftp repository, and got it compiled and linking just well. Now we can without any problem set locales with standard UNIX names under windows but… new gettex has no more the gettext_putenv helper!!! And as blender is compiled with the msvc /MT option (gettext is with the /MD one), it looks like both cannot access to the same envvars, because one use putenv/getenv from one ms runtime CRT lib, and the other from another one…

So either we go back to old, ugly “longlocale” situation (yuck!), or we find a way to build our own intl.dll with /MT option! But finding a valid nmake file for recent gettext looks hard (it is officially no more supported), think will try to contact the gnome team to see who makes those builds (unless they are made with mingw?)…

All this is quite frustrating (not to mention the Big Question: why in hell did it worked fine when I first tested the shorlocales on windows???)…

Bastien Montagne (mont29) added a comment.Via Old WorldNov 2 2012, 9:10 PM

Should bix fix (for now :/ ) in r51825. Thanks for the report.

Mikhail Rachinskiy (alm) added a comment.Via Old WorldNov 3 2012, 12:48 PM

Still not working - r51825
Debug is attached.

Bastien Montagne (mont29) added a comment.Via Old WorldNov 3 2012, 12:52 PM

Grmll… it should do exactly the same as before my changes on windows, now… Will have to switch to that ugly OS another time. :/

Btw, your attachment did not work, it seems…

Mikhail Rachinskiy (alm) added a comment.Via Old WorldNov 3 2012, 1:20 PM

I receive the error when I tried to upload attachment.

Link to the log file http://www.pasteall.org/36851

Attached here the log (you always have to add a comment here when uploading an attachment…).

Looks strange, there seems to be no problem setting the locale (no i18n error message)? Will check under win asap.

Bastien Montagne (mont29) added a comment.Via Old WorldNov 11 2012, 5:58 PM

Hopefully this is definitively fixed in r52106! :)

Bastien Montagne (mont29) closed this task as "Resolved".Via Old WorldNov 11 2012, 5:58 PM

Add Comment