Blender crashes when I start the game engine
Closed, ResolvedPublic

Description

This problem has also been in an other project from me, but I thought it would be my fault. But it happened again. I created a lot of objects and they were not shown correctly in the texture GLSL Mode and if I start the game engine blender crashes.
Sorry for my bad english
Laurenz

Details

Type
Bug

Moved from Blender 2.6 Bug Tracker to Game Engine

No crash here - but a lot of GPU errors

ERROR: Implementation limit of 16 active fragment shader samplers (e.g., maximum number of supported image units) exceeded, fragment shader uses 33 samplers
Might be my mac...

Crash confirmed - in physics engine initialize. Moved to the GE issue tracker.

I get the shader errors, but no crash when starting the blendfile:

Win7 64bit
NVIDIA GeForce GT 425M

I have windows 64 bit, blender 2.64a and 8gb ram. My graphic card is also a nvidia. The pc is only one year old and should be able to run blender correctly. I got the problem when i duplicated some objects. Suddenly blender did't show the textures right. They were all black. When i started the game engine blender crashes.

I'm attaching a simpler file (Tunnel2.blend) that has just one object that reproduces the crash. It has two materials, and getting rid of either and assigning all of the faces to one material seems to stop the crash. I'll investigate this further when I have more time.

Another way to prevent the crash is to make sure both materials either have physics enabled or disabled. It seems mixing them causes problems.

Daniel Stokes (kupoman) closed this task as Resolved.Jul 20 2013, 12:12 AM