Page MenuHome

Speakers not rendering Audio to 7.1 in viewport animation.
Closed, InvalidPublic

Description

blender r 51871
Windows XP 32 bit
nVidia GTX 465
Creative Audigy 2 7.1 sound card (which I tested by playing a 7.1 speaker identification file to make sure it's working)



In the viewport, I add a speaker behind the camera, and parent it to a circle that's rotating around a centered camera.
Then I look through the camera.
Then I update the animation cache
Then I hit Alt+A to play my animation.

Since blender is in openAL 7.1 audio mode (in the user settings),
it should start by playing the sound into my back L/R speakers,
and rotate from right to left, back to front.

Instead, it plays in my side and front speakers - panning appropriately.

When I mix it down, it renders correctly to the exported file. It's just playing live in the viewport that's broken.

(this is not a game engine issue. The 7.1 in the game engine works fine)


Thanks!!

Details

Type
Bug

Event Timeline

Joerg can check on this.

Are you sure this works correctly in the BGE too? I can only think of a problem with OpenAL on windows.

I've tried out the same testscene as you and as I don't have a 7.1 system, I played back via jack and recorded it in ardour. Looking at the output it's correct.

No response for about a month... Reopen if the problem is still present and can answer my question. ;-)

Joerg Mueller (nexyon) closed this task as Invalid.Dec 5 2012, 3:39 PM

Sorry! I ended up putting the e-mail on my "star and forget" list =D

7.1 is working just fine in the game engine, so I expect it should be able to do the same in the normal 3D mode.

Of course, I'm using OpenAL, and Jack isn't supported in windows.

And you made sure the channels in the user settings are 7.1 surround?

Yeah. I've got a game project I'm working on where objects fly past you, and it's really sweet to hear them in 7.1 surround sound.

I even made a demo video of me doing it with a slightly different setup. - http://www.youtube.com/watch?v=BYNlpgyJ9_g

I've attached a surround_test.blend file, could you try that out? Just open it, update the animation cache and play back, but make sure you set OpenAL Channels to 7.1 in the user preferences first!

Open Blender -> File -> User Preferences (Ctrl + Alt + U) -> System tab -> Sound -> OpenAL -> Channels -> 7.1 Surround -> Save as Default

With that double checked does it still not work?

I checked that, and it still didn't work.
I also recorded it in a 7.1 recording setup


I then attempted to run my sound through an HDMI cable (using gtx465 video card sound, instead analog off my creative sound card).
This attempt failed, as I couldn't get any program to send audio through to my receiver.

This does work in windows 8. I'll give that a shot if you'd like. (I primarily use XP)

I could also test it over my onboard sound - it'd take a few minutes to swap cables, but it'd doable.

I could also try it on a 5.1 system on a windows 7 computer.

Should I test all this stuff for you?

I have no clue how to test this further/find out what's wrong, we'd have to find a windows developer with a 7.1 system... :-/