Extrude and mirror editing 2.65 RC1
Closed, ResolvedPublic

Description

When using the extrude tool I become confused, There are two options for Mirror Editing, but none of them seems to work properly.

To recreate:
subdivide a single cube once or twice, select one face and extrude it.
Try toggle the mirror editing option

patrox (Patrik Andersson) set Type to Bug.Via Old WorldDec 1 2012, 2:22 PM
mont29 (Bastien Montagne) added a comment.Via Old WorldDec 1 2012, 2:44 PM

Mirror editing only works on editing properties of existing vertices/faces/edges (mainly position…), but absolutely not on modifying the topology itself (whether using extrusion, or simply adding new vertices, etc.).

Not a bug, closing. :)

patrox (Patrik Andersson) added a comment.Via Old WorldDec 1 2012, 3:00 PM

Wait a minute. Why is this an option in the extrude tool, since the tool is used to add vertices to the mesh? If the option is not needed for the extrude tool, why does the option occur twice? It would then more logically to combine the extrude tool mirroring option with the symmetrize tool.

So I suggest to develop the extrusion tool/Inset tool together with the symmetrize tool which would improve the workflow a lot :)

mont29 (Bastien Montagne) added a comment.Via Old WorldDec 1 2012, 6:53 PM

Woops… Looks like I went a bit too quicky on this one… Sorry, looks like there is indeed something wrong here.

patrox (Patrik Andersson) added a comment.Via Old WorldDec 1 2012, 6:56 PM

Thanks! :)

campbellbarton (Campbell Barton) added a comment.Via Old WorldDec 2 2012, 3:43 AM

Looks like BMesh broke this but 2.61 (pre-bmesh didnt use this well either), functionality seemed kindof broken there too.

I'll look into it.

dingto (Thomas Dinges) added a comment.Via Old WorldJan 20 2013, 5:55 PM

Any updates here? :)

dingto (Thomas Dinges) added a comment.Via Old WorldMar 26 2013, 4:47 PM

Ping.

patrox (Patrik Andersson) added a comment.Via Old WorldMar 26 2013, 8:09 PM

I investigated the behavior in release 2.66.1 r55057 for Mac OS X and now the result have change slightly.

I created a unit cube, subdivide it trice and selected a face (A) of the outer border and extruded the it to get the extruded and selected face (B)
I checked the first option of Mirror editing below Extrude region, nothing happens
I checked the second option of Mirror editing below Orientation, the mirrored (A) face copy the face (B) position, but it is not extruded.
I investigated if the translation vector by changing it from (0,0,D) to (X,Y,Z) for a normal offset, only the 3rd component is affected by the result, same goes for all transform orientation except the view. In the view-transform orientation mode, the mirroring appear not to be correct.

I can understand why the translation is wrong for the normal transform orientation mode, since the normal only consist of vector, and have not a fixed coordinate-system in the same way as the Local, View and Global transform orientation mode. I don't know how it is for Gimbal, because I don't know what kind of coordinate system it is.

In fact this option was never meant to be enabled, its only apart of the extrude macro so that transform never enables it. the options hidden r57494.

closing.

campbellbarton (Campbell Barton) closed this task as "Resolved".Via Old WorldJun 16 2013, 7:37 AM

Add Comment