Home

BMesh: Knife tool Angle Constraint function (again)
Closed, ResolvedPublic

Description

Relates to: T31433
Duplicates: T31433

"The BMesh Knife tool Angle Constraint function does not work properly; The cut veers off in one direction or another for a reason I haven't found out yet. This shouldn't need a .blend file; just use the default one and try to get the knife tool to get a perfect straight line(or 45 degree angle line) using the knife tool"(and angle constraint, with or without snapping).

This time you need to start or end on a line. It "should work as of r48155", but seems to be bugged again.

Win7 64bit
Current Blender version is 2.64.9, r52715

Also tested in;

-2.65 RC2
-(close to)Latest Buildbot release (2.64.9, r52813)

To no avail, the bug still persists. Video is attached in a ".7z" to keep size down. Duplicate is above, but if you can't acess it;

http://projects.blender.org/tracker/index.php?func=detail&aid=31433&group_id=9&atid=498
Confirmed, Will check on a fix.
howardt (Howard Trickey) added a comment.Via Old WorldJan 11 2013, 3:46 PM
This is mostly fixed in rev 53730.
There is still the problem (which may be regarded as a bug or a less-than-satisfactory 'working as intended') that if the ending point of the cut line is snapped to an edge, then the snapped point will likely not be exactly on the constraint line. There is an easy workaround for this: just drag a little past the edge before clicking and then the edge will be cut exactly on the constrained line.

I wonder whether people would be happier if the whole constraint mechanism were reworked so that the constraints happened in world space orthogonal coordinates: that is, the cut line is just constrained to which of the x, y, z, or 45 degree lines in the xy, xz, or yz plane is closest to the mouse movement? If we implemented that instead of the current constraint mechanism then I think it would be easier to calculate the angle-snapped points.
howardt (Howard Trickey) closed this task as "Resolved".Via Old WorldJan 11 2013, 3:46 PM

Add Comment