Home

Texture/Project Paint "Clone" Permanently Greyed Out
Closed, ResolvedPublic

Description
Howdy folks! Trying to use the Projection Paint feature to clone part of a texture from one UV Map to another.

First off, it appears that if Cycles is the selected render engine, cycling through multiple UV Maps on a single object will not cycle through the image textures associated with each unwrap. The same image sticks with all unwraps. Not sure if bug, or...

Once I switch over to Blender Internal, this behavior is as expected. Regardless, in Texture Paint mode the "Clone" checkbox under "Project Paint" looks unavailable.

I've replicated the issue in a simple file, attached.

Blender 2.65 r52859
Mac OS 10.8.2

Thanks!
brecht (Brecht Van Lommel) added a comment.Via Old WorldDec 27 2012, 12:37 PM
Regarding cycles, there is no such things as an image texture associated with a uv map there. Not sure yet how this clone option should work with cycles.
http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/Texture_Editing

The Clone option becomes available when you select the clone brush. The UI is confusing here, the option should probably be renamed so that it's clear that enabling it makes it clone from the UV map, and disabling it makes it clone from the 3D cursor.
effstops (Colin Levy) added a comment.Via Old WorldDec 27 2012, 7:34 PM
Aha! I see, thanks.

File this one under UI, then. The clone brush seems obvious but for some reason I was stumped! Something like "Clone Source" for that drop down might clarify.

Thanks Brecht!
sergey (Sergey Sharybin) added a comment.Via Old WorldJan 8 2013, 2:59 PM
Made it more clear name for Clone option in svn rev53655. Guess now we could consider the issue is solved :)
sergey (Sergey Sharybin) closed this task as "Resolved".Via Old WorldJan 8 2013, 2:59 PM

Add Comment