Manipulator in wrong position when editing with Armature modifier enabled
Closed, InvalidPublic

Description

When in edit mode with an armature modifier enabled the manipulator is being showed as if the modifier were disabled. Although the manipulator is working correctly. You can open the attached file and see for yourself. Tested on Windows 7 and Gentoo Linux (official binaries) with versions 2.64a and 2.65a.

Machine
CPU: Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz (4 CPUs), ~3.1GHz
RAM: 8192 MB
GFX: NVIDIA GeForce GT 220, 1024 MB
OS: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 & Gentoo Linux x86_64
Drivers: Windows - nVidia 9.18.13.697 (Final Rettail), Gentoo - Nouveau kernel 3.6.11
Blender: 2.64a and 2.65a

Ton Roosendaal (ton) added a comment.Via Old WorldDec 28 2012, 12:24 PM

Confirmed, goes on my todo!

Campbell Barton (campbellbarton) added a comment.Via Old WorldJan 9 2013, 7:55 AM

This isnt so simple to fix, I had a patch we used for sintel which would make it show in the location you'd expect, but internally this is still transforming the original location.

closing - this is a known limitation.

Campbell Barton (campbellbarton) closed this task as "Invalid".Via Old WorldJan 9 2013, 7:56 AM
Tobias Oelgarte (niabot) added a comment.Via Old WorldJan 9 2013, 10:55 AM

But it is important to be able to drag the vertex to have the 3d manipulator at a reasonable location. If it isn't then grabbing a vertex is often impossible, because the distance you drag depends on the manipulator location relative to the view. If it is very close the view, the distance is massive, if it is somewhere near the view plane but not on screen it is nearly not reacting and so on. See: http://projects.blender.org/tracker/?func=detail&atid=498&aid=33647&group_id=9

Rodrigo Ledig (botrops) added a comment.Via Old WorldJan 9 2013, 12:20 PM

Sorry, I didn't know that was a known limitation.

Ton Roosendaal (ton) added a comment.Via Old WorldJan 10 2013, 3:19 PM

The transform code stores the original cage vertices, and works on these vertices to apply transforms using our "CrazySpace" conversion.
That ensures that moving vertices will appear to move with your mouse motion.

However, as you can see on selecting items, rotate or scale uses the center of the original vertices too (the stippled line).

Add Comment