Input change object.select_all behaves stragely if changed
Closed, ArchivedPublic

Description

Hello,
So I pretty sure this functionality never was detected, a few revisions before blender
arrived to 2.65 something changed on how this function on the interface worked, I'm creating this
post to ask what changed and if i would be possible to have things working like before, of course
I know this change might had been triggered because of something essential to the inner workings
of the interface is witch case I would understand, but if this is not the case I would request if
it would be possible to make things how they were on version 2.64 just on this particular instance,
or maybe its a bug but nobody noticed because nobody modified their keys the exact same
way as me :)

Now Here's what I could do in version 2.64a x64 Windows version

Start blender 2.64a

Go back to factory settings

Got the User preferences window

Go to input>Select With: Left

Go to input>3Dview>Object Mode>(De)select All

Inside (De)select All change the following:
Make it so this function is summoned by pressing the
left mouse with a click.
Meaning the little window where the properties of
the hot key looks like:

object.select_all Left/Click

Any Shift Ctrl Alt Cm
Action:Toggle

Close the Blender user preferences window

Go back to the main 3d view where the default cube is.

Now in blender 2.64 if I make this changes I get a behavior in which if I click on a 3d mesh
lamp, etc. I select the object, which is fine, and if I click on empty space where there's no
objects all this selections get cancelled.

Now with no object select previous click on the background empty space, and all the objects on the screen will be selected,
click a second time on the empty space and all the objects will be deselect, with his change I can select
individual objects, deselect them, select them all with nothing but one mouse clicks, I have
been working this way with very good results since blender 2.61, now on version 2.65 something
changed on the input that has made this system unusable.


Start Blender 2.65a
Do the same steps I wrote for blender 2.64a.

You will see the behavior where I click on the empty space remains the same, one click deselects all
one click selects all on the screen.
Now try to select one of the objects, and you will see you can't do any more, what you get is like an
attempt form the program to do it, but something cancels the selection.
Now what I don't get is why this used to work on version 2.64a and now it doesn't.

This way of selecting things is way more efficient than having to click the A key to select and deselect all,
I know lots of people like the old method and I agree it should be included, but could there be
a way to fix this problem so it works like it did on version 2.64a?
I would be eternally grateful for this, I made this change since version 2.61 because i found having to go
to hit A every time I wanted to deselect something or to select all was very cumbersome and
I had grow very accustomed working this way, I was also very happy to see how powerful the user interface
was in that I allowed me to change the keys so the user could work as they would feel more comfortable,
now this power as been taken away :(

Please fix this,
and if its something that has to stay this
way because this is just the way it has to be
on newer versions, a least let me know why It changed

If something on my explanation is unclear feel free to ask me
any question, I would be glad to do any test you ask me to do
as I'm very interested on getting this behavior back.

Kind Regards
-Luis

This is just a copy of my initial post, I found some very appalling typos that
I corrected, Im very sorry, In just not a very good writer.

Hello,
So I'm pretty sure this functionality never was detected, a few revisions before blender
arrived to 2.65 something changed on how this function on the interface worked, I'm creating this
post to ask what changed and if it would be possible to have things working like before, of course
I know this change might had been triggered because of something essential to the inner workings
of the interface is which case I would understand, but if this is not the case I would request if
it would be possible to make things how they were on version 2.64 just on this particular instance,
or maybe its a bug but nobody noticed because nobody modified their keys the exact same
way as me :)

Now Here's what I could do in version 2.64a x64 Windows version

Start blender 2.64a

Go back to factory settings

Got the User preferences window

Go to input>Select With: Left

Go to input>3Dview>Object Mode>(De)select All

Inside (De)select All change the following:
Make it so this function is summoned by pressing the
left mouse with a click.
Meaning the little window where the properties of
the hot key looks like:

object.select_all Left/Click

Any Shift Ctrl Alt Cm
Action:Toggle

Close the Blender user preferences window

Go back to the main 3d view where the default cube is.

Now in blender 2.64 if I make this changes I get a behavior in which if I click on a 3d mesh
lamp, etc. I select the object, which is fine, and if I click on an empty space where there's no
objects all this selections get cancelled.

Now with no object selected previous click on the background empty space, and all the objects on the screen will be selected,
click a second time on the empty space and all the objects will be deselect, with this change I can select
individual objects, deselect them, select them all with nothing but one mouse clicks, I have
been working this way with very good results since blender 2.61, now on version 2.65 something
changed on the input that has made this system unusable.


Start Blender 2.65a
Do the same steps I wrote for blender 2.64a.

You will see the behavior where I click on the empty space remains the same, one click deselects all
one click selects all on the screen.
Now try to select one of the objects, and you will see you can't do any more, what you get is like an
attempt from the program to do it, but something cancels the selection.
Now what I don't get is why this used to work on version 2.64a and now it doesn't.

This way of selecting things is way more efficient than having to click the A key to select and deselect all,
I know lots of people like the old method and I agree it should be included, but could there be
a way to fix this problem so it works like it did on version 2.64a?
I would be eternally grateful for this, I made this change since version 2.61 because i found having to go
to hit A every time I wanted to deselect something or to select all was very cumbersome and
I had grow very accustomed working this way, I was also very happy to see how powerful the user interface
was in that I allowed me to change the keys so the user could work as they would feel more comfortable,
now this power as been taken away :(

Please fix this,
and if its something that has to stay this
way because this is just the way it has to be
on newer versions, a least let me know why It changed

If something on my explanation is unclear feel free to ask me
any question, I would be glad to do any test you ask me to do
as I'm very interested on getting this behavior back.

Kind Regards
-Luis

ton (Ton Roosendaal) added a comment.Via Old WorldJan 1 2013, 2:36 PM

A little too much text for a simple problem :)

The issue is this: in Blender, the order of keymaps is not what you see in the editor - unfortunately. Keymaps are being added and removed dynamically all the time, depending on settings in views and modes. They even depend on individual regions. This order is not in user control.

To see keymap handling work you can run blender in debug mode: start from commandline as blender --debug-handlers

As for your issue: I cannot make this work in any release I tried: 2.57, 2.61. and 2.64 and 2.65a.
That is even expected, since the a select click will always pass on to next events to be handled. (so you can do click-drag-move).

Please provide a 2.64 startup.blend with keymap configured as you made it work?

Hi Ton :) its an honor to meet you :D

Thanks for the response, and for the explanation.
Strange that you weren't able to reproduce it, I have been working
with my key setup like this since 2.61 with no problems of any kind,
from modeling to rigging and texturing... I'm wondering what makes my setup
the way it is that allowed blender to get this behavior, which I really like.

I attached a zip with both a start up file and a hot-keys export file, let me
know if you where able to reproduce this effect whit it.

Also I downloaded the version 2.64a from the old builds repository,

http://download.blender.org/release/Blender2.64/
I specifically used the last link on this list.

I checked the rev and its r51232 so in theory you should be able
to reproduce it on this revision for sure.

Let me know if you were successful on reproducing the behavior.
Cheers
-Luis

Hi Ton,
So I ran both blender 2.64a and 2.65a in debug mode with my keys changed how I use them on 2.64a
and indeed something is being handled differently on version 2.65a compared to 2.64a
I made a screenshot of my command window so you can see what each version is doing,
let me know if this sheds some light on what changed and what made this possible on 2.64a
and impossible on 2.65a

Hi just checking if somebody knows why this changed form 2.64a to 2.65a any clues?,
I know I'm probably the only one that wants to know still this is import to me, so any ideas?

ton (Ton Roosendaal) added a comment.Via Old WorldFeb 7 2013, 1:35 PM

Sorry we ignore this topic still - keymap syncing is nasty code, and have a lot more issues here to check too.
Report is still open though :)

ton (Ton Roosendaal) added a comment.Via Old WorldFeb 14 2013, 2:12 PM

A similar report has been handled here:
http://projects.blender.org/tracker/index.php?func=detail&aid=34206&group_id=9&atid=498

That report also shows a solution for your case. Work on making this better possible is a 2.67 target (for next months).

ton (Ton Roosendaal) closed this task as "Archived".Via Old WorldFeb 14 2013, 2:12 PM

Add Comment