animated layer movement no longer works
Closed, ArchivedPublic

Description

--- Operating System, Graphics card ---
Fedora linux 18, blender-2.65a-linux-glibc211-x86_64,
01:00.0 VGA compatible controller: NVIDIA Corporation G92 [GeForce 9800 GT] (rev a2), nouveau driver

--- Blender version with error, and version that worked ---
2.65 packaged with fedora and official 64bit build shows the issue.
2.63 worked

--- Short description of error ---
animating layer movement for objects doesn't seem to reflect in eitehr the 3D view, nor the renders.

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
Load up the attached .blend file to see the cube being keyframed to be on layer 1 at frame 1, and on layer 2 on frame 2.

To reproduce manually, select both layer 1 and 2 to be visible, select a cube, in the object button, select layer 1 on frame one and press I to add a keyframe (or use add single keyframe to only keyframe one layer). switch to frame 2 and click on the 2nd layer to move the object there and keyframe it with I.

This used to work fine in 2.63.

Sergey Sharybin (sergey) added a comment.Via Old WorldJan 4 2013, 8:20 AM

This was intentional change caused by limitation of dependency graph system. There was a confusing thing in 2.65a which allowed you to add keyframes on layers which later didn't apply properly. In current svn we've forbid to add keyframes on layers, so there should be less confusing.

Adding layer animation back could be a helpful feature, but it's not doable in reliable way with current dependency graph. Meanwhile you could animate visibility flag in outliner.

Thanks for the report, but it's a known issue which is a TODO.

Sergey Sharybin (sergey) closed this task as "Archived".Via Old WorldJan 4 2013, 8:20 AM
Jakub Steiner (jimmacfx) added a comment.Via Old WorldJan 4 2013, 4:21 PM

Didn't realize the visibilty toggle being keyframable. Feel free to close this as this is even better to what I need this for.

Add Comment