Page MenuHome

Multi UV objects not displaying textures and Channel correctly in game mode.
Closed, ResolvedPublic

Description

Category: Rendering

Computer tested on:

Intel i5 - 2500K @ 4.0ghz
16gb ddr3 1600mhz
nVidia geForce GTX 560 ti
Windows 7 x64

Example it too big for attachment.

link posted here: http://www.crimsoneye.co.uk/UVGlitch2.blend

On game play the 3rd Texture layer (multiplied ambient occlusion) is using the 1st texture channel when it should be using the AO channel.

In viewport Displays Fine, in game play it displays incorrectly.

this happens on 2.66 all revisions.

problem does not exist in 2.65a.

CTBM

Details

Type
Bug

Event Timeline

Forgot to mention again GLSL

Does this report show anything different than all the various other multi-uv bug reports? In other words, I suspect this is a duplicate.

last issue reported multiple problems, 1 was fixed. I assure you this is a completely different bug as the included blend shows.

I think the problem is the same as of the attached file. This is a small simplified file though. Should help with debugging.

Any status on this?

Hi, there is a patch for this (see uvfix.diff). it should be applied on trunk only tomorrow though.
If you can however test the patch (with this and other test files) that would help

OK, i have applied the patch and rebuilt the Source, all channels working correctly.

Thanks.

Fix commit by Mitchell Stokes on rev. 54972. It will be present in 2.66a.
Thanks for reporting.

Dalai Felinto (dfelinto) closed this task as Resolved.Mar 2 2013, 11:29 PM