Marker gets initialized to arbitrary position
Closed, ResolvedPublic

Description

Relates to: T35232

--- Operating System, Graphics card ---

Ubuntu Linux 12.10 32bit
Intel Core Processor Integrated Graphics Controller (rev 02) - information from lspci

--- Blender version with error, and version that worked ---

svn 56305: version with error

--- Short description of error ---
I had reported bug #35232: Marker right-click misbehavior on adding.

The original bug was fixed but the resulting behavior is not ideal (it works OK but not as expected). So I am opening this new bug report documenting and arguing that this behavior needs to be improved (or polished). Basically after #35232 bugfix the "Add Marker" places the marker initially in the center of the frame,
but if the frame center is not in view the marker is initialized outside of view, which is not good UI behavior. Correct behavior should be to allow the user to click where the marker should be initialized, even if this makes the bugfix relatively harder to do. Also, initializing markers in the center of the video frame and only then dragging them to the right position could impact productivity when many markers have to be placed in practice.


--- Steps for others to reproduce the error (preferably based on attached .blend file) ---

1. Open Blender
2. Choose type to "Movie and Clip editor" clicking on the "cube" button situated on the lower left side.
3. Open a video clicking on the "Open" button, situated on the lower left side too.
4. Click on "Add Marker" and a marker is initialized in the center of the video frame.
5. If the center of the video frame is not visible, the marker will be initialized off the viewport and the user will not know where it went, unless the user gets used to to this "quirk" of initializing markers in the middle of the frame.
6. Additional markers will always be initialized to the center of the video frame as well, before they can be positioned.

ocf (Marcos Couto) set Type to Bug.Via Old WorldMay 22 2013, 3:28 AM
ocf (Marcos Couto) added a comment.Via Old WorldMay 22 2013, 4:09 AM

short video on how to reproduce bug: https://vimeo.com/channels/labmacambira/66697585

ocf (Marcos Couto) added a comment.Via Old WorldMay 22 2013, 4:33 AM

I also tested on OSX 10.8.3 (12D78) with NVIDIA GeForce GT 650M 1024 MB which is my professor's laptop from the University.

The compiled version on OSX was svn 56956 from git-svn - it says git-svn-id: https://svn.blender.org/svnroot/bf-blender/trunk@56956.

The svn version for Linux is the same as this one - 56956. However, the status bar shows 56305 for some reason.

sergey (Sergey Sharybin) added a comment.Via Old WorldMay 22 2013, 8:10 AM

Would not consider this is actually a bug, position will be arbitrary anyway. And doubt anyone actually uses toolbox to add markers to the footage, Ctrl-Click is a way faster way for this.

But commited some tweaks, so now marker will be added to the center of visible frame part, not to the center of whole frame in svn rev56959.

Thanks for the report, closing now.

P.S. Videos are really rarely useful for bug tracker -- they're time consuming to load and navigate back to specified step to doublecheck whether you're understanding bug correct. Plain text instructions and simple .blend file (which is not needed in such simple cases) are much more useful.

sergey (Sergey Sharybin) closed this task as "Resolved".Via Old WorldMay 22 2013, 8:10 AM
ocf (Marcos Couto) added a comment.Via Old WorldMay 22 2013, 12:55 PM

Hello Sergey, improving on your patch code I could write a more complete operator that seems to be an improved solution, please kindly take a look http://projects.blender.org/tracker/index.php?func=detail&aid=35464&group_id=9&atid=127

Add Comment