Page MenuHome

Segfault when starting BGE
Closed, ResolvedPublic

Description

Category: Physics

--- Operating System, Graphics card ---

Debian 7.0 Wheezy, ATI 6310 with fglrx drivers

--- Blender version with error, and version that worked ---

Blender from SVN (r57577) and Blender 2.67b both have the same problem.

--- Short description of error ---

I'm using armatures in the game engine and have been messing around with the parents. Starting the BGE segfaults Blender immediately.

Output to terminal:

$ blender-svn
connect failed: No such file or directory
Read new prefs: /home/forest/.config/blender/2.67/config/userpref.blend
found bundled python: /home/forest/files/blender/blender-svn/build/bin/2.67/python
read blend: /home/forest/projects/3d/game/Broken_Figure.blend
Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
Detected GL_ARB_multitexture
Detected GL_ARB_shader_objects
Detected GL_ARB_vertex_shader
Detected GL_ARB_fragment_shader
Detected GL_ARB_vertex_program
Detected GL_ARB_depth_texture
Detected GL_EXT_separate_specular_color

Blender Game Engine Started
Writing: /tmp/Broken_Figure.crash.txt
Segmentation fault
$

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---

1. Open file.
2. Press 'p'.


Details

Type
Bug

Event Timeline

can't redo r57596, 64bit linux.

I should have mentioned that I'm using 32-bit Blender and Linux.

Moved from Blender 2.6 Bug Tracker to Game Engine

Can not reproduce on Windows 7 64bit r57681

Cannot reproduce with r57708 on 64bit Arch Linux.

Cannot reproduce on OSX
Forest, can you build as debug and see where it crashes?

I'm not sure if this is what you want; here's /tmp/Broken_Figure.crash.txt:

# Blender 2.67 (sub 1), Revision: 57706

# backtrace
blender-svn() [0x98fcd57]
blender-svn() [0x98fcf9d]
[0xb77e1400]
blender-svn(_ZN15btCompoundShape20recalculateLocalAabbEv+0xfa) [0xa80af08]
blender-svn(_ZNK13btConvexShape44localGetSupportVertexWithoutMarginNonVirtualERK9btVector3+0xcc7) [0xa810b5b]
blender-svn(_ZN17btGjkPairDetector26getClosestPointsNonVirtualERKN36btDiscreteCollisionDetectorInterface17ClosestPointInputERNS0_6ResultEP12btIDebugDraw+0x33d) [0xa82911d]
blender-svn(_ZN17btGjkPairDetector16getClosestPointsERKN36btDiscreteCollisionDetectorInterface17ClosestPointInputERNS0_6ResultEP12btIDebugDrawb+0x38) [0xa828dda]
blender-svn(_ZN27btContinuousConvexCollision20computeClosestPointsERK11btTransformS2_R16btPointCollector+0x179) [0xa827767]
blender-svn(_ZN27btContinuousConvexCollision16calcTimeOfImpactERK11btTransformS2_S2_S2_RN12btConvexCast10CastResultE+0x2c6) [0xa827ce4]
blender-svn(_ZN28btTriangleConvexcastCallback15processTriangleEP9btVector3ii+0x110) [0xa82d346]
blender-svn(_ZN24btScaledTriangleCallback15processTriangleEP9btVector3ii+0x110) [0xa819804]
blender-svn() [0xa8082f0]
blender-svn(_ZNK14btQuantizedBvh26walkStacklessQuantizedTreeEP21btNodeOverlapCallbackPtS2_ii+0x12a) [0xa8a3ebc]
blender-svn(_ZNK14btQuantizedBvh26reportAabbOverlappingNodexEP21btNodeOverlapCallbackRK9btVector3S4_+0xb0) [0xa8a2f9c]
blender-svn(_ZNK22btBvhTriangleMeshShape19processAllTrianglesEP18btTriangleCallbackRK9btVector3S4_+0x52) [0xa808376]
blender-svn(_ZNK28btScaledBvhTriangleMeshShape19processAllTrianglesEP18btTriangleCallbackRK9btVector3S4_+0x3da) [0xa8190ee]
blender-svn(_ZN16btCollisionWorld25objectQuerySingleInternalEPK13btConvexShapeRK11btTransformS5_PK24btCollisionObjectWrapperRNS_20ConvexResultCallbackEf+0x872) [0xa7fa6a4]
blender-svn(_ZN16btCollisionWorld17objectQuerySingleEPK13btConvexShapeRK11btTransformS5_P17btCollisionObjectPK16btCollisionShapeS5_RNS_20ConvexResultCallbackEf+0x78) [0xa7f9a90]
blender-svn(_ZNK13btGhostObject15convexSweepTestEPK13btConvexShapeRK11btTransformS5_RN16btCollisionWorld20ConvexResultCallbackEf+0x2c1) [0xa803687]
blender-svn(_ZN30btKinematicCharacterController8stepDownEP16btCollisionWorldf+0x1fb) [0xa85cddf]
blender-svn(_ZN30btKinematicCharacterController10playerStepEP16btCollisionWorldf+0x1fb) [0xa85d2b3]
blender-svn(_ZN30btKinematicCharacterController12updateActionEP16btCollisionWorldf+0x3f) [0xa697843]
blender-svn(_ZN32BlenderBulletCharacterController12updateActionEP16btCollisionWorldf+0x4f) [0xa68ef5b]
blender-svn(_ZN23btDiscreteDynamicsWorld13updateActionsEf+0x65) [0xa84ed59]
blender-svn(_ZN23btDiscreteDynamicsWorld28internalSingleStepSimulationEf+0x137) [0xa84e87f]
blender-svn(_ZN24btSoftRigidDynamicsWorld28internalSingleStepSimulationEf+0x7a) [0xa884f90]
blender-svn(_ZN23btDiscreteDynamicsWorld14stepSimulationEfif+0x1a7) [0xa84e6c7]
blender-svn(_ZN21CcdPhysicsEnvironment16proceedDeltaTimeEdff+0xff) [0xa67c3c1]
blender-svn(_ZN15KX_KetsjiEngine9NextFrameEv+0x6d8) [0xa6f364c]
blender-svn() [0xa6253ac]
blender-svn(StartKetsjiShell+0x1042) [0xa6266a2]
blender-svn() [0x9a10d9f]
blender-svn() [0x99068cc]
blender-svn() [0x9907b8c]
blender-svn() [0x9908348]
blender-svn() [0x99086c5]
blender-svn(wm_event_do_handlers+0x4aa) [0x990915c]
blender-svn(WM_main+0x28) [0x9900390]
blender-svn(main+0x3ce) [0x98ff66a]
/lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xe6) [0xb6221e16]
blender-svn() [0x98fc259]

if you build your own blender the even better way to get a backtrace is

1) build with DEBUG flags on
2) gdb specialfolder/blender
3) r
4) open your file, play the game
[this should crash, the window will freeze]
5) back in the console do:
bt

If you have troubles doing that, try to get online in the IRC (#blendercoders)

Here's the backtrace that gdb printed out:

#0 0x0a80af08 in btCompoundShape::recalculateLocalAabb (this=0xbfffcbd8)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/CollisionShapes/btCompoundShape.cpp:155
#1 0x0a810b5b in btConvexShape::localGetSupportVertexWithoutMarginNonVirtual (this=0xa96a9d50, localDir=...)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/CollisionShapes/btConvexShape.cpp:291
#2 0x0a82911d in btGjkPairDetector::getClosestPointsNonVirtual (this=0xbfffce38, input=..., output=..., debugDraw=0x0)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/NarrowPhaseCollision/btGjkPairDetector.cpp:146
#3 0x0a828dda in btGjkPairDetector::getClosestPoints (this=0xbfffce38, input=..., output=..., debugDraw=0x0, swapResults=false)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/NarrowPhaseCollision/btGjkPairDetector.cpp:76
#4 0x0a827767 in btContinuousConvexCollision::computeClosestPoints (this=0xbfffd624, transA=..., transB=..., pointCollector=...)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/NarrowPhaseCollision/btContinuousConvexCollision.cpp:58
#5 0x0a827ce4 in btContinuousConvexCollision::calcTimeOfImpact (this=0xbfffd624, fromA=..., toA=..., fromB=..., toB=..., result=...)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/NarrowPhaseCollision/btContinuousConvexCollision.cpp:142
#6 0x0a82d346 in btTriangleConvexcastCallback::processTriangle (this=0xbfffda58, triangle=0xbfffd680, partId=0, triangleIndex=0)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/NarrowPhaseCollision/btRaycastCallback.cpp:154
#7 0x0a819804 in btScaledTriangleCallback::processTriangle (this=0xbfffd90c, triangle=0xbfffd850, partId=0, triangleIndex=0)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/CollisionShapes/btScaledBvhTriangleMeshShape.cpp:50
#8 0x0a8082f0 in btBvhTriangleMeshShape::MyNodeOverlapCallback::processNode (this=0xbfffd844, nodeSubPart=0, nodeTriangleIndex=0)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/CollisionShapes/btBvhTriangleMeshShape.cpp:315
#9 0x0a8a3ebc in btQuantizedBvh::walkStacklessQuantizedTree (this=0xab13c420, nodeCallback=0xbfffd844, quantizedQueryAabbMin=0xbfffd816, quantizedQueryAabbMax=0xbfffd810, startNodeIndex=0,
endNodeIndex=3) at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/BroadphaseCollision/btQuantizedBvh.cpp:730
#10 0x0a8a2f9c in btQuantizedBvh::reportAabbOverlappingNodex (this=0xab13c420, nodeCallback=0xbfffd844, aabbMin=..., aabbMax=...)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/BroadphaseCollision/btQuantizedBvh.cpp:346
#11 0x0a808376 in btBvhTriangleMeshShape::processAllTriangles (this=0xab13c3b0, callback=0xbfffd90c, aabbMin=..., aabbMax=...)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/CollisionShapes/btBvhTriangleMeshShape.cpp:323
#12 0x0a8190ee in btScaledBvhTriangleMeshShape::processAllTriangles (this=0xab13c5a0, callback=0xbfffda58, aabbMin=..., aabbMax=...)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/CollisionShapes/btScaledBvhTriangleMeshShape.cpp:73
#13 0x0a7fa6a4 in btCollisionWorld::objectQuerySingleInternal (castShape=0xa96a9d50, convexFromTrans=..., convexToTrans=..., colObjWrap=0xbfffddc8, resultCallback=...,
allowedPenetration=0.0399999991) at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/CollisionDispatch/btCollisionWorld.cpp:781
#14 0x0a7f9a90 in btCollisionWorld::objectQuerySingle (castShape=0xa96a9d50, convexFromTrans=..., convexToTrans=..., collisionObject=0xa969c270, collisionShape=0xab13c5a0,
colObjWorldTransform=..., resultCallback=..., allowedPenetration=0.0399999991)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/CollisionDispatch/btCollisionWorld.cpp:571
#15 0x0a803687 in btGhostObject::convexSweepTest (this=0xa96aa0d0, castShape=0xa96a9d50, convexFromWorld=..., convexToWorld=..., resultCallback=..., allowedCcdPenetration=0.0399999991)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletCollision/CollisionDispatch/btGhostObject.cpp:139
#16 0x0a85cddf in btKinematicCharacterController::stepDown (this=0xa96aa2e0, collisionWorld=0xa966afa0, dt=0.0166666675)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletDynamics/Character/btKinematicCharacterController.cpp:439
#17 0x0a85d2b3 in btKinematicCharacterController::playerStep (this=0xa96aa2e0, collisionWorld=0xa966afa0, dt=0.0166666675)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletDynamics/Character/btKinematicCharacterController.cpp:580
#18 0x0a697843 in btKinematicCharacterController::updateAction (this=0xa96aa2e0, collisionWorld=0xa966afa0, deltaTime=0.0166666675)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletDynamics/Character/btKinematicCharacterController.h:106
#19 0x0a68ef5b in BlenderBulletCharacterController::updateAction (this=0xa96aa2e0, collisionWorld=0xa966afa0, dt=0.0166666675)
at /home/forest/files/blender/blender-svn/blender/source/gameengine/Physics/Bullet/CcdPhysicsController.cpp:80
#20 0x0a84ed59 in btDiscreteDynamicsWorld::updateActions (this=0xa966afa0, timeStep=0.0166666675)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletDynamics/Dynamics/btDiscreteDynamicsWorld.cpp:608
#21 0x0a84e87f in btDiscreteDynamicsWorld::internalSingleStepSimulation (this=0xa966afa0, timeStep=0.0166666675)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletDynamics/Dynamics/btDiscreteDynamicsWorld.cpp:507
#22 0x0a884f90 in btSoftRigidDynamicsWorld::internalSingleStepSimulation (this=0xa966afa0, timeStep=0.0166666675)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletSoftBody/btSoftRigidDynamicsWorld.cpp:94
#23 0x0a84e6c7 in btDiscreteDynamicsWorld::stepSimulation (this=0xa966afa0, timeStep=0.0166666675, maxSubSteps=25, fixedTimeStep=0.0166666675)
at /home/forest/files/blender/blender-svn/blender/extern/bullet2/src/BulletDynamics/Dynamics/btDiscreteDynamicsWorld.cpp:448
#24 0x0a67c3c1 in CcdPhysicsEnvironment::proceedDeltaTime (this=0xa9668f30, curTime=0.7641849530395125, timeStep=0.0166666675, interval=0.0166666675)
at /home/forest/files/blender/blender-svn/blender/source/gameengine/Physics/Bullet/CcdPhysicsEnvironment.cpp:661
#25 0x0a6f364c in KX_KetsjiEngine::NextFrame (this=0xaa0bffd0) at /home/forest/files/blender/blender-svn/blender/source/gameengine/Ketsji/KX_KetsjiEngine.cpp:708
#26 0x0a6253ac in BL_KetsjiNextFrame (ketsjiengine=0xaa0bffd0, C=0xe447370, win=0xab2b0370, scene=0xab2e2440, ar=0xab2d3b98, keyboarddevice=0xaa1c76c0, mousedevice=0xaa1c8340,
draw_letterbox=0) at /home/forest/files/blender/blender-svn/blender/source/gameengine/BlenderRoutines/BL_KetsjiEmbedStart.cpp:132
#27 0x0a6266a2 in StartKetsjiShell (C=0xe447370, ar=0xab2d3b98, cam_frame=0xbffff338, always_use_expand_framing=1)
at /home/forest/files/blender/blender-svn/blender/source/gameengine/BlenderRoutines/BL_KetsjiEmbedStart.cpp:563
#28 0x09a10d9f in game_engine_exec (C=0xe447370, op=0xab2d15d0) at /home/forest/files/blender/blender-svn/blender/source/blender/editors/space_view3d/view3d_view.c:1495
#29 0x099068cc in wm_operator_invoke (C=0xe447370, ot=0xe6bea48, event=0xaa0c1570, properties=0xabc95628, reports=0x0, poll_only=0)
at /home/forest/files/blender/blender-svn/blender/source/blender/windowmanager/intern/wm_event_system.c:954
#30 0x09907b8c in wm_handler_operator_call (C=0xe447370, handlers=0xab2d3c90, handler=0xab0acd70, event=0xaa0c1570, properties=0xabc95628)
at /home/forest/files/blender/blender-svn/blender/source/blender/windowmanager/intern/wm_event_system.c:1532
#31 0x09908348 in wm_handlers_do_intern (C=0xe447370, event=0xaa0c1570, handlers=0xab2d3c90)
at /home/forest/files/blender/blender-svn/blender/source/blender/windowmanager/intern/wm_event_system.c:1800
#32 0x099086c5 in wm_handlers_do (C=0xe447370, event=0xaa0c1570, handlers=0xab2d3c90)
at /home/forest/files/blender/blender-svn/blender/source/blender/windowmanager/intern/wm_event_system.c:1911
#33 0x0990915c in wm_event_do_handlers (C=0xe447370) at /home/forest/files/blender/blender-svn/blender/source/blender/windowmanager/intern/wm_event_system.c:2203
#34 0x09900390 in WM_main (C=0xe447370) at /home/forest/files/blender/blender-svn/blender/source/blender/windowmanager/intern/wm.c:462
#35 0x098ff66a in main (argc=1, argv=0xbffff6a4) at /home/forest/files/blender/blender-svn/blender/source/creator/creator.c:1662


Are you still having this problem? Maybe we got lucky with a Bullet update.

Nope, still having the problem with Blender 2.69.0. I don't currently have a debug-compiled version but I'll try to compile it.

`# Blender 2.69 (sub 0), Revision: 60991

backtrace

blender() [0x8aca2ab]
blender() [0x8aca4f1]
[0xb76fa400]
[0xbfe04b40]
[(nil)]
`

I'm still unable to reproduce this problem with latest master using Arch Linux 64bit. I've also tried running Valgrind and Helgrind to try and check for memory or threading errors. You could try Blender 2.70, which updated to Bullet 2.82, but I am doubtful that will solve anything.

Can not reproduce on Windows 7 64bit blender 2.70.
In opensuse linux 64-bit / blender 2.70 neither.

Can no longer reproduce with 2.69 release or 2.70 release on Arch Linux 64-bit... I guess it might have been a library version problem when I originally encountered it.

Mitchell Stokes (moguri) closed this task as Resolved.May 21 2014, 1:22 AM
Mitchell Stokes (moguri) claimed this task.