Page MenuHome

blender only displays white blank screen on startup
Closed, InvalidPublic

Description

--- Operating System, Graphics card --- nvidea gt windows 8 64


--- Blender version with error, and version that worked --- none worked


--- Short description of error ---fresh install blender 2.68 only displays white blank screen on startup


--- Steps for others to reproduce the error (preferably based on attached .blend file) ---

Details

Type
Bug

Event Timeline

This is most likely a graphical driver bug… So we need at the very least the exact model of or graphic card. Also pleas make sure you use the latest drivers available, and try our 2.69RC1 (http://download.blender.org/release/Blender2.69/).

In fact, could you please attach the output of Help -> System Info (found in a text window)?

No reply in a week. Closing because of lack of information needed to troubleshoot.

Happy to reopen the issue as soon as more info is provided :)

Same problem. Win 8 x64, Nvidia GeForce GT 645M and Intel HD Graphics 4000. Blender opens to just white blank window (cant see the menu or anything). Blender actually boots (shows) himself after like 10 minutes.

Some questions to @Jana (Jana_Tk):

  • As i understand it's Nvidia optimus? In this case does this issue happen when running blender on both intel and nvidia cards?
  • Make sure drivers are all up-to-date
  • Download opengl32.dll from ftp://ftp.blender.org/sergey/softwaregl/ and put it next to blender.exe. This will switch blender to fully software opengl mode, which would allow to know if it's driver issue (which we can not fix) or maybe blender doesn't work correctly with some hardware due to some hw limitations (which we might actually solve).

This problem doesnt occur any more at my computer. Not sure why, my drivers been latest before also...whatever it works now.

Just to note the last:
Not sure if its optimus, cant find that anywhere at my pc but looks like this model is optimus... ive put this .dll there and run blender, it turned on fine but it was very slow (and its not using nvidia). When i deleted .dll, works fine (and using nvidia).

So i seems fine now, thanks

I am having this same issue and have not found a solution to this. I hope someone can help me out with this. Thank you in advance.

I have the same issue. Blender starts up with a white screen. I have an Windows 10, 64bit, intel i7 (1.99GHz), 16GB RAM, NVIDIA GEFORCE. I don't know much about computers, but the way that I was able to get Blender to work was to right-click on the start up icon, and choose "Run with Graphics Processor > integrated graphics". I don't know what implications this has on renders, etc., but it is the onl way I could get Blender to work.

I am having this issue too. I loaded Blender 2.8 then tried 2.79b both have a solid whiter box.

Win10 64bit Version 10.0.17763 Build 17763
Processor Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz, 3600 Mhz, 8 Core(s), 8 Logical Processor(s)
GPU GeForce RTX 2070 Driver 436.02

Never tried this software before and it's not a great first impression. Any help offered, greatly received.