Page MenuHome

Problem with translate/scale/rotate in Armature and Objects in different layers
Closed, ArchivedPublic

Description

--- Operating System, Graphics card ---
Ubuntu 12.04 - Nvidia 8600

--- Blender version with error, and version that worked ---
r61011

--- Short description of error ---
If I put a Armature on a layer and an object influenced by Armature in other layer, when I select only the Armature layer and perform some transformation in pose mode, returning to the object's layer influenced this has not moved.

--- Steps for others to reproduce the error (preferably based on attached .blend file) ---
In the .blend:
1. In pose mode. Translate the bone.
2. Go to the layer 1.
3. Go to the layer 2 and translate the bone again.
4. Go to the layer 1. The cube has not moved.

Details

Type
To Do

Event Timeline

Confirmed here.
Seems to be a display refresh problem. If I select both layers and start moving bone again, cube will "jump" to bone's position.

IIRC, there was a similar report (only perhaps more complicated) related to changing layers and things not being up to date (since for efficient depsgraph updates, we currently skip hidden layers - it definitely helps ensure that heavy scenes can work faster when you hide a whole bunch of stuff).

Nevertheless, I've added this to the list of depgraph-related todo issues.

Joshua Leung (aligorith) closed this task as Archived.Nov 1 2013, 11:52 AM

It is true, the scenes works faster.

But, could you refresh the 3D view when a layer is activated? Not while this hidden, only when becomes visible.