Page MenuHome

C3D file import error
Closed, ResolvedPublic

Description

System Information
Windows 8 64-bit

Blender Version
Blender 2.69 r60995

Short description of error
Importing the attached C3D file gives me an error. Trying to fix the error makes the importer do nothing at all.

Exact steps for others to reproduce the error

  1. Enable the C3D importer addon
  2. Load the attached C3D file
  3. Check the console window

The error is:

Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender\2.69\scripts\addons\io_anim_c3d\__init__.py", line 221, in execute
    ms = import_c3d.read(self.properties.filepath, onlyHeader=True)
  File "C:\Program Files\Blender Foundation\Blender\2.69\scripts\addons\io_anim_c3d\import_c3d.py", line 266, in read
    return MarkerSet(filename, *a, **kw)
  File "C:\Program Files\Blender Foundation\Blender\2.69\scripts\addons\io_anim_c3d\import_c3d.py", line 88, in __init__
    self.identifyMarkerPrefix(stripPrefix)
  File "C:\Program Files\Blender Foundation\Blender\2.69\scripts\addons\io_anim_c3d\import_c3d.py", line 143, in identifyMarkerPrefix
    prefix = self.markerLabels[0]
IndexError: list index out of range

This error can be circumvented by prefixing the offending line with something like this:

if not self.markerLabels:
    # If there are no marker labels at all, there also is no common prefix.
    self.prefix = ''
    return

However, then the importer does nothing; no error, but also no imported data from the C3D file. Opening the C3D file in MotionBuilder shows that it contains moving motion capture markers, which should have been imported as keyframed empties. The exception shown above probably was caused by the same bug that prevents the data from getting imported.

The C3D file was obtained from Carnegie Mellon University: http://mocap.cs.cmu.edu/search.php?subjectnumber=2&trinum=1
That page also contains a AVI file that shows a virtual character following the motions of the mocap data.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) lowered the priority of this task from Needs Triage by Developer to Normal.

I fixed the problem (

), but for some reason I'm not able to push my commit:

$ git push
fatal: remote error: access denied or repository not exported: /blender-addons.git

I added my SSH key around 30 minutes ago, is there anything else that I need to do?

Ok, the problem was I had not setup the submodule to use git@git.blender.org:blender-addons.git. Now the bug fix has been pushed, please check that it works.
@My disabled brother (sybrenstuvel): you might find the CMU Mocap Browser addon interesting as well. It has not been accepted to be included in the release repository yet, but you can find it in contrib (and test builds).

Yep, the data can now be imported, so this bug is fixed!

Daniel M. Basso (dmbasso) closed this task as Resolved.Dec 12 2013, 6:46 PM