Bake Action operator doesn't bake animation for all objects.
Closed, ArchivedPublic

Description

System Information
Windows 7, Ge-Force GT 430

Blender Version
Broken: All versions

Short description of error
Like in title, It just doesn't work. It bake only the active one. It goes about object animation, not bones.
This should work, in operator GUI is "Only selected" option which means what it means. Really I'm a bit confused why this don't work.
Exact steps for others to reproduce the error
Anything. For example, make an f-curve modifier for 5 objects, and try to bake to keyframes at once for all object's. It wont work.

Details

Type
Bug
Kamil Adamski (adrian2608) updated the task description. (Show Details)
Kamil Adamski (adrian2608) raised the priority of this task from to Needs Triage.

"Only Selected" refers to bones here.
Baking actions for several objects is currently not implemented.

Hi,
Ou, that's very sad.
Any plans to implement it?

It shouldn't be hard to add, better ask aligorith.

Thank You, I just hope if this really isn't hard, that someone just add it, Because it's useful in many cases.

Brecht Van Lommel (brecht) triaged this task as Normal priority.Jan 27 2014, 2:28 PM
Sergey Sharybin (sergey) closed this task as Archived.Jun 3 2014, 10:07 AM

Strictly speaking it's not a bug but something which is good to have improved. Moving to TODO now http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Animation#Animation_System

Thanks for the report anyway!