Page MenuHome

blender crashes right after adding image texture to material in cycles
Closed, ResolvedPublic

Description

System Information
Vista 32
amd HD 4800series

Blender Version
Broken: 88843ca
Worked: 4b206af

Short description of error

blender crashes right after adding image texture to material ( in panel or in node editor)

it will crash only with image color space set to color works fine with non-color

Exact steps for others to reproduce the error

add image texture to material and press render

Event Timeline

Adrian Rutkowski (rrtk) set Type to Bug.
Adrian Rutkowski (rrtk) created this task.
Adrian Rutkowski (rrtk) raised the priority of this task from to Needs Triage by Developer.

Which CPU/processor model do you have? It's show in Control Panel > System I think.

Probably this is related to recent SSE optimizations which might not work on all processors.

Intel core2 Duo E8400 3.00 GHz but working on 32 vista

SIMD is disabled for x32 so this should not be a problem, but I admit I haven't really tested on x32 for ages...

Brecht Van Lommel (brecht) triaged this task as Normal priority.

I'll have to test this a 32 bit windows build then, not sure why this would be a problem since this is a modern CPU supporting enough SSE instructions.

Crash occurs in SSE code (either _mm_load_ps or cast to (__m128&) for unaligned data -- remember, that float3 and float4 are not aligned in win32). Assigned to myself.

Sv. Lockal (lockal) edited this Maniphest Task.Feb 10 2014, 2:25 PM
Sv. Lockal (lockal) closed this task as Resolved.Feb 10 2014, 2:25 PM

Closed by commit rB709652970498.

@Thomas Dinges (dingto): SSE kernels are enabled on win32 (except for SSE41 and AVX).

Note for myself to retest the next msvc 2008 build from buildserver: for now I have checked only with cmake and msvc 2012.

Sv. Lockal (lockal) reopened this task as Open.Feb 11 2014, 7:59 AM

MSVC 2008 builds still crash, investigating...

Sv. Lockal (lockal) closed this task as Resolved.Feb 11 2014, 2:57 PM

Closed by commit rBbd44dcb63229.

Now tested with an actual MSVC 2008 Express. This bug in MSVC 2008 in 32-bit mode is severe. If other __m128 loads from float3/float4 crash, it would be a good idea to disable SSE for MSVC 2008 in 32-bit mode.

Sv. Lockal (lockal) edited this Maniphest Task.May 12 2014, 4:39 PM