Page MenuHome

Motion in zero-velocity particle system
Closed, ArchivedPublic

Description

Windows 7 Professional 64-bit w Service Pack 1
Nvidia GeForce GTX 760

Blender 2.69 - r60995

There appears to be an instability in the generation of particles. It can be seen in the attached .blend file.

In this file I arranged the particle system so that a moving object would generate a trail of particles. Each single particle has zero velocity, thus the stream should be completely stationary.

If the file is loaded and played only one time through there is nothing strange to be seen. On the second and all subsequent times through the animation, there is unexpected movement that can be seen in some of the particles. The particles first appear in a position somewhat 'behind' where they should be and then slide into place over the next frame or two. This visible and unexpected motion also ends up in the rendered animation. If the file is reloaded, the animation will be displayed (again) correct the first time through and then incorrect every time thereafter.

This may (?) have something to do with the algorithm of the subframes system. I say that because as one increases the particles settings subframes the amount and visibility of the unexpected particle motion also increases.

A second effect I have noticed is that the trail of particle objects that are being left behind the emitter are not immediately 'solid' when they appear. It is almost as if they have a one frame 'fade-up' into existence so that instead of being the assigned yellow color at the instant of the creation they are first gray in color and only one frame later do they attain their full yellow color. I do not know if this 'fade-up' behavior is supposed to be normal or not (or is some sort of trick of the eye) and so have not listed it in a separate bug report.

Details

Type
Bug

Event Timeline

Ignatz (ignatz) added a project: BF Blender.
Ignatz (ignatz) set Type to Bug.
Ignatz (ignatz) added a subscriber: Ignatz (ignatz).
Ignatz (ignatz) created this task.
Ignatz (ignatz) raised the priority of this task from to Needs Triage by Developer.
Lukas Toenne (lukastoenne) triaged this task as Confirmed, Medium priority.

Looks like this is an artifact caused by the cache step feature. By default this only forces cache frame storage every 10 frames, which for some reason leads to interpolation errors in this case. Possibly the algorithm for detecting motion thresholds (which supposedly increases steps where needed) fails if the particle doesn't move at all ...

Simple solution is to lower the cache frame step to 1, which will store an accurate cache sample in every frame. Just note that it may increase the cache size drastically (only an issue for much larger particle numbers than in this file).

Sergey Sharybin (sergey) closed this task as Archived.Feb 17 2014, 9:45 AM
Sergey Sharybin (sergey) claimed this task.

Cache step of 10 frames works in simple cases but fails in more tricky setup. Don't think it's a bug, just a specific of current implementation. Added to the TODO list http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Tools#Particles so we could check on this later when improving the system.

Thanks for the report anyway!