Page MenuHome

Cycles render is not updating
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card
Ubuntu 13.10 64
Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)
2.69 official
Short description of error
hitting f12 starts cycles render, but doesnot update the renderwindow until tile is finished
Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps
any startup with cube will do...

Event Timeline

Karsten Bitter (tencars) raised the priority of this task from to Needs Triage by Developer.
Karsten Bitter (tencars) updated the task description. (Show Details)
Karsten Bitter (tencars) set Type to Bug.
Thomas Dinges (dingto) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Feb 19 2014, 12:47 AM

This is not enough information. I cannot reproduce such an error.
The currently rendered tiles update every second or so. Do you render with CPU or GPU?

Also please check with a build from builder.blender.org.

Hi Thomas,

I use GPU GFORCE 580 gtx on Ubuntu.
I used a "daily build" yesterday and today, both same problem. Not in regular 2.69.
Tomorrow I will test on similar System (Ubuntu as well) but with 560 gtx ti.

thank you for your great work!
KB

I just checked:

I used the build blender-2.69-688d098-linux-glibc211-x86_64.tar.bz2 from builder.blender.org.

regards,
kb

Ok,

I just tried on the same Hardware (GFORCE 580gtx) but the windows 7 64bit Operating system:
todays windows version of builder.blender.org same behaviour: GPU rendering does not update, cpu does.

best regards,
kb

Thomas Dinges (dingto) raised the priority of this task from Needs Information from User to Confirmed, Medium.Feb 19 2014, 1:46 AM

Thanks for the additional info. Can confirm it now with GPU.

It updates though, even before a tile is finished. If I render the bmw scene with 500 samples and 256x256 tile size, I get updates about every 150 samples. So I guess the updates are just not as frequent as before.

Guys, is that intentional?

@Thomas Dinges (dingto). This is a direct result of my last fix to device_cuda.

It can happen depending on the driver and the exact timing that almost all path_trace jobs get pushed into the Cuda event queue it seems.
I am not sure how often we want to update but I am pretty sure I can fix it to update more often.

Ill look into this tonight.

Thomas Dinges (dingto) closed this task as Resolved.Feb 19 2014, 6:36 PM

This is solved in newer builds. Thanks for the report.

Welcome,

Thank you for the excellent work to all you guys!

best regards,
kb