Page MenuHome

CTRL-Z and Undo button, broken Blender
Closed, ArchivedPublic

Description

System Information
Operating system: windows7
graphics card: nvidia geforce gtx 660 ti

Blender Version
Broken: 2.70 RC 19f7f9a,
Worked:

Short description of error
Ctrl+Z and undo button, broken blender in various screens working

Exact steps for others to reproduce the error
I can not attach. blend due to the weight of a video file (. avi, JPEG format, codec MJPG, Lossy compression mode)
I can not specify exactly all the steps, it was after a few hours. Roughly:
-load and cut video sequence editor
-load video in movie clip editor
-tracking camera motion for escene, solve camera, and setup tracking scene
-select new tracking object, process two marker track and Link Empty to Track
-add planes for mask objects in 3dview
-append model and rigging
-add and parent poly curve to Empty Track (object)
-add damped track constraint to poly curve (target Empty Track.001)
-delete nodes and prepare composite and render Layers
-processing renders
*everything works fine, but in the process, repeatedly, blender closes without comment system or other warning screen, using the Undo button and press Ctrl+Z Keys.

Details

Type
Bug

Event Timeline

abraham castilla (Abraham) created this task.
abraham castilla (Abraham) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

What you describe is an heavy work session… Saying it crash in that kind of case won’t help us troubleshooting the issue. If you can’t provide precise, simple steps to reproduce the crash, we can’t do much.

Also you say "it was after a few hours"… Did it happened once (or a few times), or is it an issue you can reproduce fairly easily? Because if it appears scarcely and randomly, it might be caused by pretty much anything (mem corruption, GPU issue, CPU issue, OS issue, Blender issue, whatever)…

sorry for the incomplete areas, it is the first time I report a bug with this interface, I had to put very clear and I preferred to leave it incomplete, to avoid confusion.
I just try:
  with version 2.69
in another pc with windows 8 and nvidia geforce 710M
no video files attached
and the bug persists.
I tried to repeat the steps, but as well there are many comets task.

I think I'd better upload the file for you can try

opens in the sequencer editor screen, this screen does not appear to be a problem.
but changing the movie clip editor or 3DView, if two or three steps are performed ...
to make multiple undo, blender closes.

I’m sorry, but I could not get your file to crash for me…

Can not reproduce the issue. Does it still happen with current builds from builder.blender.org?

tested with the 2.70 release:
the problem persists only with the Movie clip editor
not happening in the 3Dview

What are the exact steps reproducing the crash in MCE?

really are no steps, it is to perform various actions, no matter what.
I think it's very incomplete, difficult to define which step the error occurs, I make random steps and happens to make several Ctrl + Z. .. for example:
file-open, I'll MVE screen, move a track, and then Ctrl + Z performed several times ... there broken

I was able to crash the file a few times.
Open file.
On the VSE set the Time Cursor forward to a different position LMB 3 times.
Then press Ctrl+Z 3 times.

Windows 7 32 bit.
AMD Radeon HD 7310M.
Blender 2.70 win 32 bit 19e627c.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.Apr 24 2014, 8:45 AM

I'm unable to re-do the issue. @Thomas Dinges (dingto), mind checking on windows?

I can confirm the problem on Windows at least (Win7 64b, VS 1013, latest git tip)
It's the first time ever I look at Blender's source code, but it looks like it has nothing to do with videos or VSE.
One of the "Follow Track" constraints data was deleted and not set to NULL, and deleted again, thus crashing in BKE_constraint_free_data during the undo.

May it be related to the fact that there are 2 constraints with the same name ("Seguir rastro") ? I thought it should be "Seguir rastro" and "Seguir rastro.001" ?

@Thomas Dinges (dingto), can you test it on windows and if you'll find .blernd with exact steps which crashes for you re-assign to me? Backtraces could also help.

Spend 5 minutes on this, tried various actions, moved around objects, vse strips etc, then multiple Undo operations. No crash. Tested with 918f6a4 on Windows 7 x64.

The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

Bastien Montagne (mont29) closed this task as Archived.Oct 16 2014, 4:44 PM
Bastien Montagne (mont29) claimed this task.

Time to archive, thanks for the report anyway.