Page MenuHome

Wire Frame Operator
Closed, ResolvedPublic

Description

System Information
win7x64, lenovo y580

Blender Version
Broken: 2.70rc
Worked: 2.69

Short description of error
Wire Frame operator makes wire from selection but delates unselected mesh

Exact steps for others to reproduce the error
EditMode:: CTRL+F --> Wire Frame

Event Timeline

Czarek Kopias (kopias) set Type to Bug.
Czarek Kopias (kopias) created this task.
Czarek Kopias (kopias) raised the priority of this task from to Needs Triage by Developer.
Thomas Dinges (dingto) closed this task as Invalid.Mar 19 2014, 2:50 PM
Thomas Dinges (dingto) claimed this task.

That is not a bug but intentional behavior. If you execute the "Wire Frame "operator, you can change the settings in the F6 popup or in the Toolbar. You can disable the "Replace" option there, the unselected Geometry will then stay.

dingto: to my knowlage "replace" is also selection wise and means if you want to remove geometry that the wire frame was build on... just fire up 2.69 and give it a try

I can reproduce this problem. Note that there is the "Replace" option. If checked, in 2.69, it only replaced the face, but in 2.70, it also deletes unrelated vertices. This should not happen. Independent from the replace option, no vertex needs to be deleted at all. It only decides whether the existing face is to be deleted.

sorry dingto, you were faster. :)

Thomas Dinges (dingto) reopened this task as Open.Mar 19 2014, 3:07 PM

Looks like its a regression indeed - too late to make it into 2.70 though, think this can be fixed for 2.71 (or 2.70a)