Page MenuHome

Dyntopo snake hook and collapse edge broken
Closed, InvalidPublic

Description

System Information
Operating system and graphics card
xp sp3

Blender Version
Broken: blender-2.70 c359de2 win32
Worked: blender 2.69

Short description of error
when sculpting with Dyntopo , and the snake hook with Collapse Edge , the resulting geometry is completely broken

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  • use a subdivided cube ( a polysphere)
  • go to sculpt mode
  • enable Dyntopo , set the Detail to 10
  • change Subdivide Edges into Collapse Edges
  • select the Snake Hook brush and make a snake hook stroke

very bad result :
http://i.imgur.com/8qCv06p.jpg

In Blender 2.69 it worked perfectly under those conditions and same settings :
http://i.imgur.com/uSlnwa2.jpg

Details

Type
Bug

Event Timeline

Sanc Tuary (sanctuary) set Type to Bug.
Sanc Tuary (sanctuary) created this task.
Sanc Tuary (sanctuary) raised the priority of this task from to Needs Triage by Developer.
Sanc Tuary (sanctuary) closed this task as Invalid.Mar 23 2014, 10:50 PM
Sanc Tuary (sanctuary) claimed this task.

Update on this, thanks to Michalis pointing it to me on the Blenderartist dedicaced Dyntopo thread.

So it appears it is not a bug, but the "Collapse Short Edge" in Blender 2.69 is not called "Collapse Edge" as i thought in Blender 2.70

"Collapse Short Edge" from Blender 2.69 is now called "Collapse Subdivide" in Blender 2.70, as by using Collapse Subdivide i obtain now the same acceptable result as in Blender 2.69

So Blender 2.70 "Collapse Edge" seems to be a new setting and unlike the name suggest is not the same as all as Collapse short Edge was in 2.69.

I guess this can be closed now